summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-10-28 17:15:33 +0100
committerRemi Collet <remi@php.net>2024-10-28 17:15:33 +0100
commita006aa38e72de81aa03ad22a751f5d1518104d8d (patch)
treec63697467c9530af546a0e18be7210a8c038395a
parentb0fb81655c50e4900e2d93ef128156905bf28035 (diff)
fix patchHEADmaster
-rw-r--r--phpunit11-rpm.patch22
-rw-r--r--phpunit11.spec4
2 files changed, 20 insertions, 6 deletions
diff --git a/phpunit11-rpm.patch b/phpunit11-rpm.patch
index 90d2187..bcc35c6 100644
--- a/phpunit11-rpm.patch
+++ b/phpunit11-rpm.patch
@@ -51,7 +51,7 @@ diff -up ./phpunit.rpm ./phpunit
+}
diff -up ./src/TextUI/Command/Commands/VersionCheckCommand.php.rpm ./src/TextUI/Command/Commands/VersionCheckCommand.php
--- ./src/TextUI/Command/Commands/VersionCheckCommand.php.rpm 2024-10-28 16:32:22.000000000 +0100
-+++ ./src/TextUI/Command/Commands/VersionCheckCommand.php 2024-10-28 16:35:20.006475997 +0100
++++ ./src/TextUI/Command/Commands/VersionCheckCommand.php 2024-10-28 17:11:42.258839065 +0100
@@ -39,7 +39,7 @@ final readonly class VersionCheckCommand
assert($latestVersion !== false);
@@ -61,7 +61,12 @@ diff -up ./src/TextUI/Command/Commands/VersionCheckCommand.php.rpm ./src/TextUI/
assert($latestCompatibleVersion !== false);
-@@ -56,7 +56,7 @@ final readonly class VersionCheckCommand
+@@ -52,11 +52,11 @@ final readonly class VersionCheckCommand
+
+ if (!$notLatest && !$notLatestCompatible) {
+ return Result::from(
+- 'You are using the latest version of PHPUnit.' . PHP_EOL,
++ 'You are using the latest version of PHPUnit.' . PHP_EOL . PHP_EOL,
);
}
@@ -132,8 +137,17 @@ diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
if ($phar) {
diff -up ./tests/unit/TextUI/Command/Commands/VersionCheckCommandTest.php.rpm ./tests/unit/TextUI/Command/Commands/VersionCheckCommandTest.php
---- ./tests/unit/TextUI/Command/Commands/VersionCheckCommandTest.php.rpm 2024-10-28 16:40:07.648741770 +0100
-+++ ./tests/unit/TextUI/Command/Commands/VersionCheckCommandTest.php 2024-10-28 16:41:19.892571275 +0100
+--- ./tests/unit/TextUI/Command/Commands/VersionCheckCommandTest.php.rpm 2024-10-28 16:32:22.000000000 +0100
++++ ./tests/unit/TextUI/Command/Commands/VersionCheckCommandTest.php 2024-10-28 17:11:47.725052771 +0100
+@@ -28,7 +28,7 @@ final class VersionCheckCommandTest exte
+ {
+ return [
+ [
+- 'You are using the latest version of PHPUnit.' . PHP_EOL,
++ 'You are using the latest version of PHPUnit.' . PHP_EOL . PHP_EOL,
+ Result::SUCCESS,
+ 10,
+ '10.5.0',
@@ -36,8 +36,9 @@ final class VersionCheckCommandTest exte
'10.5.0',
],
diff --git a/phpunit11.spec b/phpunit11.spec
index 1ca42a8..398ec97 100644
--- a/phpunit11.spec
+++ b/phpunit11.spec
@@ -39,7 +39,7 @@
Name: %{pk_project}%{ver_major}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: The PHP Unit Testing framework version %{ver_major}
License: BSD-3-Clause
@@ -280,7 +280,7 @@ exit $ret
%changelog
-* Mon Oct 28 2024 Remi Collet <remi@remirepo.net> - 11.4.3-1
+* Mon Oct 28 2024 Remi Collet <remi@remirepo.net> - 11.4.3-2
- update to 11.4.3
* Mon Oct 21 2024 Remi Collet <remi@remirepo.net> - 11.4.2-1