summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-10-28 16:44:12 +0100
committerRemi Collet <remi@php.net>2024-10-28 16:44:12 +0100
commitb0fb81655c50e4900e2d93ef128156905bf28035 (patch)
tree95a80eb26032bbce8ce6e0ecaa1727a4843a856e
parenta234dce4857cd30aa038b5489a371b872238f289 (diff)
update to 11.4.3
-rw-r--r--phpunit11-rpm.patch62
-rw-r--r--phpunit11.spec9
2 files changed, 51 insertions, 20 deletions
diff --git a/phpunit11-rpm.patch b/phpunit11-rpm.patch
index 10b1cc7..90d2187 100644
--- a/phpunit11-rpm.patch
+++ b/phpunit11-rpm.patch
@@ -1,6 +1,6 @@
diff -up ./phpunit.rpm ./phpunit
---- ./phpunit.rpm 2024-08-02 08:11:38.000000000 +0200
-+++ ./phpunit 2024-08-02 08:12:01.101893244 +0200
+--- ./phpunit.rpm 2024-10-28 16:32:22.000000000 +0100
++++ ./phpunit 2024-10-28 16:32:27.795731213 +0100
@@ -46,27 +46,13 @@ if (isset($GLOBALS['_composer_autoload_p
define('PHPUNIT_COMPOSER_INSTALL', $GLOBALS['_composer_autoload_path']);
@@ -50,18 +50,18 @@ diff -up ./phpunit.rpm ./phpunit
+ PHPUnit\TextUI\Command::main();
+}
diff -up ./src/TextUI/Command/Commands/VersionCheckCommand.php.rpm ./src/TextUI/Command/Commands/VersionCheckCommand.php
---- ./src/TextUI/Command/Commands/VersionCheckCommand.php.rpm 2024-08-02 08:11:38.000000000 +0200
-+++ ./src/TextUI/Command/Commands/VersionCheckCommand.php 2024-08-02 08:13:24.053211780 +0200
-@@ -31,7 +31,7 @@ final readonly class VersionCheckCommand
+--- ./src/TextUI/Command/Commands/VersionCheckCommand.php.rpm 2024-10-28 16:32:22.000000000 +0100
++++ ./src/TextUI/Command/Commands/VersionCheckCommand.php 2024-10-28 16:35:20.006475997 +0100
+@@ -39,7 +39,7 @@ final readonly class VersionCheckCommand
assert($latestVersion !== false);
-- $latestCompatibleVersion = @file_get_contents('https://phar.phpunit.de/latest-version-of/phpunit-' . Version::majorVersionNumber());
-+ $latestCompatibleVersion = @file_get_contents('https://phar.phpunit.de/latest-version-of/phpunit-' . $major=Version::majorVersionNumber());
+- $latestCompatibleVersion = $this->downloader->download('https://phar.phpunit.de/latest-version-of/phpunit-' . $this->majorVersionNumber);
++ $latestCompatibleVersion = $this->downloader->download('https://phar.phpunit.de/latest-version-of/phpunit-' . $major=$this->majorVersionNumber);
- $notLatest = version_compare($latestVersion, Version::id(), '>');
- $notLatestCompatible = false;
-@@ -46,7 +46,7 @@ final readonly class VersionCheckCommand
+ assert($latestCompatibleVersion !== false);
+
+@@ -56,7 +56,7 @@ final readonly class VersionCheckCommand
);
}
@@ -70,15 +70,15 @@ diff -up ./src/TextUI/Command/Commands/VersionCheckCommand.php.rpm ./src/TextUI/
if ($notLatestCompatible) {
$buffer .= sprintf(
-@@ -54,6 +54,7 @@ final readonly class VersionCheckCommand
- Version::id(),
+@@ -64,6 +64,7 @@ final readonly class VersionCheckCommand
+ $this->versionId,
$latestCompatibleVersion,
);
+ $buffer .= sprintf('Try a system update for new phpunit%s package.' . PHP_EOL . PHP_EOL, $major);
}
if ($notLatest) {
-@@ -61,6 +62,9 @@ final readonly class VersionCheckCommand
+@@ -71,6 +72,9 @@ final readonly class VersionCheckCommand
'The latest version is PHPUnit %s.' . PHP_EOL,
$latestVersion,
);
@@ -89,8 +89,8 @@ diff -up ./src/TextUI/Command/Commands/VersionCheckCommand.php.rpm ./src/TextUI/
return Result::from($buffer, Result::FAILURE);
diff -up ./src/TextUI/Configuration/Xml/SchemaFinder.php.rpm ./src/TextUI/Configuration/Xml/SchemaFinder.php
---- ./src/TextUI/Configuration/Xml/SchemaFinder.php.rpm 2024-08-02 08:11:38.000000000 +0200
-+++ ./src/TextUI/Configuration/Xml/SchemaFinder.php 2024-08-02 08:12:01.102893284 +0200
+--- ./src/TextUI/Configuration/Xml/SchemaFinder.php.rpm 2024-10-28 16:32:22.000000000 +0100
++++ ./src/TextUI/Configuration/Xml/SchemaFinder.php 2024-10-28 16:32:27.795731213 +0100
@@ -77,6 +77,6 @@ final readonly class SchemaFinder
return __PHPUNIT_PHAR_ROOT__ . '/';
}
@@ -100,8 +100,8 @@ diff -up ./src/TextUI/Configuration/Xml/SchemaFinder.php.rpm ./src/TextUI/Config
}
}
diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
---- ./tests/bootstrap.php.rpm 2024-08-02 08:11:38.000000000 +0200
-+++ ./tests/bootstrap.php 2024-08-02 08:12:01.102893284 +0200
+--- ./tests/bootstrap.php.rpm 2024-10-28 16:32:22.000000000 +0100
++++ ./tests/bootstrap.php 2024-10-28 16:32:27.796731252 +0100
@@ -11,8 +11,8 @@ if (!defined('TEST_FILES_PATH')) {
define('TEST_FILES_PATH', __DIR__ . DIRECTORY_SEPARATOR . '_files' . DIRECTORY_SEPARATOR);
}
@@ -131,3 +131,31 @@ diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
}
if ($phar) {
+diff -up ./tests/unit/TextUI/Command/Commands/VersionCheckCommandTest.php.rpm ./tests/unit/TextUI/Command/Commands/VersionCheckCommandTest.php
+--- ./tests/unit/TextUI/Command/Commands/VersionCheckCommandTest.php.rpm 2024-10-28 16:40:07.648741770 +0100
++++ ./tests/unit/TextUI/Command/Commands/VersionCheckCommandTest.php 2024-10-28 16:41:19.892571275 +0100
+@@ -36,8 +36,9 @@ final class VersionCheckCommandTest exte
+ '10.5.0',
+ ],
+ [
+- 'You are not using the latest version of PHPUnit.' . PHP_EOL .
++ 'You are not using the latest version of PHPUnit.' . PHP_EOL . PHP_EOL .
+ 'The latest version compatible with PHPUnit 10.5.0 is PHPUnit 10.5.1.' . PHP_EOL .
++ 'Try a system update for new phpunit10 package.' . PHP_EOL . PHP_EOL .
+ 'The latest version is PHPUnit 10.5.1.' . PHP_EOL,
+ Result::FAILURE,
+ 10,
+@@ -46,9 +47,11 @@ final class VersionCheckCommandTest exte
+ '10.5.1',
+ ],
+ [
+- 'You are not using the latest version of PHPUnit.' . PHP_EOL .
++ 'You are not using the latest version of PHPUnit.' . PHP_EOL . PHP_EOL .
+ 'The latest version compatible with PHPUnit 10.5.0 is PHPUnit 10.5.1.' . PHP_EOL .
+- 'The latest version is PHPUnit 11.0.0.' . PHP_EOL,
++ 'Try a system update for new phpunit10 package.' . PHP_EOL . PHP_EOL .
++ 'The latest version is PHPUnit 11.0.0.' . PHP_EOL .
++ 'Try to install and use the phpunit11 command.' . PHP_EOL . PHP_EOL,
+ Result::FAILURE,
+ 10,
+ '10.5.0',
diff --git a/phpunit11.spec b/phpunit11.spec
index d9f3465..1ca42a8 100644
--- a/phpunit11.spec
+++ b/phpunit11.spec
@@ -20,8 +20,8 @@
%bcond_with defcmd
%endif
-%global gh_commit 1863643c3f04ad03dcb9c6996c294784cdda4805
-%global gh_date 2024-10-21
+%global gh_commit e8e8ed1854de5d36c088ec1833beae40d2dedd76
+%global gh_date 2024-10-28
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project phpunit
@@ -34,7 +34,7 @@
%global ver_major 11
%global ver_minor 4
-%global upstream_version 11.4.2
+%global upstream_version 11.4.3
#global upstream_prever dev
Name: %{pk_project}%{ver_major}
@@ -280,6 +280,9 @@ exit $ret
%changelog
+* Mon Oct 28 2024 Remi Collet <remi@remirepo.net> - 11.4.3-1
+- update to 11.4.3
+
* Mon Oct 21 2024 Remi Collet <remi@remirepo.net> - 11.4.2-1
- update to 11.4.2
- raise dependency on phpunit/php-code-coverage 11.0.7