summaryrefslogtreecommitdiffstats
path: root/php82.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php82.spec')
-rw-r--r--php82.spec65
1 files changed, 49 insertions, 16 deletions
diff --git a/php82.spec b/php82.spec
index 4d7a7e8..a2ad797 100644
--- a/php82.spec
+++ b/php82.spec
@@ -25,13 +25,15 @@
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
%ifarch aarch64
-%global oraclever 19.22
+%global oraclever 19.24
+%global oraclemax 20
%global oraclelib 19.1
-%global oracledir 19.22
+%global oracledir 19.24
%else
-%global oraclever 21.13
-%global oraclelib 21.1
-%global oracledir 21
+%global oraclever 23.5
+%global oraclemax 24
+%global oraclelib 23.1
+%global oracledir 23
%endif
# Build for LiteSpeed Web Server (LSAPI), you can disable using --without tests
@@ -120,13 +122,13 @@
%bcond_without libgd
%bcond_with zip
-%global upver 8.2.20
+%global upver 8.2.25
#global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 2%{?dist}
+Release: 1%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -172,7 +174,7 @@ Patch10: php-8.2.0-curl.patch
# Use system nikic/php-parser
Patch41: php-8.2.0-parser.patch
# use system tzdata
-Patch42: php-8.1.0-systzdata-v24.patch
+Patch42: php-8.2.23-systzdata-v24.patch
# See http://bugs.php.net/53436
Patch43: php-7.4.0-phpize.patch
# Use -lldap_r for OpenLDAP
@@ -181,13 +183,12 @@ Patch45: php-7.4.0-ldap_r.patch
Patch46: php-8.0.7-argon2.patch
# drop "Configure command" from phpinfo output
# and only use gcc (instead of full version)
-Patch47: php-8.1.0-phpinfo.patch
+Patch47: php-8.2.25-phpinfo.patch
# RC Patch
Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
-Patch100: php-gh14480.patch
# Security fixes (200+)
@@ -236,6 +237,9 @@ BuildRequires: libtool
BuildRequires: libtool-ltdl-devel
%if %{with dtrace}
BuildRequires: %{?dtsprefix}systemtap-sdt-devel
+%if 0%{?fedora} >= 41
+BuildRequires: %{?dtsprefix}systemtap-sdt-dtrace
+%endif
%endif
#BuildRequires: bison
#BuildRequires: re2c
@@ -762,7 +766,7 @@ BuildRequires: oracle-instantclient%{oraclever}-devel
Requires: libclntsh.so.%{oraclelib}
AutoReq: 0
%else
-BuildRequires: oracle-instantclient-devel >= %{oraclever}
+BuildRequires: (oracle-instantclient-devel >= %{oraclever} with oracle-instantclient-devel < %{oraclemax})
%endif
Requires: php-pdo%{?_isa} = %{version}-%{release}
Provides: php_database
@@ -1043,9 +1047,9 @@ Summary: Internationalization extension for PHP applications
# All files licensed under PHP version 3.01
License: PHP-3.01
Requires: php-common%{?_isa} = %{version}-%{release}
-BuildRequires: pkgconfig(icu-i18n) >= 73
-BuildRequires: pkgconfig(icu-io) >= 73
-BuildRequires: pkgconfig(icu-uc) >= 73
+BuildRequires: pkgconfig(icu-i18n) >= 74
+BuildRequires: pkgconfig(icu-io) >= 74
+BuildRequires: pkgconfig(icu-uc) >= 74
%if 0%{?rhel} == 7
Obsoletes: php53-intl, php53u-intl, php54-intl, php54w-intl, php55u-intl, php55w-intl, php56u-intl, php56w-intl
Obsoletes: php70u-intl, php70w-intl, php71u-intl, php71w-intl, php72u-intl, php72w-intl
@@ -1206,7 +1210,6 @@ in pure PHP.
%patch -P91 -p1 -b .remi-oci8
# upstream patches
-%patch -P100 -p1 -b .gh14480
# security patches
@@ -1449,7 +1452,7 @@ build --libdir=%{_libdir}/php \
--enable-pcntl \
--enable-opcache \
--enable-opcache-file \
- --enable-phpdbg \
+ --enable-phpdbg --enable-phpdbg-readline \
%if %{with imap}
--with-imap=shared --with-imap-ssl \
%endif
@@ -2202,6 +2205,36 @@ fi
%changelog
+* Wed Oct 23 2024 Remi Collet <remi@remirepo.net> - 8.2.25-1
+- Update to 8.2.25 - http://www.php.net/releases/8_2_25.php
+
+* Wed Oct 9 2024 Remi Collet <remi@remirepo.net> - 8.2.25~RC1-1
+- update to 8.2.25RC1
+
+* Wed Sep 25 2024 Remi Collet <remi@remirepo.net> - 8.2.24-1
+- Update to 8.2.24 - http://www.php.net/releases/8_2_24.php
+
+* Wed Sep 11 2024 Remi Collet <remi@remirepo.net> - 8.2.24~RC1-1
+- update to 8.2.24RC1
+- use ICU 74.2
+
+* Wed Aug 28 2024 Remi Collet <remi@remirepo.net> - 8.2.23-1
+- Update to 8.2.23 - http://www.php.net/releases/8_2_23.php
+
+* Wed Aug 14 2024 Remi Collet <remi@remirepo.net> - 8.2.23~RC1-1
+- update to 8.2.23RC1
+
+* Tue Jul 30 2024 Remi Collet <remi@remirepo.net> - 8.2.22-1
+- Update to 8.2.22 - http://www.php.net/releases/8_2_22.php
+- use oracle client library version 23.5 on x86_64
+
+* Wed Jul 17 2024 Remi Collet <remi@remirepo.net> - 8.2.22~RC1-1
+- update to 8.2.22RC1
+- use oracle client library version 23.4 on x86_64, 19.23 on aarch64
+
+* Tue Jul 2 2024 Remi Collet <remi@remirepo.net> - 8.2.21-1
+- Update to 8.2.21 - http://www.php.net/releases/8_2_21.php
+
* Fri Jun 7 2024 Remi Collet <remi@remirepo.net> - 8.2.20-2
- Fix GH-14480 Method visibility issue introduced in version 8.2.20