summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--failed.txt9
-rw-r--r--php-8.2.23-systzdata-v24.patch (renamed from php-8.1.0-systzdata-v24.patch)8
-rw-r--r--php-gh14480.patch99
-rw-r--r--php82.spec56
4 files changed, 47 insertions, 125 deletions
diff --git a/failed.txt b/failed.txt
index 5ced462..cedac56 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,22 +1,19 @@
-===== 8.2.20 (2024-05-06)
+===== 8.2.24RC1 (2024-09-12)
$ grep -ar 'Tests failed' /var/lib/mock/*/build.log
-/var/lib/mock/el7x82/build.log:Tests failed : 1
/var/lib/mock/el8a82/build.log:Tests failed : 0
/var/lib/mock/el8x82/build.log:Tests failed : 0
/var/lib/mock/el9a82/build.log:Tests failed : 0
/var/lib/mock/el9x82/build.log:Tests failed : 0
-/var/lib/mock/fc38x82/build.log:Tests failed : 0
/var/lib/mock/fc39a82/build.log:Tests failed : 0
/var/lib/mock/fc39x82/build.log:Tests failed : 0
/var/lib/mock/fc40a82/build.log:Tests failed : 0
/var/lib/mock/fc40x82/build.log:Tests failed : 0
+/var/lib/mock/fc41a82/build.log:Tests failed : 0
+/var/lib/mock/fc41x82/build.log:Tests failed : 0
-el7:
- 3 ext/openssl/tests/openssl_error_string_basic.phpt
-
1 proc_open give erratic test results :(
2 test issue
3 known issue
diff --git a/php-8.1.0-systzdata-v24.patch b/php-8.2.23-systzdata-v24.patch
index ca6e634..90bdc78 100644
--- a/php-8.1.0-systzdata-v24.patch
+++ b/php-8.2.23-systzdata-v24.patch
@@ -40,7 +40,7 @@ diff --git a/ext/date/config0.m4 b/ext/date/config0.m4
index 6b803bf33e..53c3cdb3f4 100644
--- a/ext/date/config0.m4
+++ b/ext/date/config0.m4
-@@ -4,6 +4,19 @@ AC_CHECK_HEADERS([io.h])
+@@ -4,6 +4,19 @@
dnl Check for strtoll, atoll
AC_CHECK_FUNCS(strtoll atoll)
@@ -57,9 +57,9 @@ index 6b803bf33e..53c3cdb3f4 100644
+ fi
+fi
+
- PHP_DATE_CFLAGS="-Wno-implicit-fallthrough -I@ext_builddir@/lib -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1 -DHAVE_TIMELIB_CONFIG_H=1"
- timelib_sources="lib/astro.c lib/dow.c lib/parse_date.c lib/parse_tz.c lib/parse_posix.c
- lib/timelib.c lib/tm2unixtime.c lib/unixtime2tm.c lib/parse_iso_intervals.c lib/interval.c"
+ AX_CHECK_COMPILE_FLAG([-Wno-implicit-fallthrough],
+ [PHP_DATE_CFLAGS="$PHP_DATE_CFLAGS -Wno-implicit-fallthrough"],,
+ [-Werror])
diff --git a/ext/date/lib/parse_tz.c b/ext/date/lib/parse_tz.c
index c7f93580d7..ec196a98b6 100644
--- a/ext/date/lib/parse_tz.c
diff --git a/php-gh14480.patch b/php-gh14480.patch
deleted file mode 100644
index 7920e17..0000000
--- a/php-gh14480.patch
+++ /dev/null
@@ -1,99 +0,0 @@
-From 86b93bc479477e6c0de6207bfe59c1e276dfdafb Mon Sep 17 00:00:00 2001
-From: Dmitry Stogov <dmitry@zend.com>
-Date: Wed, 5 Jun 2024 23:53:31 +0300
-Subject: [PATCH] Fix GH-14480: Method visibility issue introduced in version
- 8.3.8 (#14484)
-
----
- Zend/tests/gh14480.phpt | 60 +++++++++++++++++++++++++++++++++++++++++
- Zend/zend_inheritance.c | 8 +++---
- 2 files changed, 65 insertions(+), 3 deletions(-)
- create mode 100644 Zend/tests/gh14480.phpt
-
-diff --git a/Zend/tests/gh14480.phpt b/Zend/tests/gh14480.phpt
-new file mode 100644
-index 0000000000000..bab74785b6b23
---- /dev/null
-+++ b/Zend/tests/gh14480.phpt
-@@ -0,0 +1,60 @@
-+--TEST--
-+GH-14480: Method visibility issue
-+--FILE--
-+<?php
-+trait PropertyHelperTrait
-+{
-+ protected function splitPropertyParts(): void
-+ {
-+ echo "OK\n";
-+ }
-+}
-+
-+trait OrmPropertyHelperTrait
-+{
-+ abstract protected function splitPropertyParts(): void;
-+
-+ protected function addJoinsForNestedProperty(): void
-+ {
-+ $this->splitPropertyParts();
-+ }
-+}
-+
-+trait SearchFilterTrait
-+{
-+ use PropertyHelperTrait;
-+}
-+
-+abstract class AbstractFilter
-+{
-+ use OrmPropertyHelperTrait, PropertyHelperTrait;
-+
-+ public function apply(): void
-+ {
-+ $this->filterProperty();
-+ }
-+
-+ abstract protected function filterProperty(): void;
-+}
-+
-+class SearchFilter extends AbstractFilter
-+{
-+ use SearchFilterTrait;
-+ protected function filterProperty(): void
-+ {
-+ $this->addJoinsForNestedProperty();
-+ }
-+}
-+
-+class FilterExtension
-+{
-+ public function applyToCollection(): void
-+ {
-+ (new SearchFilter())->apply();
-+ }
-+}
-+
-+(new FilterExtension)->applyToCollection();
-+?>
-+--EXPECT--
-+OK
-diff --git a/Zend/zend_inheritance.c b/Zend/zend_inheritance.c
-index 8c7ea963891bf..2e9bf25b59c48 100644
---- a/Zend/zend_inheritance.c
-+++ b/Zend/zend_inheritance.c
-@@ -1933,11 +1933,13 @@ static void zend_add_trait_method(zend_class_entry *ce, zend_string *name, zend_
- if (check_inheritance) {
- /* Inherited members are overridden by members inserted by traits.
- * Check whether the trait method fulfills the inheritance requirements. */
-+ uint32_t flags = ZEND_INHERITANCE_CHECK_PROTO | ZEND_INHERITANCE_CHECK_VISIBILITY;
-+ if (!(existing_fn->common.scope->ce_flags & ZEND_ACC_TRAIT)) {
-+ flags |= ZEND_INHERITANCE_SET_CHILD_CHANGED |ZEND_INHERITANCE_SET_CHILD_PROTO;
-+ }
- do_inheritance_check_on_method(
- fn, fixup_trait_scope(fn, ce), existing_fn, fixup_trait_scope(existing_fn, ce),
-- ce, NULL,
-- ZEND_INHERITANCE_CHECK_PROTO | ZEND_INHERITANCE_CHECK_VISIBILITY |
-- ZEND_INHERITANCE_SET_CHILD_CHANGED| ZEND_INHERITANCE_SET_CHILD_PROTO);
-+ ce, NULL, flags);
- }
- }
- /* }}} */
diff --git a/php82.spec b/php82.spec
index 4d7a7e8..6bdf8e4 100644
--- a/php82.spec
+++ b/php82.spec
@@ -25,13 +25,15 @@
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
%ifarch aarch64
-%global oraclever 19.22
+%global oraclever 19.24
+%global oraclemax 20
%global oraclelib 19.1
-%global oracledir 19.22
+%global oracledir 19.24
%else
-%global oraclever 21.13
-%global oraclelib 21.1
-%global oracledir 21
+%global oraclever 23.5
+%global oraclemax 24
+%global oraclelib 23.1
+%global oracledir 23
%endif
# Build for LiteSpeed Web Server (LSAPI), you can disable using --without tests
@@ -120,13 +122,13 @@
%bcond_without libgd
%bcond_with zip
-%global upver 8.2.20
-#global rcver RC1
+%global upver 8.2.24
+%global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 2%{?dist}
+Release: 1%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -172,7 +174,7 @@ Patch10: php-8.2.0-curl.patch
# Use system nikic/php-parser
Patch41: php-8.2.0-parser.patch
# use system tzdata
-Patch42: php-8.1.0-systzdata-v24.patch
+Patch42: php-8.2.23-systzdata-v24.patch
# See http://bugs.php.net/53436
Patch43: php-7.4.0-phpize.patch
# Use -lldap_r for OpenLDAP
@@ -187,7 +189,6 @@ Patch47: php-8.1.0-phpinfo.patch
Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
-Patch100: php-gh14480.patch
# Security fixes (200+)
@@ -236,6 +237,9 @@ BuildRequires: libtool
BuildRequires: libtool-ltdl-devel
%if %{with dtrace}
BuildRequires: %{?dtsprefix}systemtap-sdt-devel
+%if 0%{?fedora} >= 41
+BuildRequires: %{?dtsprefix}systemtap-sdt-dtrace
+%endif
%endif
#BuildRequires: bison
#BuildRequires: re2c
@@ -762,7 +766,7 @@ BuildRequires: oracle-instantclient%{oraclever}-devel
Requires: libclntsh.so.%{oraclelib}
AutoReq: 0
%else
-BuildRequires: oracle-instantclient-devel >= %{oraclever}
+BuildRequires: (oracle-instantclient-devel >= %{oraclever} with oracle-instantclient-devel < %{oraclemax})
%endif
Requires: php-pdo%{?_isa} = %{version}-%{release}
Provides: php_database
@@ -1043,9 +1047,9 @@ Summary: Internationalization extension for PHP applications
# All files licensed under PHP version 3.01
License: PHP-3.01
Requires: php-common%{?_isa} = %{version}-%{release}
-BuildRequires: pkgconfig(icu-i18n) >= 73
-BuildRequires: pkgconfig(icu-io) >= 73
-BuildRequires: pkgconfig(icu-uc) >= 73
+BuildRequires: pkgconfig(icu-i18n) >= 74
+BuildRequires: pkgconfig(icu-io) >= 74
+BuildRequires: pkgconfig(icu-uc) >= 74
%if 0%{?rhel} == 7
Obsoletes: php53-intl, php53u-intl, php54-intl, php54w-intl, php55u-intl, php55w-intl, php56u-intl, php56w-intl
Obsoletes: php70u-intl, php70w-intl, php71u-intl, php71w-intl, php72u-intl, php72w-intl
@@ -1206,7 +1210,6 @@ in pure PHP.
%patch -P91 -p1 -b .remi-oci8
# upstream patches
-%patch -P100 -p1 -b .gh14480
# security patches
@@ -1449,7 +1452,7 @@ build --libdir=%{_libdir}/php \
--enable-pcntl \
--enable-opcache \
--enable-opcache-file \
- --enable-phpdbg \
+ --enable-phpdbg --enable-phpdbg-readline \
%if %{with imap}
--with-imap=shared --with-imap-ssl \
%endif
@@ -2202,6 +2205,27 @@ fi
%changelog
+* Wed Sep 11 2024 Remi Collet <remi@remirepo.net> - 8.2.24~RC1-1
+- update to 8.2.24RC1
+- use ICU 74.2
+
+* Wed Aug 28 2024 Remi Collet <remi@remirepo.net> - 8.2.23-1
+- Update to 8.2.23 - http://www.php.net/releases/8_2_23.php
+
+* Wed Aug 14 2024 Remi Collet <remi@remirepo.net> - 8.2.23~RC1-1
+- update to 8.2.23RC1
+
+* Tue Jul 30 2024 Remi Collet <remi@remirepo.net> - 8.2.22-1
+- Update to 8.2.22 - http://www.php.net/releases/8_2_22.php
+- use oracle client library version 23.5 on x86_64
+
+* Wed Jul 17 2024 Remi Collet <remi@remirepo.net> - 8.2.22~RC1-1
+- update to 8.2.22RC1
+- use oracle client library version 23.4 on x86_64, 19.23 on aarch64
+
+* Tue Jul 2 2024 Remi Collet <remi@remirepo.net> - 8.2.21-1
+- Update to 8.2.21 - http://www.php.net/releases/8_2_21.php
+
* Fri Jun 7 2024 Remi Collet <remi@remirepo.net> - 8.2.20-2
- Fix GH-14480 Method visibility issue introduced in version 8.2.20