summaryrefslogtreecommitdiffstats
path: root/makesrc.sh
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-01-16 09:17:26 +0100
committerRemi Collet <remi@php.net>2024-01-16 09:17:26 +0100
commit6521cc6d0b045bf7b29447c45c85f99c4762b7aa (patch)
treec323fdd206c71fe27aa8ea9473158174ed97723d /makesrc.sh
parent35586ce7e0710c7bcb3d475c0026eba5dfc24134 (diff)
update to 3.47.0
Diffstat (limited to 'makesrc.sh')
-rwxr-xr-xmakesrc.sh5
1 files changed, 3 insertions, 2 deletions
diff --git a/makesrc.sh b/makesrc.sh
index ef1af4d..0ddf2ba 100755
--- a/makesrc.sh
+++ b/makesrc.sh
@@ -1,6 +1,7 @@
#!/bin/bash
NAME=$(sed -n '/^Name:/{s/.* //;p}' *.spec)
+DATE=$(sed -n '/^%global gh_date/{s/.* //;p}' $NAME.spec)
OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
@@ -10,10 +11,10 @@ SHORT=${COMMIT:0:7}
if [ -f $NAME-$VERSION-$SHORT.tgz ]; then
echo "Skip $NAME-$VERSION-$SHORT.tgz"
else
- echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION, Commit=$COMMIT\n"
+ echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION, Commit=$COMMIT, Date=$DATE\n"
echo "Cloning..."
- git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+ git clone --shallow-since=$DATE https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT || exit1
echo "Getting commit..."
pushd $PROJECT-$COMMIT