diff options
author | Remi Collet <remi@remirepo.net> | 2024-01-16 09:17:26 +0100 |
---|---|---|
committer | Remi Collet <remi@php.net> | 2024-01-16 09:17:26 +0100 |
commit | 6521cc6d0b045bf7b29447c45c85f99c4762b7aa (patch) | |
tree | c323fdd206c71fe27aa8ea9473158174ed97723d | |
parent | 35586ce7e0710c7bcb3d475c0026eba5dfc24134 (diff) |
update to 3.47.0
-rwxr-xr-x | makesrc.sh | 5 | ||||
-rw-r--r-- | php-cs-fixer.spec | 11 |
2 files changed, 10 insertions, 6 deletions
@@ -1,6 +1,7 @@ #!/bin/bash NAME=$(sed -n '/^Name:/{s/.* //;p}' *.spec) +DATE=$(sed -n '/^%global gh_date/{s/.* //;p}' $NAME.spec) OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec) PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec) VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec) @@ -10,10 +11,10 @@ SHORT=${COMMIT:0:7} if [ -f $NAME-$VERSION-$SHORT.tgz ]; then echo "Skip $NAME-$VERSION-$SHORT.tgz" else - echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION, Commit=$COMMIT\n" + echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION, Commit=$COMMIT, Date=$DATE\n" echo "Cloning..." - git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT + git clone --shallow-since=$DATE https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT || exit1 echo "Getting commit..." pushd $PROJECT-$COMMIT diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec index da9d570..7751b61 100644 --- a/php-cs-fixer.spec +++ b/php-cs-fixer.spec @@ -10,15 +10,15 @@ # For compatibility with SCL %undefine __brp_mangle_shebangs -%global gh_commit be6831c9af1740470d2a773119b9273f8ac1c3d2 +%global gh_commit 184dd992fe49169a18300dba4435212db55220f7 %global gh_short %(c=%{gh_commit}; echo ${c:0:7}) -#global gh_date 20150717 +%global gh_date 2024-01-15 %global gh_owner FriendsOfPHP %global gh_project PHP-CS-Fixer Name: php-cs-fixer -Version: 3.46.0 -Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist} +Version: 3.47.0 +Release: 1%{?dist} Summary: PHP Coding Standards Fixer # see bundled list below, SPDX @@ -150,6 +150,9 @@ PHP_CS_FIXER_IGNORE_ENV=1 ./%{name} --version | grep %{version} %changelog +* Tue Jan 16 2024 Remi Collet <remi@remirepo.net> - 3.47.0-1 +- update to 3.47.0 + * Thu Jan 4 2024 Remi Collet <remi@remirepo.net> - 3.46.0-1 - update to 3.46.0 |