summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-12-02 13:44:28 +0100
committerRemi Collet <remi@php.net>2024-12-02 13:44:28 +0100
commita5e81db9036a5a899aef9aef5cfebe36006880ba (patch)
treea6bbbe1cf9a58ba66e37fb3e88d7982e82e95807
parent659db92d9352d60b4c56a902ebeeb4011f951b60 (diff)
EL-9.5: enable argon2 password hash, using OpenSSL 3.2
-rw-r--r--php.spec19
1 files changed, 16 insertions, 3 deletions
diff --git a/php.spec b/php.spec
index f71245c..dea891b 100644
--- a/php.spec
+++ b/php.spec
@@ -81,6 +81,12 @@
%bcond_without tzdata
# build with libiodbc instead of unixODBC
%bcond_with iodbc
+# OpenSSL2 with argon2
+%if 0%{?fedora} >= 40 || 0%{?rhel} >= 9
+%bcond_without openssl32
+%else
+%bcond_with openssl32
+%endif
%global gh_commit 9ce6980b4d93d539341807087abef9217cb81351
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
@@ -94,7 +100,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?rcver:~%{rcver}}%{?gh_date:.%{gh_date}}
-Release: 1%{?dist}
+Release: 2%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -173,8 +179,12 @@ BuildRequires: pam-devel
# to ensure we are using httpd with filesystem feature (see #1081453)
BuildRequires: httpd-filesystem
BuildRequires: %{?dtsprefix}libstdc++-devel
-# no pkgconfig to avoid compat-openssl10
+%if %{with openssl32}
+BuildRequires: pkgconfig(openssl) >= 3.2
+%else
+# no pkgconfig to avoid compat-openssl10/compat-openssl11
BuildRequires: openssl-devel >= 1.0.2
+%endif
BuildRequires: pkgconfig(sqlite3) >= 3.7.4
BuildRequires: pkgconfig(zlib) >= 1.2.0.4
BuildRequires: smtpdaemon
@@ -1051,7 +1061,7 @@ ln -sf ../configure
--with-exec-dir=%{_bindir} \
--without-gdbm \
--with-openssl \
-%if 0%{?fedora} >= 40 || 0%{?rhel} >= 10
+%if %{with openssl32}
--with-openssl-argon2 \
%endif
--with-system-ciphers \
@@ -1656,6 +1666,9 @@ fi
%changelog
+* Mon Dec 2 2024 Remi Collet <remi@remirepo.net> - 8.4.1-2
+- EL-9.5: enable argon2 password hash, using OpenSSL 3.2
+
* Wed Nov 20 2024 Remi Collet <remi@remirepo.net> - 8.4.1-1
- Update to 8.4.1 - http://www.php.net/releases/8_4_1.php