summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--failed.txt9
-rw-r--r--php-8.2.23-systzdata-v24.patch (renamed from php-8.1.0-systzdata-v24.patch)8
-rw-r--r--php-gh14480.patch99
-rw-r--r--php.spec57
4 files changed, 49 insertions, 124 deletions
diff --git a/failed.txt b/failed.txt
index 501e127..f94742a 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,20 +1,17 @@
-===== 8.2.20 (2024-05-06)
+===== 8.2.24 (2024-09-26)
$ grep -ar 'Tests failed' /var/lib/mock/*/build.log
-/var/lib/mock/scl82el7x/build.log:Tests failed : 1
/var/lib/mock/scl82el8a/build.log:Tests failed : 0
/var/lib/mock/scl82el8x/build.log:Tests failed : 0
/var/lib/mock/scl82el9a/build.log:Tests failed : 0
/var/lib/mock/scl82el9x/build.log:Tests failed : 0
-/var/lib/mock/scl82fc38x/build.log:Tests failed : 0
/var/lib/mock/scl82fc39a/build.log:Tests failed : 0
/var/lib/mock/scl82fc39x/build.log:Tests failed : 0
/var/lib/mock/scl82fc40a/build.log:Tests failed : 0
/var/lib/mock/scl82fc40x/build.log:Tests failed : 0
-
-el7:
- 3 ext/openssl/tests/openssl_error_string_basic.phpt
+/var/lib/mock/scl82fc41a/build.log:Tests failed : 0
+/var/lib/mock/scl82fc41x/build.log:Tests failed : 0
(1) proc_open give erratic test results :(
diff --git a/php-8.1.0-systzdata-v24.patch b/php-8.2.23-systzdata-v24.patch
index ca6e634..90bdc78 100644
--- a/php-8.1.0-systzdata-v24.patch
+++ b/php-8.2.23-systzdata-v24.patch
@@ -40,7 +40,7 @@ diff --git a/ext/date/config0.m4 b/ext/date/config0.m4
index 6b803bf33e..53c3cdb3f4 100644
--- a/ext/date/config0.m4
+++ b/ext/date/config0.m4
-@@ -4,6 +4,19 @@ AC_CHECK_HEADERS([io.h])
+@@ -4,6 +4,19 @@
dnl Check for strtoll, atoll
AC_CHECK_FUNCS(strtoll atoll)
@@ -57,9 +57,9 @@ index 6b803bf33e..53c3cdb3f4 100644
+ fi
+fi
+
- PHP_DATE_CFLAGS="-Wno-implicit-fallthrough -I@ext_builddir@/lib -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1 -DHAVE_TIMELIB_CONFIG_H=1"
- timelib_sources="lib/astro.c lib/dow.c lib/parse_date.c lib/parse_tz.c lib/parse_posix.c
- lib/timelib.c lib/tm2unixtime.c lib/unixtime2tm.c lib/parse_iso_intervals.c lib/interval.c"
+ AX_CHECK_COMPILE_FLAG([-Wno-implicit-fallthrough],
+ [PHP_DATE_CFLAGS="$PHP_DATE_CFLAGS -Wno-implicit-fallthrough"],,
+ [-Werror])
diff --git a/ext/date/lib/parse_tz.c b/ext/date/lib/parse_tz.c
index c7f93580d7..ec196a98b6 100644
--- a/ext/date/lib/parse_tz.c
diff --git a/php-gh14480.patch b/php-gh14480.patch
deleted file mode 100644
index 7920e17..0000000
--- a/php-gh14480.patch
+++ /dev/null
@@ -1,99 +0,0 @@
-From 86b93bc479477e6c0de6207bfe59c1e276dfdafb Mon Sep 17 00:00:00 2001
-From: Dmitry Stogov <dmitry@zend.com>
-Date: Wed, 5 Jun 2024 23:53:31 +0300
-Subject: [PATCH] Fix GH-14480: Method visibility issue introduced in version
- 8.3.8 (#14484)
-
----
- Zend/tests/gh14480.phpt | 60 +++++++++++++++++++++++++++++++++++++++++
- Zend/zend_inheritance.c | 8 +++---
- 2 files changed, 65 insertions(+), 3 deletions(-)
- create mode 100644 Zend/tests/gh14480.phpt
-
-diff --git a/Zend/tests/gh14480.phpt b/Zend/tests/gh14480.phpt
-new file mode 100644
-index 0000000000000..bab74785b6b23
---- /dev/null
-+++ b/Zend/tests/gh14480.phpt
-@@ -0,0 +1,60 @@
-+--TEST--
-+GH-14480: Method visibility issue
-+--FILE--
-+<?php
-+trait PropertyHelperTrait
-+{
-+ protected function splitPropertyParts(): void
-+ {
-+ echo "OK\n";
-+ }
-+}
-+
-+trait OrmPropertyHelperTrait
-+{
-+ abstract protected function splitPropertyParts(): void;
-+
-+ protected function addJoinsForNestedProperty(): void
-+ {
-+ $this->splitPropertyParts();
-+ }
-+}
-+
-+trait SearchFilterTrait
-+{
-+ use PropertyHelperTrait;
-+}
-+
-+abstract class AbstractFilter
-+{
-+ use OrmPropertyHelperTrait, PropertyHelperTrait;
-+
-+ public function apply(): void
-+ {
-+ $this->filterProperty();
-+ }
-+
-+ abstract protected function filterProperty(): void;
-+}
-+
-+class SearchFilter extends AbstractFilter
-+{
-+ use SearchFilterTrait;
-+ protected function filterProperty(): void
-+ {
-+ $this->addJoinsForNestedProperty();
-+ }
-+}
-+
-+class FilterExtension
-+{
-+ public function applyToCollection(): void
-+ {
-+ (new SearchFilter())->apply();
-+ }
-+}
-+
-+(new FilterExtension)->applyToCollection();
-+?>
-+--EXPECT--
-+OK
-diff --git a/Zend/zend_inheritance.c b/Zend/zend_inheritance.c
-index 8c7ea963891bf..2e9bf25b59c48 100644
---- a/Zend/zend_inheritance.c
-+++ b/Zend/zend_inheritance.c
-@@ -1933,11 +1933,13 @@ static void zend_add_trait_method(zend_class_entry *ce, zend_string *name, zend_
- if (check_inheritance) {
- /* Inherited members are overridden by members inserted by traits.
- * Check whether the trait method fulfills the inheritance requirements. */
-+ uint32_t flags = ZEND_INHERITANCE_CHECK_PROTO | ZEND_INHERITANCE_CHECK_VISIBILITY;
-+ if (!(existing_fn->common.scope->ce_flags & ZEND_ACC_TRAIT)) {
-+ flags |= ZEND_INHERITANCE_SET_CHILD_CHANGED |ZEND_INHERITANCE_SET_CHILD_PROTO;
-+ }
- do_inheritance_check_on_method(
- fn, fixup_trait_scope(fn, ce), existing_fn, fixup_trait_scope(existing_fn, ce),
-- ce, NULL,
-- ZEND_INHERITANCE_CHECK_PROTO | ZEND_INHERITANCE_CHECK_VISIBILITY |
-- ZEND_INHERITANCE_SET_CHILD_CHANGED| ZEND_INHERITANCE_SET_CHILD_PROTO);
-+ ce, NULL, flags);
- }
- }
- /* }}} */
diff --git a/php.spec b/php.spec
index ed95922..4738b0c 100644
--- a/php.spec
+++ b/php.spec
@@ -50,13 +50,15 @@
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
%ifarch aarch64
-%global oraclever 19.22
+%global oraclever 19.24
+%global oraclemax 20
%global oraclelib 19.1
-%global oracledir 19.22
+%global oracledir 19.24
%else
-%global oraclever 21.13
-%global oraclelib 21.1
-%global oracledir 21
+%global oraclever 23.5
+%global oraclemax 24
+%global oraclelib 23.1
+%global oracledir 23
%endif
# Build for LiteSpeed Web Server (LSAPI), you can disable using --without tests
@@ -129,13 +131,13 @@
#global gh_date 20220530
%global gh_owner php
%global gh_project php-src
-%global upver 8.2.20
+%global upver 8.2.24
#global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?rcver:~%{rcver}}%{?gh_date:.%{gh_date}}
-Release: 2%{?dist}
+Release: 1%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -183,7 +185,7 @@ Patch10: php-8.2.0-curl.patch
# Use system nikic/php-parser
Patch41: php-8.2.0-parser.patch
# use system tzdata
-Patch43: php-8.1.0-systzdata-v24.patch
+Patch43: php-8.2.23-systzdata-v24.patch
# See http://bugs.php.net/53436
Patch44: php-7.4.0-phpize.patch
# Use -lldap_r for OpenLDAP
@@ -198,7 +200,6 @@ Patch47: php-8.1.0-phpinfo.patch
Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
-Patch100: php-gh14480.patch
# Security fixes (200+)
@@ -244,6 +245,9 @@ BuildRequires: libtool
BuildRequires: libtool-ltdl-devel
%if %{with dtrace}
BuildRequires: %{?dtsprefix}systemtap-sdt-devel
+%if 0%{?fedora} >= 41
+BuildRequires: %{?dtsprefix}systemtap-sdt-dtrace
+%endif
%endif
%if 0%{?gh_date}
BuildRequires: bison
@@ -645,7 +649,7 @@ BuildRequires: oracle-instantclient%{oraclever}-devel
Requires: libclntsh.so.%{oraclelib}
AutoReq: 0
%else
-BuildRequires: oracle-instantclient-devel >= %{oraclever}
+BuildRequires: (oracle-instantclient-devel >= %{oraclever} with oracle-instantclient-devel < %{oraclemax})
%endif
Requires: %{?scl_prefix}php-pdo%{?_isa} = %{version}-%{release}
Provides: %{?scl_prefix}php_database
@@ -835,9 +839,9 @@ Summary: Internationalization extension for PHP applications
# All files licensed under PHP version 3.01
License: PHP-3.01
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
-BuildRequires: pkgconfig(icu-i18n) >= 73
-BuildRequires: pkgconfig(icu-io) >= 73
-BuildRequires: pkgconfig(icu-uc) >= 73
+BuildRequires: pkgconfig(icu-i18n) >= 74
+BuildRequires: pkgconfig(icu-io) >= 74
+BuildRequires: pkgconfig(icu-uc) >= 74
%description intl
The %{?scl_prefix}php-intl package contains a dynamic shared object that will add
@@ -983,7 +987,6 @@ sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
%patch -P91 -p1 -b .remi-oci8
# upstream patches
-%patch -P100 -p1 -b .gh14480
# security patches
@@ -1223,7 +1226,7 @@ build --libdir=%{_libdir}/php \
--enable-pcntl \
--enable-opcache \
--enable-opcache-file \
- --enable-phpdbg \
+ --enable-phpdbg --enable-phpdbg-readline \
%if %{with imap}
--with-imap=shared --with-imap-ssl \
%endif
@@ -1864,6 +1867,30 @@ fi
%changelog
+* Wed Sep 25 2024 Remi Collet <remi@remirepo.net> - 8.2.24-1
+- Update to 8.2.24 - http://www.php.net/releases/8_2_24.php
+
+* Wed Sep 11 2024 Remi Collet <remi@remirepo.net> - 8.2.24~RC1-1
+- update to 8.2.24RC1
+- use ICU 74.2
+
+* Wed Aug 28 2024 Remi Collet <remi@remirepo.net> - 8.2.23-1
+- Update to 8.2.23 - http://www.php.net/releases/8_2_23.php
+
+* Wed Aug 14 2024 Remi Collet <remi@remirepo.net> - 8.2.23~RC1-1
+- update to 8.2.23RC1
+
+* Tue Jul 30 2024 Remi Collet <remi@remirepo.net> - 8.2.22-1
+- Update to 8.2.22 - http://www.php.net/releases/8_2_22.php
+- use oracle client library version 23.5 on x86_64
+
+* Wed Jul 17 2024 Remi Collet <remi@remirepo.net> - 8.2.22~RC1-1
+- update to 8.2.22RC1
+- use oracle client library version 23.4 on x86_64, 19.23 on aarch64
+
+* Tue Jul 2 2024 Remi Collet <remi@remirepo.net> - 8.2.21-1
+- Update to 8.2.21 - http://www.php.net/releases/8_2_21.php
+
* Fri Jun 7 2024 Remi Collet <remi@remirepo.net> - 8.2.20-2
- Fix GH-14480 Method visibility issue introduced in version 8.2.20