summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--failed.txt8
-rw-r--r--php-8.1.32-pcretests.patch43
-rw-r--r--php.spec26
3 files changed, 57 insertions, 20 deletions
diff --git a/failed.txt b/failed.txt
index 38e75e2..84fbd10 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,4 +1,4 @@
-===== 8.1.31 (2024-11-20)
+===== 8.1.32 (2025-03-13)
$ grep -ar 'Tests failed' /var/lib/mock/*/build.log
@@ -8,15 +8,15 @@ $ grep -ar 'Tests failed' /var/lib/mock/*/build.log
/var/lib/mock/scl81el9x/build.log:Tests failed : 0
/var/lib/mock/scl81el10a/build.log:Tests failed : 1
/var/lib/mock/scl81el10x/build.log:Tests failed : 1
-/var/lib/mock/scl81fc39a/build.log:Tests failed : 0
-/var/lib/mock/scl81fc39x/build.log:Tests failed : 0
/var/lib/mock/scl81fc40a/build.log:Tests failed : 1
/var/lib/mock/scl81fc40x/build.log:Tests failed : 1
/var/lib/mock/scl81fc41a/build.log:Tests failed : 1
/var/lib/mock/scl81fc41x/build.log:Tests failed : 1
+/var/lib/mock/scl81fc42a/build.log:Tests failed : 1
+/var/lib/mock/scl81fc42x/build.log:Tests failed : 1
-fc40, fc41, el10:
+fc*, el10:
3 openssl_x509_parse() tests [ext/openssl/tests/openssl_x509_parse_basic.phpt]
diff --git a/php-8.1.32-pcretests.patch b/php-8.1.32-pcretests.patch
new file mode 100644
index 0000000..c226661
--- /dev/null
+++ b/php-8.1.32-pcretests.patch
@@ -0,0 +1,43 @@
+From c3150fcc89825f50d476b1b1971870aeb71f167d Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Wed, 12 Mar 2025 07:48:05 +0100
+Subject: [PATCH 1/2] Relax test expectation for pcre2lib 10.45 Using
+ e92848789acd8aa5cf32fedb519ba9378ac64e02
+
+---
+ ext/pcre/tests/bug75457.phpt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ext/pcre/tests/bug75457.phpt b/ext/pcre/tests/bug75457.phpt
+index ee5ab162f8a6c..87dc12a1ad056 100644
+--- a/ext/pcre/tests/bug75457.phpt
++++ b/ext/pcre/tests/bug75457.phpt
+@@ -6,5 +6,5 @@ $pattern = "/(((?(?C)0?=))(?!()0|.(?0)0)())/";
+ var_dump(preg_match($pattern, "hello"));
+ ?>
+ --EXPECTF--
+-Warning: preg_match(): Compilation failed: assertion expected after (?( or (?(?C) at offset 8 in %sbug75457.php on line %d
++Warning: preg_match(): Compilation failed: %r(atomic|)%r assertion expected after (?( or (?(?C) at offset 8 in %sbug75457.php on line %d
+ bool(false)
+
+From 126095700a02b9aa1f33764a63c93a70e8373ad8 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@famillecollet.com>
+Date: Wed, 12 Mar 2025 09:36:33 +0100
+Subject: [PATCH 2/2] Update ext/pcre/tests/bug75457.phpt
+
+Co-authored-by: Niels Dossche <7771979+nielsdos@users.noreply.github.com>
+---
+ ext/pcre/tests/bug75457.phpt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ext/pcre/tests/bug75457.phpt b/ext/pcre/tests/bug75457.phpt
+index 87dc12a1ad056..1401b25ff6fb7 100644
+--- a/ext/pcre/tests/bug75457.phpt
++++ b/ext/pcre/tests/bug75457.phpt
+@@ -6,5 +6,5 @@ $pattern = "/(((?(?C)0?=))(?!()0|.(?0)0)())/";
+ var_dump(preg_match($pattern, "hello"));
+ ?>
+ --EXPECTF--
+-Warning: preg_match(): Compilation failed: %r(atomic|)%r assertion expected after (?( or (?(?C) at offset 8 in %sbug75457.php on line %d
++Warning: preg_match(): Compilation failed:%r( atomic|)%r assertion expected after (?( or (?(?C) at offset 8 in %sbug75457.php on line %d
+ bool(false)
diff --git a/php.spec b/php.spec
index 2264723..b5e51a1 100644
--- a/php.spec
+++ b/php.spec
@@ -49,17 +49,10 @@
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
-%ifarch aarch64
-%global oraclever 19.25
-%global oraclemax 20
-%global oraclelib 19.1
-%global oracledir 19.25
-%else
%global oraclever 23.7
%global oraclemax 24
%global oraclelib 23.1
%global oracledir 23
-%endif
# Build for LiteSpeed Web Server (LSAPI), you can disable using --without tests
%bcond_without lsws
@@ -135,12 +128,12 @@
#global gh_date 20210809
%global gh_owner php
%global gh_project php-src
-%global upver 8.1.31
+%global upver 8.1.32
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?rcver:~%{rcver}}%{?gh_date:.%{gh_date}}
-Release: 2%{?dist}
+Release: 1%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -209,7 +202,10 @@ Patch91: php-7.2.0-oci8conf.patch
# Fixes for tests (300+)
# Factory is droped from system tzdata
Patch300: php-7.4.0-datetests.patch
+# for zlib-ng
Patch301: php-8.1.27-zlib-tests.patch
+# for pcre2 10.45
+Patch302: php-8.1.32-pcretests.patch
# WIP
@@ -645,14 +641,7 @@ License.
Summary: A module for PHP applications that use OCI8 databases
# All files licensed under PHP version 3.01
License: PHP
-%ifarch aarch64
-BuildRequires: oracle-instantclient%{oraclever}-devel
-# Should requires libclntsh.so.19.1()(aarch-64), but it's not provided by Oracle RPM.
-Requires: libclntsh.so.%{oraclelib}
-AutoReq: 0
-%else
BuildRequires: (oracle-instantclient-devel >= %{oraclever} with oracle-instantclient-devel < %{oraclemax})
-%endif
Requires: %{?scl_prefix}php-pdo%{?_isa} = %{version}-%{release}
Provides: %{?scl_prefix}php_database
Provides: %{?scl_prefix}php-pdo_oci
@@ -993,6 +982,7 @@ sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
# Fixes for tests
%patch -P300 -p1 -b .datetests
%patch -P301 -p1 -b .zlibng
+%patch -P302 -p1 -b .pcretests
# WIP patch
@@ -1870,6 +1860,10 @@ fi
%changelog
+* Wed Mar 12 2025 Remi Collet <remi@remirepo.net> - 8.1.32-1
+- Update to 8.1.32 - http://www.php.net/releases/8_1_32.php
+- use oracle client library version 23.7 on x86_64 and arm64
+
* Thu Feb 13 2025 Remi Collet <remi@remirepo.net> - 8.1.31-2
- backport fix for ICU 74+