summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json5
-rw-r--r--plugins/jqueryui/composer.json2
-rw-r--r--plugins/reconnect/composer.json2
-rw-r--r--roundcubemail-1.6-confpath.patch32
-rw-r--r--roundcubemail.spec58
5 files changed, 26 insertions, 73 deletions
diff --git a/composer.json b/composer.json
index 85a5491..8d3f7ec 100644
--- a/composer.json
+++ b/composer.json
@@ -21,10 +21,7 @@
"masterminds/html5": "~2.7.0",
"bacon/bacon-qr-code": "^2.0.0",
"guzzlehttp/guzzle": "^7.3.0",
- "kolab/net_ldap3": "~1.1.1"
- },
- "require-dev": {
- "phpunit/phpunit": "^9"
+ "kolab/net_ldap3": "~1.1.4"
},
"suggest": {
"bjeavons/zxcvbn-php": "^1.0 required for Zxcvbn password strength driver"
diff --git a/plugins/jqueryui/composer.json b/plugins/jqueryui/composer.json
index 10cf660..97ed998 100644
--- a/plugins/jqueryui/composer.json
+++ b/plugins/jqueryui/composer.json
@@ -3,7 +3,7 @@
"type": "roundcube-plugin",
"description": "Plugin adds the complete jQuery-UI library including the smoothness theme to Roundcube. This allows other plugins to use jQuery-UI without having to load their own version. The benefit of using one central jQuery-UI is that we wont run into problems of conflicting jQuery libraries being loaded. All plugins that want to use jQuery-UI should use this plugin as a requirement.",
"license": "GPL-3.0-or-later",
- "version": "1.13.1",
+ "version": "1.13.2",
"authors": [
{
"name": "Thomas Bruederli",
diff --git a/plugins/reconnect/composer.json b/plugins/reconnect/composer.json
index 23faaa6..c7a990b 100644
--- a/plugins/reconnect/composer.json
+++ b/plugins/reconnect/composer.json
@@ -3,7 +3,7 @@
"type": "roundcube-plugin",
"description": "Reconnects to server for several attempts.",
"license": "GPL-3.0-or-later",
- "version": "0.1",
+ "version": "0.2",
"authors": [
{
"name": "Sandro Knauß",
diff --git a/roundcubemail-1.6-confpath.patch b/roundcubemail-1.6-confpath.patch
index 0b372ee..d9d50e3 100644
--- a/roundcubemail-1.6-confpath.patch
+++ b/roundcubemail-1.6-confpath.patch
@@ -1,7 +1,7 @@
-diff -up ./config/defaults.inc.php.rpm ./config/defaults.inc.php
---- ./config/defaults.inc.php.rpm 2022-03-06 21:32:08.000000000 +0100
-+++ ./config/defaults.inc.php 2022-03-07 11:48:41.252956405 +0100
-@@ -525,11 +525,11 @@ $config['user_aliases'] = false;
+diff -up roundcubemail-1.6.10/config/defaults.inc.php.rpm roundcubemail-1.6.10/config/defaults.inc.php
+--- roundcubemail-1.6.10/config/defaults.inc.php.rpm 2025-02-08 09:47:42.000000000 +0100
++++ roundcubemail-1.6.10/config/defaults.inc.php 2025-02-09 08:05:33.268275358 +0100
+@@ -540,11 +540,11 @@ $config['user_aliases'] = false;
// use this folder to store log files
// must be writeable for the user who runs PHP process (Apache user if mod_php is being used)
// This is used by the 'file' log driver.
@@ -15,16 +15,16 @@ diff -up ./config/defaults.inc.php.rpm ./config/defaults.inc.php
// expire files in temp_dir after 48 hours
// possible units: s, m, h, d, w
-@@ -763,7 +763,7 @@ $config['mime_magic'] = null;
+@@ -778,7 +778,7 @@ $config['mime_magic'] = null;
// This is used to derive mime-types from the filename extension or vice versa.
// Such a file is usually part of the apache webserver. If you don't find a file named mime.types on your system,
- // download it from http://svn.apache.org/repos/asf/httpd/httpd/trunk/docs/conf/mime.types
+ // download it from https://svn.apache.org/repos/asf/httpd/httpd/trunk/docs/conf/mime.types
-$config['mime_types'] = null;
+$config['mime_types'] = '/etc/mime.types';
// path to imagemagick identify binary (if not set we'll use Imagick or GD extensions)
$config['im_identify_path'] = null;
-@@ -1452,3 +1452,7 @@ $config['message_show_email'] = false;
+@@ -1480,3 +1480,7 @@ $config['message_show_email'] = false;
// 0 - Reply-All always
// 1 - Reply-List if mailing list is detected
$config['reply_all_mode'] = 0;
@@ -32,9 +32,9 @@ diff -up ./config/defaults.inc.php.rpm ./config/defaults.inc.php
+// Keys directory for all users.
+// Must be writeable by PHP process, and not in the web server document root
+$config['enigma_pgp_homedir'] = '/var/lib/roundcubemail/enigma';
-diff -up ./plugins/enigma/config.inc.php.dist.rpm ./plugins/enigma/config.inc.php.dist
---- ./plugins/enigma/config.inc.php.dist.rpm 2022-03-06 21:32:08.000000000 +0100
-+++ ./plugins/enigma/config.inc.php.dist 2022-03-07 11:48:41.252956405 +0100
+diff -up roundcubemail-1.6.10/plugins/enigma/config.inc.php.dist.rpm roundcubemail-1.6.10/plugins/enigma/config.inc.php.dist
+--- roundcubemail-1.6.10/plugins/enigma/config.inc.php.dist.rpm 2025-02-08 09:47:42.000000000 +0100
++++ roundcubemail-1.6.10/plugins/enigma/config.inc.php.dist 2025-02-09 08:04:38.723191340 +0100
@@ -12,10 +12,6 @@ $config['enigma_smime_driver'] = 'phpssl
// Enables logging of enigma operations (including Crypt_GPG debug info)
$config['enigma_debug'] = false;
@@ -46,9 +46,9 @@ diff -up ./plugins/enigma/config.inc.php.dist.rpm ./plugins/enigma/config.inc.ph
// Location of gpg binary. By default it will be auto-detected.
// This is also a way to force gpg2 use if there are both 1.x and 2.x on the system.
$config['enigma_pgp_binary'] = '';
-diff -up ./program/include/iniset.php.rpm ./program/include/iniset.php
---- ./program/include/iniset.php.rpm 2022-03-06 21:32:09.000000000 +0100
-+++ ./program/include/iniset.php 2022-03-07 11:49:54.668718920 +0100
+diff -up roundcubemail-1.6.10/program/include/iniset.php.rpm roundcubemail-1.6.10/program/include/iniset.php
+--- roundcubemail-1.6.10/program/include/iniset.php.rpm 2025-02-08 09:47:42.000000000 +0100
++++ roundcubemail-1.6.10/program/include/iniset.php 2025-02-09 08:04:38.723191340 +0100
@@ -32,7 +32,7 @@ if (!defined('INSTALL_PATH')) {
}
@@ -67,9 +67,9 @@ diff -up ./program/include/iniset.php.rpm ./program/include/iniset.php
// Show basic error message on fatal PHP error
register_shutdown_function('rcmail_error_handler');
-diff -up ./program/lib/Roundcube/bootstrap.php.rpm ./program/lib/Roundcube/bootstrap.php
---- ./program/lib/Roundcube/bootstrap.php.rpm 2022-03-06 21:32:09.000000000 +0100
-+++ ./program/lib/Roundcube/bootstrap.php 2022-03-07 11:48:41.252956405 +0100
+diff -up roundcubemail-1.6.10/program/lib/Roundcube/bootstrap.php.rpm roundcubemail-1.6.10/program/lib/Roundcube/bootstrap.php
+--- roundcubemail-1.6.10/program/lib/Roundcube/bootstrap.php.rpm 2025-02-08 09:47:42.000000000 +0100
++++ roundcubemail-1.6.10/program/lib/Roundcube/bootstrap.php 2025-02-09 08:04:38.723191340 +0100
@@ -71,7 +71,7 @@ if (!defined('RCUBE_INSTALL_PATH')) {
}
diff --git a/roundcubemail.spec b/roundcubemail.spec
index ec548ce..4b4475f 100644
--- a/roundcubemail.spec
+++ b/roundcubemail.spec
@@ -9,11 +9,10 @@
#
%bcond_with internet
-%bcond_with generators
# support for apache / nginx / php-fpm
%global with_phpfpm 1
-%global upstream_version 1.6.9
+%global upstream_version 1.6.10
#global upstream_prever rc
%global roundcubedir %{_datadir}/roundcubemail
@@ -56,9 +55,7 @@ BuildRequires: gnupg2
BuildRequires: php(language) >= 7.3
# For test
BuildRequires: php-cli
-%if %{with generators}
BuildRequires: composer-generators
-%endif
%if %{with_phpfpm}
Requires: webserver
@@ -128,54 +125,14 @@ Provides: bundled(js-lessjs) = 3.13.0
Provides: bundled(js-publickey) = 0e011cb1
# License LGPL
Provides: bundled(js-openpgp) = 5.0.0
-Provides: bundled(js-tinymce) = 5.8.2
+Provides: bundled(js-tinymce) = 5.10.9
# License MIT
Provides: bundled(js-bootstrap) = 4.5.3
Provides: bundled(js-codemirror) = 5.58.3
Provides: bundled(js-jquery) = 3.5.1
Provides: bundled(js-jstimezonedetect) = 1.0.7
# License Unkown
-Provides: bundled(js-tinymce-langs) = 5.8.2
-
-%if %{without generators}
-# Bundled PHP libraries
-# see vendor/composer/installed.json
-# License BSD
-Provides: bundled(php-pear-auth-sasl) = v1.1.0
-# License BSD-2-Clause
-Provides: bundled(php-bacon-bacon-qr-code) = 2.0.8
-Provides: bundled(php-dasprid-enum) = 1.0.6
-Provides: bundled(php-pear-console-getopt) = v1.4.3
-Provides: bundled(php-pear-net-sieve) = 1.4.7
-Provides: bundled(php-pear-net-smtp) = 1.10.1
-Provides: bundled(php-pear-pear-exception) = v1.0.2
-# License BSD-3-Clause
-Provides: bundled(php-pear-mail-mime) = 1.10.12
-Provides: bundled(php-pear-pear-core-minimal) = v1.10.15
-# License GPL-2.0
-Provides: bundled(php-roundcube-rtf-html-php) = v2.2
-# License GPL-3.0+
-Provides: bundled(php-kolab-net-ldap3) = v1.1.5
-# License GPL-3.0-or-later
-Provides: bundled(php-roundcube-plugin-installer) = 0.3.8
-# License LGPL-2.1
-Provides: bundled(php-pear-crypt-gpg) = v1.6.9
-# License LGPL-3.0
-Provides: bundled(php-pear-net-ldap2) = v2.3.0
-# License MIT
-Provides: bundled(php-guzzlehttp-guzzle) = 7.9.2
-Provides: bundled(php-guzzlehttp-promises) = 2.0.3
-Provides: bundled(php-guzzlehttp-psr7) = 2.7.0
-Provides: bundled(php-masterminds-html5) = 2.7.6
-Provides: bundled(php-pear-console-commandline) = v1.2.6
-Provides: bundled(php-psr-http-client) = 1.0.3
-Provides: bundled(php-psr-http-factory) = 1.1.0
-Provides: bundled(php-psr-http-message) = 2.0
-Provides: bundled(php-ralouphie-getallheaders) = 3.0.3
-Provides: bundled(php-symfony-deprecation-contracts) = v2.5.3
-# License PHP License
-Provides: bundled(php-pear-net-socket) = v1.2.2
-%endif
+Provides: bundled(js-tinymce-langs) = 5.10.9
%description
@@ -195,11 +152,6 @@ CSS 2.
%setup -q -n roundcubemail-%{upstream_version}%{?upstream_prever:-%{upstream_prever}}
%patch -P1 -p1 -b .rpm
-%if %{without generators}
-: PHP bundled libraries
-php %{SOURCE5} vendor/composer/installed.json
-%endif
-
%if %{with internet}
: JS bundled libraries
php %{SOURCE5} https://raw.githubusercontent.com/roundcube/roundcubemail/%{upstream_version}%{?upstream_prever:-%{upstream_prever}}/jsdeps.json
@@ -329,6 +281,10 @@ fi
%changelog
+* Sun Feb 9 2025 Remi Collet <remi@remirepo.net> - 1.6.10-1
+- update to 1.6.10
+- always use composer-generators
+
* Mon Sep 2 2024 Remi Collet <remi@remirepo.net> - 1.6.9-1
- update to 1.6.9