summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-12-24 09:14:40 +0100
committerRemi Collet <remi@php.net>2024-12-24 09:14:40 +0100
commite9fd349f99a697a6d8dac01d556ca99ca2c6e560 (patch)
tree158f40236d6b5ae6fa41c9fad1f8bcd531f5ccc1
parentca58ee3a03e5d31fa3decaf06a051b50b125d49d (diff)
update to 0.3.0
-rw-r--r--composer.json25
-rw-r--r--installed.json250
-rw-r--r--pie.spec24
3 files changed, 159 insertions, 140 deletions
diff --git a/composer.json b/composer.json
index 41a3452..7a8a882 100644
--- a/composer.json
+++ b/composer.json
@@ -29,20 +29,23 @@
"require": {
"php": "8.1.*||8.2.*||8.3.*||8.4.*",
"ext-zip": "*",
- "composer/composer": "^2.8.2",
- "illuminate/container": "^10.47",
- "psr/http-message": "^2.0",
- "symfony/console": "^6.4",
- "symfony/process": "^6.4",
+ "composer/composer": "^2.8.4",
+ "composer/pcre": "^3.3.2",
+ "composer/semver": "^3.4.3",
+ "fidry/cpu-core-counter": "^1.2",
+ "illuminate/container": "^10.48.25",
+ "psr/container": "^2.0.2",
+ "symfony/console": "^6.4.15",
+ "symfony/process": "^6.4.15",
"webmozart/assert": "^1.11"
},
"require-dev": {
- "behat/behat": "^3.14",
+ "behat/behat": "^3.17",
"doctrine/coding-standard": "^12.0",
"php-standard-library/psalm-plugin": "^2.3",
- "phpunit/phpunit": "^10.5",
- "psalm/plugin-phpunit": "^0.18.4",
- "vimeo/psalm": "^5.22"
+ "phpunit/phpunit": "^10.5.39",
+ "psalm/plugin-phpunit": "^0.19.0",
+ "vimeo/psalm": "^5.26.1"
},
"replace": {
"symfony/polyfill-php81": "*",
@@ -52,8 +55,12 @@
"config": {
"sort-packages": true,
"preferred-install": "dist",
+ "bump-after-update": true,
"allow-plugins": {
"dealerdirect/phpcodesniffer-composer-installer": true
+ },
+ "platform": {
+ "php": "8.1.0"
}
}
}
diff --git a/installed.json b/installed.json
index 07b1017..77cb6a7 100644
--- a/installed.json
+++ b/installed.json
@@ -2,17 +2,17 @@
"packages": [
{
"name": "composer/ca-bundle",
- "version": "1.5.3",
- "version_normalized": "1.5.3.0",
+ "version": "1.5.4",
+ "version_normalized": "1.5.4.0",
"source": {
"type": "git",
"url": "https://github.com/composer/ca-bundle.git",
- "reference": "3b1fc3f0be055baa7c6258b1467849c3e8204eb2"
+ "reference": "bc0593537a463e55cadf45fd938d23b75095b7e1"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/composer/ca-bundle/zipball/3b1fc3f0be055baa7c6258b1467849c3e8204eb2",
- "reference": "3b1fc3f0be055baa7c6258b1467849c3e8204eb2",
+ "url": "https://api.github.com/repos/composer/ca-bundle/zipball/bc0593537a463e55cadf45fd938d23b75095b7e1",
+ "reference": "bc0593537a463e55cadf45fd938d23b75095b7e1",
"shasum": ""
},
"require": {
@@ -26,7 +26,7 @@
"psr/log": "^1.0 || ^2.0 || ^3.0",
"symfony/process": "^4.0 || ^5.0 || ^6.0 || ^7.0"
},
- "time": "2024-11-04T10:15:26+00:00",
+ "time": "2024-11-27T15:35:25+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -61,7 +61,7 @@
"support": {
"irc": "irc://irc.freenode.org/composer",
"issues": "https://github.com/composer/ca-bundle/issues",
- "source": "https://github.com/composer/ca-bundle/tree/1.5.3"
+ "source": "https://github.com/composer/ca-bundle/tree/1.5.4"
},
"funding": [
{
@@ -81,17 +81,17 @@
},
{
"name": "composer/class-map-generator",
- "version": "1.4.0",
- "version_normalized": "1.4.0.0",
+ "version": "1.5.0",
+ "version_normalized": "1.5.0.0",
"source": {
"type": "git",
"url": "https://github.com/composer/class-map-generator.git",
- "reference": "98bbf6780e56e0fd2404fe4b82eb665a0f93b783"
+ "reference": "4b0a223cf5be7c9ee7e0ef1bc7db42b4a97c9915"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/composer/class-map-generator/zipball/98bbf6780e56e0fd2404fe4b82eb665a0f93b783",
- "reference": "98bbf6780e56e0fd2404fe4b82eb665a0f93b783",
+ "url": "https://api.github.com/repos/composer/class-map-generator/zipball/4b0a223cf5be7c9ee7e0ef1bc7db42b4a97c9915",
+ "reference": "4b0a223cf5be7c9ee7e0ef1bc7db42b4a97c9915",
"shasum": ""
},
"require": {
@@ -100,14 +100,14 @@
"symfony/finder": "^4.4 || ^5.3 || ^6 || ^7"
},
"require-dev": {
- "phpstan/phpstan": "^1.6",
- "phpstan/phpstan-deprecation-rules": "^1",
- "phpstan/phpstan-phpunit": "^1",
- "phpstan/phpstan-strict-rules": "^1.1",
+ "phpstan/phpstan": "^1.12 || ^2",
+ "phpstan/phpstan-deprecation-rules": "^1 || ^2",
+ "phpstan/phpstan-phpunit": "^1 || ^2",
+ "phpstan/phpstan-strict-rules": "^1.1 || ^2",
"phpunit/phpunit": "^8",
"symfony/filesystem": "^5.4 || ^6"
},
- "time": "2024-10-03T18:14:00+00:00",
+ "time": "2024-11-25T16:11:06+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -137,7 +137,7 @@
],
"support": {
"issues": "https://github.com/composer/class-map-generator/issues",
- "source": "https://github.com/composer/class-map-generator/tree/1.4.0"
+ "source": "https://github.com/composer/class-map-generator/tree/1.5.0"
},
"funding": [
{
@@ -157,17 +157,17 @@
},
{
"name": "composer/composer",
- "version": "2.8.3",
- "version_normalized": "2.8.3.0",
+ "version": "2.8.4",
+ "version_normalized": "2.8.4.0",
"source": {
"type": "git",
"url": "https://github.com/composer/composer.git",
- "reference": "2a7c71266b2545a3bed9f4860734081963f6e688"
+ "reference": "112e37d1dca22b3fdb81cf3524ab4994f47fdb8c"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/composer/composer/zipball/2a7c71266b2545a3bed9f4860734081963f6e688",
- "reference": "2a7c71266b2545a3bed9f4860734081963f6e688",
+ "url": "https://api.github.com/repos/composer/composer/zipball/112e37d1dca22b3fdb81cf3524ab4994f47fdb8c",
+ "reference": "112e37d1dca22b3fdb81cf3524ab4994f47fdb8c",
"shasum": ""
},
"require": {
@@ -206,19 +206,19 @@
"ext-zip": "Enabling the zip extension allows you to unzip archives",
"ext-zlib": "Allow gzip compression of HTTP requests"
},
- "time": "2024-11-17T12:13:04+00:00",
+ "time": "2024-12-11T10:57:47+00:00",
"bin": [
"bin/composer"
],
"type": "library",
"extra": {
- "branch-alias": {
- "dev-main": "2.8-dev"
- },
"phpstan": {
"includes": [
"phpstan/rules.neon"
]
+ },
+ "branch-alias": {
+ "dev-main": "2.8-dev"
}
},
"installation-source": "dist",
@@ -254,7 +254,7 @@
"irc": "ircs://irc.libera.chat:6697/composer",
"issues": "https://github.com/composer/composer/issues",
"security": "https://github.com/composer/composer/security/policy",
- "source": "https://github.com/composer/composer/tree/2.8.3"
+ "source": "https://github.com/composer/composer/tree/2.8.4"
},
"funding": [
{
@@ -373,13 +373,13 @@
"time": "2024-11-12T16:29:46+00:00",
"type": "library",
"extra": {
- "branch-alias": {
- "dev-main": "3.x-dev"
- },
"phpstan": {
"includes": [
"extension.neon"
]
+ },
+ "branch-alias": {
+ "dev-main": "3.x-dev"
}
},
"installation-source": "dist",
@@ -663,18 +663,82 @@
"install-path": "./xdebug-handler"
},
{
+ "name": "fidry/cpu-core-counter",
+ "version": "1.2.0",
+ "version_normalized": "1.2.0.0",
+ "source": {
+ "type": "git",
+ "url": "https://github.com/theofidry/cpu-core-counter.git",
+ "reference": "8520451a140d3f46ac33042715115e290cf5785f"
+ },
+ "dist": {
+ "type": "zip",
+ "url": "https://api.github.com/repos/theofidry/cpu-core-counter/zipball/8520451a140d3f46ac33042715115e290cf5785f",
+ "reference": "8520451a140d3f46ac33042715115e290cf5785f",
+ "shasum": ""
+ },
+ "require": {
+ "php": "^7.2 || ^8.0"
+ },
+ "require-dev": {
+ "fidry/makefile": "^0.2.0",
+ "fidry/php-cs-fixer-config": "^1.1.2",
+ "phpstan/extension-installer": "^1.2.0",
+ "phpstan/phpstan": "^1.9.2",
+ "phpstan/phpstan-deprecation-rules": "^1.0.0",
+ "phpstan/phpstan-phpunit": "^1.2.2",
+ "phpstan/phpstan-strict-rules": "^1.4.4",
+ "phpunit/phpunit": "^8.5.31 || ^9.5.26",
+ "webmozarts/strict-phpunit": "^7.5"
+ },
+ "time": "2024-08-06T10:04:20+00:00",
+ "type": "library",
+ "installation-source": "dist",
+ "autoload": {
+ "psr-4": {
+ "Fidry\\CpuCoreCounter\\": "src/"
+ }
+ },
+ "notification-url": "https://packagist.org/downloads/",
+ "license": [
+ "MIT"
+ ],
+ "authors": [
+ {
+ "name": "Théo FIDRY",
+ "email": "theo.fidry@gmail.com"
+ }
+ ],
+ "description": "Tiny utility to get the number of CPU cores.",
+ "keywords": [
+ "CPU",
+ "core"
+ ],
+ "support": {
+ "issues": "https://github.com/theofidry/cpu-core-counter/issues",
+ "source": "https://github.com/theofidry/cpu-core-counter/tree/1.2.0"
+ },
+ "funding": [
+ {
+ "url": "https://github.com/theofidry",
+ "type": "github"
+ }
+ ],
+ "install-path": "../fidry/cpu-core-counter"
+ },
+ {
"name": "illuminate/container",
- "version": "v10.48.23",
- "version_normalized": "10.48.23.0",
+ "version": "v10.48.25",
+ "version_normalized": "10.48.25.0",
"source": {
"type": "git",
"url": "https://github.com/illuminate/container.git",
- "reference": "ddc26273085fad3c471b2602ad820e0097ff7939"
+ "reference": "ed6253f7dd3a67d468b2cc7a69a657e1f14c7ba3"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/illuminate/container/zipball/ddc26273085fad3c471b2602ad820e0097ff7939",
- "reference": "ddc26273085fad3c471b2602ad820e0097ff7939",
+ "url": "https://api.github.com/repos/illuminate/container/zipball/ed6253f7dd3a67d468b2cc7a69a657e1f14c7ba3",
+ "reference": "ed6253f7dd3a67d468b2cc7a69a657e1f14c7ba3",
"shasum": ""
},
"require": {
@@ -685,7 +749,7 @@
"provide": {
"psr/container-implementation": "1.1|2.0"
},
- "time": "2023-06-18T09:12:03+00:00",
+ "time": "2024-11-21T14:02:44+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -718,17 +782,17 @@
},
{
"name": "illuminate/contracts",
- "version": "v10.48.23",
- "version_normalized": "10.48.23.0",
+ "version": "v10.48.25",
+ "version_normalized": "10.48.25.0",
"source": {
"type": "git",
"url": "https://github.com/illuminate/contracts.git",
- "reference": "8d7152c4a1f5d9cf7da3e8b71f23e4556f6138ac"
+ "reference": "f90663a69f926105a70b78060a31f3c64e2d1c74"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/illuminate/contracts/zipball/8d7152c4a1f5d9cf7da3e8b71f23e4556f6138ac",
- "reference": "8d7152c4a1f5d9cf7da3e8b71f23e4556f6138ac",
+ "url": "https://api.github.com/repos/illuminate/contracts/zipball/f90663a69f926105a70b78060a31f3c64e2d1c74",
+ "reference": "f90663a69f926105a70b78060a31f3c64e2d1c74",
"shasum": ""
},
"require": {
@@ -736,7 +800,7 @@
"psr/container": "^1.1.1|^2.0.1",
"psr/simple-cache": "^1.0|^2.0|^3.0"
},
- "time": "2024-01-15T18:52:32+00:00",
+ "time": "2024-11-21T14:02:44+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -892,62 +956,6 @@
"install-path": "../psr/container"
},
{
- "name": "psr/http-message",
- "version": "2.0",
- "version_normalized": "2.0.0.0",
- "source": {
- "type": "git",
- "url": "https://github.com/php-fig/http-message.git",
- "reference": "402d35bcb92c70c026d1a6a9883f06b2ead23d71"
- },
- "dist": {
- "type": "zip",
- "url": "https://api.github.com/repos/php-fig/http-message/zipball/402d35bcb92c70c026d1a6a9883f06b2ead23d71",
- "reference": "402d35bcb92c70c026d1a6a9883f06b2ead23d71",
- "shasum": ""
- },
- "require": {
- "php": "^7.2 || ^8.0"
- },
- "time": "2023-04-04T09:54:51+00:00",
- "type": "library",
- "extra": {
- "branch-alias": {
- "dev-master": "2.0.x-dev"
- }
- },
- "installation-source": "dist",
- "autoload": {
- "psr-4": {
- "Psr\\Http\\Message\\": "src/"
- }
- },
- "notification-url": "https://packagist.org/downloads/",
- "license": [
- "MIT"
- ],
- "authors": [
- {
- "name": "PHP-FIG",
- "homepage": "https://www.php-fig.org/"
- }
- ],
- "description": "Common interface for HTTP messages",
- "homepage": "https://github.com/php-fig/http-message",
- "keywords": [
- "http",
- "http-message",
- "psr",
- "psr-7",
- "request",
- "response"
- ],
- "support": {
- "source": "https://github.com/php-fig/http-message/tree/2.0"
- },
- "install-path": "../psr/http-message"
- },
- {
"name": "psr/log",
"version": "3.0.2",
"version_normalized": "3.0.2.0",
@@ -1411,23 +1419,23 @@
},
{
"name": "symfony/deprecation-contracts",
- "version": "v3.5.0",
- "version_normalized": "3.5.0.0",
+ "version": "v3.5.1",
+ "version_normalized": "3.5.1.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/deprecation-contracts.git",
- "reference": "0e0d29ce1f20deffb4ab1b016a7257c4f1e789a1"
+ "reference": "74c71c939a79f7d5bf3c1ce9f5ea37ba0114c6f6"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/deprecation-contracts/zipball/0e0d29ce1f20deffb4ab1b016a7257c4f1e789a1",
- "reference": "0e0d29ce1f20deffb4ab1b016a7257c4f1e789a1",
+ "url": "https://api.github.com/repos/symfony/deprecation-contracts/zipball/74c71c939a79f7d5bf3c1ce9f5ea37ba0114c6f6",
+ "reference": "74c71c939a79f7d5bf3c1ce9f5ea37ba0114c6f6",
"shasum": ""
},
"require": {
"php": ">=8.1"
},
- "time": "2024-04-18T09:32:20+00:00",
+ "time": "2024-09-25T14:20:29+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -1461,7 +1469,7 @@
"description": "A generic function and convention to trigger deprecation notices",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/deprecation-contracts/tree/v3.5.0"
+ "source": "https://github.com/symfony/deprecation-contracts/tree/v3.5.1"
},
"funding": [
{
@@ -1643,8 +1651,8 @@
"type": "library",
"extra": {
"thanks": {
- "name": "symfony/polyfill",
- "url": "https://github.com/symfony/polyfill"
+ "url": "https://github.com/symfony/polyfill",
+ "name": "symfony/polyfill"
}
},
"installation-source": "dist",
@@ -1722,8 +1730,8 @@
"type": "library",
"extra": {
"thanks": {
- "name": "symfony/polyfill",
- "url": "https://github.com/symfony/polyfill"
+ "url": "https://github.com/symfony/polyfill",
+ "name": "symfony/polyfill"
}
},
"installation-source": "dist",
@@ -1803,8 +1811,8 @@
"type": "library",
"extra": {
"thanks": {
- "name": "symfony/polyfill",
- "url": "https://github.com/symfony/polyfill"
+ "url": "https://github.com/symfony/polyfill",
+ "name": "symfony/polyfill"
}
},
"installation-source": "dist",
@@ -1890,8 +1898,8 @@
"type": "library",
"extra": {
"thanks": {
- "name": "symfony/polyfill",
- "url": "https://github.com/symfony/polyfill"
+ "url": "https://github.com/symfony/polyfill",
+ "name": "symfony/polyfill"
}
},
"installation-source": "dist",
@@ -2011,17 +2019,17 @@
},
{
"name": "symfony/service-contracts",
- "version": "v3.5.0",
- "version_normalized": "3.5.0.0",
+ "version": "v3.5.1",
+ "version_normalized": "3.5.1.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/service-contracts.git",
- "reference": "bd1d9e59a81d8fa4acdcea3f617c581f7475a80f"
+ "reference": "e53260aabf78fb3d63f8d79d69ece59f80d5eda0"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/service-contracts/zipball/bd1d9e59a81d8fa4acdcea3f617c581f7475a80f",
- "reference": "bd1d9e59a81d8fa4acdcea3f617c581f7475a80f",
+ "url": "https://api.github.com/repos/symfony/service-contracts/zipball/e53260aabf78fb3d63f8d79d69ece59f80d5eda0",
+ "reference": "e53260aabf78fb3d63f8d79d69ece59f80d5eda0",
"shasum": ""
},
"require": {
@@ -2032,7 +2040,7 @@
"conflict": {
"ext-psr": "<1.1|>=2"
},
- "time": "2024-04-18T09:32:20+00:00",
+ "time": "2024-09-25T14:20:29+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -2077,7 +2085,7 @@
"standards"
],
"support": {
- "source": "https://github.com/symfony/service-contracts/tree/v3.5.0"
+ "source": "https://github.com/symfony/service-contracts/tree/v3.5.1"
},
"funding": [
{
diff --git a/pie.spec b/pie.spec
index 5259595..d3b9399 100644
--- a/pie.spec
+++ b/pie.spec
@@ -13,14 +13,14 @@
%bcond_with generators
-%global gh_commit e4b1fd111b72fafcdf9512d9a009cb54742eb72c
+%global gh_commit dc299c3580bc5300e3cac220ef93f346eb53f5e0
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20241003
%global gh_branch main
%global gh_owner php
%global gh_project pie
-%global upstream_version 0.2.0
+%global upstream_version 0.3.0
#global upstream_prever dev
#global upstream_lower DEV
@@ -30,7 +30,7 @@
Name: pie
Version: %{upstream_version}%{?upstream_prever:~%{upstream_lower}}
-Release: 2%{?dist}
+Release: 1%{?dist}
Summary: PHP Installer for Extensions
# SPDX: pie is BSD-3-Clause, all dependencies are MIT
@@ -82,18 +82,19 @@ Requires: php-phar
%if %{without generators}
# Bundled libraries
# License MIT
-Provides: bundled(php-composer(composer/class-map-generator)) = 1.4.0
-Provides: bundled(php-composer(composer/composer)) = 2.8.3
+Provides: bundled(php-composer(composer/ca-bundle)) = 1.5.4
+Provides: bundled(php-composer(composer/class-map-generator)) = 1.5.0
+Provides: bundled(php-composer(composer/composer)) = 2.8.4
Provides: bundled(php-composer(composer/metadata-minifier)) = 1.0.0
Provides: bundled(php-composer(composer/pcre)) = 3.3.2
Provides: bundled(php-composer(composer/semver)) = 3.4.3
Provides: bundled(php-composer(composer/spdx-licenses)) = 1.5.8
Provides: bundled(php-composer(composer/xdebug-handler)) = 3.0.5
-Provides: bundled(php-composer(illuminate/container)) = v10.48.23
-Provides: bundled(php-composer(illuminate/contracts)) = v10.48.23
+Provides: bundled(php-composer(fidry/cpu-core-counter)) = 1.2.0
+Provides: bundled(php-composer(illuminate/container)) = v10.48.25
+Provides: bundled(php-composer(illuminate/contracts)) = v10.48.25
Provides: bundled(php-composer(justinrainbow/json-schema)) = 5.3.0
Provides: bundled(php-composer(psr/container)) = 2.0.2
-Provides: bundled(php-composer(psr/http-message)) = 2.0
Provides: bundled(php-composer(psr/log)) = 3.0.2
Provides: bundled(php-composer(psr/simple-cache)) = 3.0.0
Provides: bundled(php-composer(react/promise)) = v3.2.0
@@ -101,7 +102,7 @@ Provides: bundled(php-composer(seld/jsonlint)) = 1.11.0
Provides: bundled(php-composer(seld/phar-utils)) = 1.2.1
Provides: bundled(php-composer(seld/signal-handler)) = 2.0.2
Provides: bundled(php-composer(symfony/console)) = v6.4.15
-Provides: bundled(php-composer(symfony/deprecation-contracts)) = v3.5.0
+Provides: bundled(php-composer(symfony/deprecation-contracts)) = v3.5.1
Provides: bundled(php-composer(symfony/filesystem)) = v6.4.13
Provides: bundled(php-composer(symfony/finder)) = v6.4.13
Provides: bundled(php-composer(symfony/polyfill-ctype)) = v1.31.0
@@ -109,7 +110,7 @@ Provides: bundled(php-composer(symfony/polyfill-intl-grapheme)) = v1.31.0
Provides: bundled(php-composer(symfony/polyfill-intl-normalizer)) = v1.31.0
Provides: bundled(php-composer(symfony/polyfill-mbstring)) = v1.31.0
Provides: bundled(php-composer(symfony/process)) = v6.4.15
-Provides: bundled(php-composer(symfony/service-contracts)) = v3.5.0
+Provides: bundled(php-composer(symfony/service-contracts)) = v3.5.1
Provides: bundled(php-composer(symfony/string)) = v6.4.15
Provides: bundled(php-composer(webmozart/assert)) = 1.11.0
@@ -201,6 +202,9 @@ done
%changelog
+* Tue Dec 24 2024 Remi Collet <remi@remirepo.net> - 0.3.0-1
+- update to 0.3.0
+
* Fri Dec 13 2024 Remi Collet <remi@remirepo.net> - 0.2.0-2
- re-license spec file to CECILL-2.1