summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-12-11 08:24:21 +0100
committerRemi Collet <remi@php.net>2024-12-11 08:24:21 +0100
commit6d480f6ddffc9c5fff3baee59d3d1aacadee15bb (patch)
tree80e8bbe9637251f1420e933af038fafe11a6e7ae
parentd330058033c45a141e6f26c080e3201e26ee2ee1 (diff)
update to 3.2.2HEADmaster
re-license spec file to CECILL-2.1 raise dependency on php 7.2 switch to phpunit11
-rw-r--r--composer.json4
-rw-r--r--php-zumba-json-serializer.spec43
2 files changed, 25 insertions, 22 deletions
diff --git a/composer.json b/composer.json
index 6653a83..1726403 100644
--- a/composer.json
+++ b/composer.json
@@ -19,14 +19,14 @@
}
],
"require": {
- "php": "^7.0 || ^8.0",
+ "php": "^7.2 || ^8.0",
"ext-mbstring": "*"
},
"suggest": {
"opis/closure": "Allow to serialize PHP closures"
},
"require-dev": {
- "phpunit/phpunit": ">=6.0 <11.0"
+ "phpunit/phpunit": ">=8 <12.0"
},
"autoload": {
"psr-4": {
diff --git a/php-zumba-json-serializer.spec b/php-zumba-json-serializer.spec
index e42038e..872d413 100644
--- a/php-zumba-json-serializer.spec
+++ b/php-zumba-json-serializer.spec
@@ -1,15 +1,15 @@
# remirepo/fedora spec file for php-zumba-json-serializer
#
-# Copyright (c) 2021-2023 Remi Collet
-# License: CC-BY-SA-4.0
-# http://creativecommons.org/licenses/by-sa/4.0/
+# SPDX-FileCopyrightText: Copyright 2024 Remi Collet
+# SPDX-License-Identifier: CECILL-2.1
+# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
#
# Please, preserve the changelog entries
#
%bcond_without tests
-%global gh_commit c869bcb7f934f785d69c978f7d0479b54bbe0cfa
+%global gh_commit 1b1b2302d46692f317021ee4b9cc06b1311b7333
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zumba
%global gh_project json-serializer
@@ -18,7 +18,7 @@
%global major %nil
Name: php-%{gh_owner}-%{gh_project}%{major}
-Version: 3.2.1
+Version: 3.2.2
Release: 1%{?dist}
Summary: Serialize PHP variables
@@ -29,7 +29,8 @@ Source1: makesrc.sh
BuildArch: noarch
%if %{with tests}
-BuildRequires: php(language) >= 7.0
+# as we use phpunit10 by default
+BuildRequires: php(language) >= 8.1
BuildRequires: php-date
BuildRequires: php-json
BuildRequires: php-mbstring
@@ -37,24 +38,22 @@ BuildRequires: php-pcre
BuildRequires: php-reflection
BuildRequires: php-spl
# For tests, from composer.json "require-dev": {
-# "phpunit/phpunit": ">=6.0 <11.0"
-# remirepo:1
-%if 0%{?fedora} >= 38
+# "phpunit/phpunit": ">=8.0 <12.0"
+%if 0%{?fedora} >= 40 || 0%{?rhel} >= 10
+BuildRequires: phpunit11
+%global phpunit %{_bindir}/phpunit11
+%else
BuildRequires: phpunit10
%global phpunit %{_bindir}/phpunit10
-# remirepo:4
-%else
-BuildRequires: phpunit9
-%global phpunit %{_bindir}/phpunit9
%endif
%endif
# For autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
-# "php": "^7.0 || ^8.0",
+# "php": "^7.2 || ^8.0",
# "ext-mbstring": "*"
-Requires: php(language) >= 7.0
+Requires: php(language) >= 7.2
Requires: php-mbstring
# From phpcompatinfo report for 3.0.1
Requires: php-json
@@ -102,11 +101,11 @@ require '%{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}%{major}/autoload
EOF
ret=0
-# ignore testS relying on SuperClosure (deprecated and removed from repo)
-for cmdarg in "php %{phpunit}" "php80 %{_bindir}/phpunit9" php81 php82 php83; do
+# ignore tests relying on SuperClosure (deprecated and removed from repo)
+for cmdarg in "php %{phpunit}" "php81 %{_bindir}/phpunit10" php82 php83 php84; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit10} \
+ $1 ${2:-%{_bindir}/phpunit11} \
--bootstrap vendor/autoload.php \
--filter '^((?!(testAddSerializer|testGetPreferredSerializer|testSerialize|testUnserialize)).)*$' \
--no-coverage || ret=1
@@ -119,8 +118,6 @@ exit $ret
%files
-# remirepo:1
-%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc composer.json
%doc README.md
@@ -129,6 +126,12 @@ exit $ret
%changelog
+* Wed Dec 11 2024 Remi Collet <remi@remirepo.net> - 3.2.2-1
+- update to 3.2.2
+- re-license spec file to CECILL-2.1
+- raise dependency on php 7.2
+- switch to phpunit11
+
* Thu Oct 19 2023 Remi Collet <remi@remirepo.net> - 3.2.1-1
- update to 3.2.1