summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-session.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-session.spec')
-rw-r--r--php-zendframework-zend-session.spec47
1 files changed, 9 insertions, 38 deletions
diff --git a/php-zendframework-zend-session.spec b/php-zendframework-zend-session.spec
index 2623059..7a6a845 100644
--- a/php-zendframework-zend-session.spec
+++ b/php-zendframework-zend-session.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 346e9709657b81a5d53d70ce754730a26d1f02f2
+%global gh_commit fa1d68852cd09e08a25c7dc7893d19811c085be9
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-session
@@ -20,8 +20,8 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.7.3
-Release: 2%{?dist}
+Version: 2.7.4
+Release: 1%{?dist}
Summary: Zend Framework %{library} component
Group: Development/Libraries
@@ -30,7 +30,6 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -50,8 +49,8 @@ BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
# "zendframework/zend-validator": "^2.6",
# "container-interop/container-interop": "^1.1",
# "mongodb/mongodb": "^1.0.1",
-# "fabpot/php-cs-fixer": "1.7.*",
-# "phpunit/PHPUnit": "~4.0"
+# "phpunit/PHPUnit": "~4.0",
+# "zendframework/zend-coding-standard": "~1.0.0"
BuildRequires: php-composer(%{gh_owner}/zend-cache) >= 2.6.1
BuildRequires: php-composer(%{gh_owner}/zend-db) >= 2.7
BuildRequires: php-composer(%{gh_owner}/zend-http) >= 2.5.4
@@ -90,7 +89,7 @@ Suggests: php-composer(%{gh_owner}/zend-validator)
Suggests: php-composer(mongodb/mongodb)
%endif
%endif
-# From phpcompatinfo report for version 2.5.2
+# From phpcompatinfo report for version 2.7.4
Requires: php-date
Requires: php-hash
Requires: php-pcre
@@ -121,8 +120,6 @@ mv LICENSE.md LICENSE
%install
-rm -rf %{buildroot}
-
mkdir -p %{buildroot}%{php_home}/Zend/
cp -pr src %{buildroot}%{php_home}/Zend/%{library}
@@ -145,42 +142,13 @@ Zend\Loader\AutoloaderFactory::factory(array(
require_once '%{php_home}/Zend/autoload.php';
EOF
-# ignore failed test with PHP 7.1
-# see https://github.com/zendframework/zend-session/issues/68
-rm test/Config/SessionConfigTest.php
-
-# remirepo:16
-%if 0%{?rhel} == 5
-# sqlite is too old
-rm test/SaveHandler/DbTableGatewayTest.php
-%endif
-
-run=0
-ret=0
-if which php56; then
- php56 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if which php71; then
- php71 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
%{_bindir}/phpunit --verbose
-# remirepo:2
-fi
-exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -189,6 +157,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Jun 20 2017 Remi Collet <remi@remirepo.net> - 2.7.4-1
+- Update to 2.7.4
+
* Wed Nov 30 2016 Remi Collet <remi@fedoraproject.org> - 2.7.3-2
- fix FTBFS, ignore failed test with PHP 7.1
open https://github.com/zendframework/zend-session/issues/68