summaryrefslogtreecommitdiffstats
path: root/php-yoast-phpunit-polyfills.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-yoast-phpunit-polyfills.spec')
-rw-r--r--php-yoast-phpunit-polyfills.spec43
1 files changed, 31 insertions, 12 deletions
diff --git a/php-yoast-phpunit-polyfills.spec b/php-yoast-phpunit-polyfills.spec
index 1a3dd81..7ec18af 100644
--- a/php-yoast-phpunit-polyfills.spec
+++ b/php-yoast-phpunit-polyfills.spec
@@ -1,13 +1,13 @@
# remirepo/fedora spec file for php-yoast-phpunit-polyfills
#
-# Copyright (c) 2020-2024 Remi Collet
-# License: CC-BY-SA-4.0
-# http://creativecommons.org/licenses/by-sa/4.0/
+# SPDX-FileCopyrightText: Copyright 2020-2025 Remi Collet
+# SPDX-License-Identifier: CECILL-2.1
+# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
#
# Please preserve changelog entries
#
# Github
-%global gh_commit 19e6d5fb8aad31f731f774f9646a10c64a8843d2
+%global gh_commit 134921bfca9b02d8f374c48381451da1d98402f9
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner Yoast
%global gh_project PHPUnit-Polyfills
@@ -18,14 +18,14 @@
%global ns_vendor Yoast
%global ns_project PHPUnitPolyfills
# don't change major version used in package name
-%global major 3
+%global major 4
%bcond_without tests
%global php_home %{_datadir}/php
Name: php-%{pk_vendor}-%{pk_project}
-Version: 3.0.0
+Version: 4.0.0
Release: 1%{?dist}
-Summary: Set of polyfills for changed PHPUnit functionality
+Summary: Set of polyfills for changed PHPUnit functionality, version %{major}
License: BSD-3-Clause
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -35,12 +35,14 @@ Source1: makesrc.sh
BuildArch: noarch
%if %{with tests}
-BuildRequires: php(language) >= 7.0
+BuildRequires: php(language) >= 7.1
BuildRequires: php-reflection
# From composer.json, "require-dev": {
# "yoast/yoastcs": "^2.3.0"
-# remirepo:1
+%if 0%{?fedora} >= 40 || 0%{?rhel} >= 10
+BuildRequires: phpunit12
BuildRequires: phpunit11
+%endif
# phpunit10 is not supported
BuildRequires: phpunit9
BuildRequires: phpunit8
@@ -48,9 +50,9 @@ BuildRequires: phpunit8
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
-# "php": ">=7.0",
-# "phpunit/phpunit": "^6.4.4 || ^7.0 || ^8.0 || ^9.0 || ^11.0"
-Requires: php(language) >= 7.0
+# "php": ">=7.1",
+# "phpunit/phpunit": "^7.5 || ^8.0 || ^9.0 || ^11.0 || ^12.0"
+Requires: php(language) >= 7.1
# from phpcompatinfo report on version 0.2.0
Requires: php-reflection
@@ -115,6 +117,13 @@ if [ -x %{_bindir}/phpunit11 ]; then
fi
done
fi
+if [ -x %{_bindir}/phpunit12 ]; then
+ for cmd in php php83 php84; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit11 --no-coverage || ret=1
+ fi
+ done
+fi
exit $ret
%endif
@@ -128,6 +137,16 @@ exit $ret
%changelog
+* Mon Feb 10 2025 Remi Collet <remi@remirepo.net> - 4.0.0-1
+- update to 4.0.0
+- move to /usr/share/php/Yoast/PHPUnitPolyfills4
+- raise dependency on PHP 7.1
+- add phpunit12
+
+* Thu Jan 9 2025 Remi Collet <remi@remirepo.net> - 3.1.0-1
+- update to 3.1.0
+- re-license spec file to CECILL-2.1
+
* Mon Sep 9 2024 Remi Collet <remi@remirepo.net> - 3.0.0-1
- update to 3.0.0
- move to /usr/share/php/Yoast/PHPUnitPolyfills3