summaryrefslogtreecommitdiffstats
path: root/php-yoast-phpunit-polyfills.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-09-09 07:58:59 +0200
committerRemi Collet <remi@php.net>2024-09-09 07:58:59 +0200
commitc89fbb5523b9d7a925c06cec55425694ae9a27c0 (patch)
tree51bac61716ad84b4bdb06eb0fcccd6c672328422 /php-yoast-phpunit-polyfills.spec
parentdac5932688ebea14fe8efba17ca836abce672f3c (diff)
update to 3.0.0HEADmaster
move to /usr/share/php/Yoast/PHPUnitPolyfills3 raise dependency on PHP 7.0 drop phpunit10, add phpunit11
Diffstat (limited to 'php-yoast-phpunit-polyfills.spec')
-rw-r--r--php-yoast-phpunit-polyfills.spec28
1 files changed, 18 insertions, 10 deletions
diff --git a/php-yoast-phpunit-polyfills.spec b/php-yoast-phpunit-polyfills.spec
index 5b65bf8..1a3dd81 100644
--- a/php-yoast-phpunit-polyfills.spec
+++ b/php-yoast-phpunit-polyfills.spec
@@ -7,7 +7,7 @@
# Please preserve changelog entries
#
# Github
-%global gh_commit 4a088f125c970d6d6ea52c927f96fe39b330d0f1
+%global gh_commit 19e6d5fb8aad31f731f774f9646a10c64a8843d2
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner Yoast
%global gh_project PHPUnit-Polyfills
@@ -18,12 +18,12 @@
%global ns_vendor Yoast
%global ns_project PHPUnitPolyfills
# don't change major version used in package name
-%global major 2
+%global major 3
%bcond_without tests
%global php_home %{_datadir}/php
Name: php-%{pk_vendor}-%{pk_project}
-Version: 2.0.1
+Version: 3.0.0
Release: 1%{?dist}
Summary: Set of polyfills for changed PHPUnit functionality
@@ -35,20 +35,22 @@ Source1: makesrc.sh
BuildArch: noarch
%if %{with tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.0
BuildRequires: php-reflection
# From composer.json, "require-dev": {
# "yoast/yoastcs": "^2.3.0"
-BuildRequires: phpunit10
+# remirepo:1
+BuildRequires: phpunit11
+# phpunit10 is not supported
BuildRequires: phpunit9
BuildRequires: phpunit8
%endif
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
-# "php": ">=5.6",
-# "phpunit/phpunit": "^5.7.21 || ^6.0 || ^7.0 || ^8.0 || ^9.0 || ^10.0"
-Requires: php(language) >= 5.6
+# "php": ">=7.0",
+# "phpunit/phpunit": "^6.4.4 || ^7.0 || ^8.0 || ^9.0 || ^11.0"
+Requires: php(language) >= 7.0
# from phpcompatinfo report on version 0.2.0
Requires: php-reflection
@@ -106,10 +108,10 @@ if [ -x %{_bindir}/phpunit9 ]; then
fi
done
fi
-if [ -x %{_bindir}/phpunit10 ]; then
+if [ -x %{_bindir}/phpunit11 ]; then
for cmd in php php82 php83 php84; do
if which $cmd; then
- $cmd %{_bindir}/phpunit10 --no-coverage || ret=1
+ $cmd %{_bindir}/phpunit11 --no-coverage || ret=1
fi
done
fi
@@ -126,6 +128,12 @@ exit $ret
%changelog
+* Mon Sep 9 2024 Remi Collet <remi@remirepo.net> - 3.0.0-1
+- update to 3.0.0
+- move to /usr/share/php/Yoast/PHPUnitPolyfills3
+- raise dependency on PHP 7.0
+- drop phpunit10, add phpunit11
+
* Fri Aug 30 2024 Remi Collet <remi@remirepo.net> - 2.0.1-1
- update to 2.0.1
- move to /usr/share/php/Yoast/PHPUnitPolyfills2