summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json10
-rw-r--r--php-tecnickcom-tc-lib-unicode.spec16
2 files changed, 15 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index ee2bcff..053d6c0 100644
--- a/composer.json
+++ b/composer.json
@@ -19,16 +19,16 @@
}
],
"require": {
- "php": ">=8.0",
+ "php": ">=8.1",
"ext-mbstring": "*",
"ext-pcre": "*",
"tecnickcom/tc-lib-unicode-data": "^2.0"
},
"require-dev": {
- "pdepend/pdepend": "2.13.0",
- "phpmd/phpmd": "2.13.0",
- "phpunit/phpunit": "10.1.2 || 9.6.13",
- "squizlabs/php_codesniffer": "3.7.2"
+ "pdepend/pdepend": "2.16.2",
+ "phpmd/phpmd": "2.15.0",
+ "phpunit/phpunit": "11.5.2 || 10.5.40",
+ "squizlabs/php_codesniffer": "3.11.2"
},
"autoload": {
"psr-4": {
diff --git a/php-tecnickcom-tc-lib-unicode.spec b/php-tecnickcom-tc-lib-unicode.spec
index 6f46976..2a1f410 100644
--- a/php-tecnickcom-tc-lib-unicode.spec
+++ b/php-tecnickcom-tc-lib-unicode.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 5ab3b65b108c947ed1559eef16fcc8aa2d651267
+%global gh_commit 34b646d8c2005bbd24169c96c41c8a0fa205dd82
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.0.17
+Version: 2.0.18
Release: 1%{?dist}
Summary: PHP library containing Unicode methods
@@ -27,8 +27,8 @@ BuildArch: noarch
%if %{with_tests}
# For tests
%global phpunit %{_bindir}/phpunit10
-BuildRequires: phpunit10 >= 10.1.2
-BuildRequires: php(language) >= 8.0
+BuildRequires: phpunit10 >= 10.5.40
+BuildRequires: php(language) >= 8.1
BuildRequires: (php-composer(%{c_vendor}/tc-lib-unicode-data) >= 2.0 with php-composer(%{c_vendor}/tc-lib-unicode-data) < 3)
BuildRequires: php-mbstring
BuildRequires: php-pcre
@@ -36,11 +36,11 @@ BuildRequires: php-pcre
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
-# "php": ">=8.0"
+# "php": ">=8.1"
# "ext-mbstring": "*",
# "ext-pcre": "*",
# "tecnickcom/tc-lib-unicode-data": "^2.0"
-Requires: php(language) >= 8.0
+Requires: php(language) >= 8.1
Requires: php-mbstring
Requires: php-pcre
Requires: (php-composer(%{c_vendor}/tc-lib-unicode-data) >= 2.0 with php-composer(%{c_vendor}/tc-lib-unicode-data) < 3)
@@ -114,6 +114,10 @@ exit $ret
%changelog
+* Fri Dec 27 2024 Remi Collet <remi@remirepo.net> - 2.0.18-1
+- update to 2.0.18
+- raise dependency on PHP 8.1
+
* Mon Dec 23 2024 Remi Collet <remi@remirepo.net> - 2.0.17-1
- update to 2.0.17 (no change)
- re-license spec file to CECILL-2.1