summaryrefslogtreecommitdiffstats
path: root/php-tecnickcom-tc-lib-pdf-image.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-11-28 16:07:33 +0100
committerRemi Collet <remi@php.net>2023-11-28 16:07:33 +0100
commitf469c2ab68c4bae8aab87917674957e34545f500 (patch)
tree9d63b92847a2cc2f9d68a109345b3fb18070b3ee /php-tecnickcom-tc-lib-pdf-image.spec
initial package, version 2.0.8
Diffstat (limited to 'php-tecnickcom-tc-lib-pdf-image.spec')
-rw-r--r--php-tecnickcom-tc-lib-pdf-image.spec146
1 files changed, 146 insertions, 0 deletions
diff --git a/php-tecnickcom-tc-lib-pdf-image.spec b/php-tecnickcom-tc-lib-pdf-image.spec
new file mode 100644
index 0000000..713ba70
--- /dev/null
+++ b/php-tecnickcom-tc-lib-pdf-image.spec
@@ -0,0 +1,146 @@
+# remirepo/fedora spec file for php-tecnickcom-tc-lib-pdf-image
+#
+# Copyright (c) 2023 Remi Collet
+# License: CC-BY-SA-4.0
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global gh_commit 8e762cb0163311f3cddc7f21e509f247d53cb17a
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global c_vendor tecnickcom
+%global gh_owner tecnickcom
+%global gh_project tc-lib-pdf-image
+%global php_project %{_datadir}/php/Com/Tecnick/Pdf/Image
+%global with_tests 0%{!?_without_tests:1}
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 2.0.8
+Release: 1%{?dist}
+Summary: PHP library containing PDF Image methods
+
+License: LGPL-3.0-or-later
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{?gh_short}.tar.gz
+
+BuildArch: noarch
+%if %{with_tests}
+# For tests
+%global phpunit %{_bindir}/phpunit10
+BuildRequires: phpunit10 >= 10.1.2
+BuildRequires: php(language) >= 8.0
+BuildRequires: php-gd
+BuildRequires: php-zlib
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(%{c_vendor}/tc-lib-file) >= 2.0 with php-composer(%{c_vendor}/tc-lib-file) < 3)
+BuildRequires: (php-composer(%{c_vendor}/tc-lib-color) >= 2.0 with php-composer(%{c_vendor}/tc-lib-color) < 3)
+BuildRequires: (php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 2.0 with php-composer(%{c_vendor}/tc-lib-pdf-encrypt) < 3)
+%else
+BuildRequires: php-%{c_vendor}-tc-lib-file < 3
+BuildRequires: php-%{c_vendor}-tc-lib-file >= 2.0
+BuildRequires: php-%{c_vendor}-tc-lib-color < 3
+BuildRequires: php-%{c_vendor}-tc-lib-color >= 2.0
+BuildRequires: php-%{c_vendor}-tc-lib-pdf-encrypt < 3
+BuildRequires: php-%{c_vendor}-tc-lib-pdf-encrypt >= 2.0
+%endif
+%endif
+BuildRequires: php-fedora-autoloader-devel
+
+# From composer.json, "require": {
+# "php": ">=8.0",
+# "ext-gd": "*",
+# "ext-zlib": "*",
+# "tecnickcom/tc-lib-file": "^2.0",
+# "tecnickcom/tc-lib-color": "^2.0",
+# "tecnickcom/tc-lib-pdf-encrypt": "^2.0"
+Requires: php(language) >= 8.0
+Requires: php-gd
+Requires: php-zlib
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(%{c_vendor}/tc-lib-file) >= 2.0 with php-composer(%{c_vendor}/tc-lib-file) < 3)
+Requires: (php-composer(%{c_vendor}/tc-lib-color) >= 2.0 with php-composer(%{c_vendor}/tc-lib-color) < 3)
+Requires: (php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 2.0 with php-composer(%{c_vendor}/tc-lib-pdf-encrypt) < 3)
+%else
+Requires: php-%{c_vendor}-tc-lib-file < 3
+Requires: php-%{c_vendor}-tc-lib-file >= 2.0
+Requires: php-%{c_vendor}-tc-lib-color < 3
+Requires: php-%{c_vendor}-tc-lib-color >= 2.0
+Requires: php-%{c_vendor}-tc-lib-pdf-encrypt) < 3
+Requires: php-%{c_vendor}-tc-lib-pdf-encrypt) >= 2.0
+%endif
+# From phpcompatinfo report for version 2.0.8
+# none
+Requires: php-composer(fedora/autoloader)
+
+# Composer
+Provides: php-composer(%{c_vendor}/%{gh_project}) = %{version}
+# Upstream package name
+Provides: php-%{gh_project} = %{version}
+
+
+%description
+PHP library containing PDF Image methods.
+
+The initial source code has been extracted from TCPDF (http://www.tcpdf.org).
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+: Sanity check
+grep -q '^%{version}$' VERSION
+
+
+%build
+phpab --template fedora --output src/autoload.php src
+cat << 'EOF' | tee -a src/autoload.php
+\Fedora\Autoloader\Dependencies::required([
+ '%{_datadir}/php/Com/Tecnick/File/autoload.php',
+ '%{_datadir}/php/Com/Tecnick/Color/autoload.php',
+ '%{_datadir}/php/Com/Tecnick/Pdf/Encrypt/autoload.php',
+]);
+EOF
+
+
+%install
+mkdir -p $(dirname %{buildroot}%{php_project})
+cp -pr src %{buildroot}%{php_project}
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require '%{buildroot}%{php_project}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('Test\\', dirname(__DIR__) . '/test');
+EOF
+
+ret=0
+for cmdarg in php php81 php82 php83; do
+ if which $cmdarg; then
+ set $cmdarg
+ cp phpunit.xml.dist phpunit.xml
+ $1 ${2:-%{phpunit}} --migrate-configuration || :
+ $1 ${2:-%{phpunit}} --no-coverage || ret=1
+ fi
+done
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+# remirepo:1
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc composer.json
+%doc *.md
+%{php_project}
+
+
+%changelog
+* Tue Nov 28 2023 Remi Collet <remi@remirepo.net> - 2.0.8-1
+- initial package, version 2.0.8
+