summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--php-tecnickcom-tc-lib-pdf-graph.spec34
2 files changed, 12 insertions, 24 deletions
diff --git a/composer.json b/composer.json
index 1ab95ef..a4fb71a 100644
--- a/composer.json
+++ b/composer.json
@@ -21,7 +21,7 @@
"require": {
"php": ">=8.0",
"ext-zlib": "*",
- "tecnickcom/tc-lib-color": "^2.0",
+ "tecnickcom/tc-lib-color": "^2.2",
"tecnickcom/tc-lib-pdf-encrypt": "^2.1"
},
"require-dev": {
diff --git a/php-tecnickcom-tc-lib-pdf-graph.spec b/php-tecnickcom-tc-lib-pdf-graph.spec
index c822a7c..d6c4ce4 100644
--- a/php-tecnickcom-tc-lib-pdf-graph.spec
+++ b/php-tecnickcom-tc-lib-pdf-graph.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-tecnickcom-tc-lib-pdf-graph
#
-# Copyright (c) 2016-2023 Remi Collet
+# Copyright (c) 2016-2024 Remi Collet
# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit 8727f40f95f03c550d90ae740bb420b2ae3682c4
+%global gh_commit 428e1800ccc4f18f6be8116a1845545b7a5bdfa2
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.0.12
+Version: 2.1.1
Release: 1%{?dist}
Summary: PHP library containing PDF graphic and geometric methods
@@ -29,34 +29,20 @@ BuildArch: noarch
%global phpunit %{_bindir}/phpunit10
BuildRequires: phpunit10 >= 10.1.2
BuildRequires: php(language) >= 8.0
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(%{c_vendor}/tc-lib-color) >= 2.0 with php-composer(%{c_vendor}/tc-lib-color) < 3)
+BuildRequires: (php-composer(%{c_vendor}/tc-lib-color) >= 2.2 with php-composer(%{c_vendor}/tc-lib-color) < 3)
BuildRequires: (php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 2.1 with php-composer(%{c_vendor}/tc-lib-pdf-encrypt) < 3)
-%else
-BuildRequires: php-%{c_vendor}-tc-lib-color < 3
-BuildRequires: php-%{c_vendor}-tc-lib-color >= 2.0
-BuildRequires: php-%{c_vendor}-tc-lib-pdf-encrypt < 3
-BuildRequires: php-%{c_vendor}-tc-lib-pdf-encrypt >= 2.1
-%endif
%endif
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
# "php": ">=8.0"
# "ext-zlib": "*",
-# "tecnickcom/tc-lib-color": "^2.0",
+# "tecnickcom/tc-lib-color": "^2.2",
# "tecnickcom/tc-lib-pdf-encrypt": "^2.1"
Requires: php(language) >= 8.0
Requires: php-zlib
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(%{c_vendor}/tc-lib-color) >= 2.0 with php-composer(%{c_vendor}/tc-lib-color) < 3)
+Requires: (php-composer(%{c_vendor}/tc-lib-color) >= 2.2 with php-composer(%{c_vendor}/tc-lib-color) < 3)
Requires: (php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 2.1 with php-composer(%{c_vendor}/tc-lib-pdf-encrypt) < 3)
-%else
-Requires: php-%{c_vendor}-tc-lib-color < 3
-Requires: php-%{c_vendor}-tc-lib-color >= 2.0
-Requires: php-%{c_vendor}-tc-lib-pdf-encrypt < 3
-Requires: php-%{c_vendor}-tc-lib-pdf-encrypt >= 2.1
-%endif
# From phpcompatinfo report for version 1.4.2
# none
Requires: php-composer(fedora/autoloader)
@@ -105,7 +91,7 @@ require '%{buildroot}%{php_project}/autoload.php';
EOF
ret=0
-for cmdarg in php php81 php82 php83; do
+for cmdarg in php php81 php82 php83 php84; do
if which $cmdarg; then
set $cmdarg
cp phpunit.xml.dist phpunit.xml
@@ -120,8 +106,6 @@ exit $ret
%files
-# remirepo:1
-%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc composer.json
%doc *.md
@@ -129,6 +113,10 @@ exit $ret
%changelog
+* Mon Aug 19 2024 Remi Collet <remi@remirepo.net> - 2.1.1-1
+- update to 2.1.1
+- raise dependency on tc-lib-color 2.2
+
* Fri Apr 12 2024 Remi Collet <remi@remirepo.net> - 2.0.12-1
- update to 2.0.12