summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json10
-rw-r--r--php-tecnickcom-tc-lib-pdf-graph.spec26
2 files changed, 22 insertions, 14 deletions
diff --git a/composer.json b/composer.json
index a4fb71a..8b834c1 100644
--- a/composer.json
+++ b/composer.json
@@ -19,16 +19,16 @@
}
],
"require": {
- "php": ">=8.0",
+ "php": ">=8.1",
"ext-zlib": "*",
"tecnickcom/tc-lib-color": "^2.2",
"tecnickcom/tc-lib-pdf-encrypt": "^2.1"
},
"require-dev": {
- "pdepend/pdepend": "2.13.0",
- "phpmd/phpmd": "2.13.0",
- "phpunit/phpunit": "10.1.2 || 9.6.13",
- "squizlabs/php_codesniffer": "3.7.2"
+ "pdepend/pdepend": "2.16.2",
+ "phpmd/phpmd": "2.15.0",
+ "phpunit/phpunit": "11.5.2 || 10.5.40",
+ "squizlabs/php_codesniffer": "3.11.2"
},
"autoload": {
"psr-4": {
diff --git a/php-tecnickcom-tc-lib-pdf-graph.spec b/php-tecnickcom-tc-lib-pdf-graph.spec
index 76ebe80..7283742 100644
--- a/php-tecnickcom-tc-lib-pdf-graph.spec
+++ b/php-tecnickcom-tc-lib-pdf-graph.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-tecnickcom-tc-lib-pdf-graph
#
-# Copyright (c) 2016-2024 Remi Collet
-# License: CC-BY-SA-4.0
-# http://creativecommons.org/licenses/by-sa/4.0/
+# SPDX-FileCopyrightText: Copyright 2016-2024 Remi Collet
+# SPDX-License-Identifier: CECILL-2.1
+# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
#
# Please, preserve the changelog entries
#
-%global gh_commit 9d71f4483772c447b2d03581a12b4f229710d765
+%global gh_commit 6ec472e9be9a9c247124ff53ad8a14110cda18ac
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.2.4
+Version: 2.2.6
Release: 1%{?dist}
Summary: PHP library containing PDF graphic and geometric methods
@@ -27,19 +27,19 @@ BuildArch: noarch
%if %{with_tests}
# For tests
%global phpunit %{_bindir}/phpunit10
-BuildRequires: phpunit10 >= 10.1.2
-BuildRequires: php(language) >= 8.0
+BuildRequires: phpunit10 >= 10.5.40
+BuildRequires: php(language) >= 8.1
BuildRequires: (php-composer(%{c_vendor}/tc-lib-color) >= 2.2 with php-composer(%{c_vendor}/tc-lib-color) < 3)
BuildRequires: (php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 2.1 with php-composer(%{c_vendor}/tc-lib-pdf-encrypt) < 3)
%endif
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
-# "php": ">=8.0"
+# "php": ">=8.1"
# "ext-zlib": "*",
# "tecnickcom/tc-lib-color": "^2.2",
# "tecnickcom/tc-lib-pdf-encrypt": "^2.1"
-Requires: php(language) >= 8.0
+Requires: php(language) >= 8.1
Requires: php-zlib
Requires: (php-composer(%{c_vendor}/tc-lib-color) >= 2.2 with php-composer(%{c_vendor}/tc-lib-color) < 3)
Requires: (php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 2.1 with php-composer(%{c_vendor}/tc-lib-pdf-encrypt) < 3)
@@ -113,6 +113,14 @@ exit $ret
%changelog
+* Fri Dec 27 2024 Remi Collet <remi@remirepo.net> - 2.2.6-1
+- update to 2.2.6
+- raise dependency on PHP 8.1
+
+* Mon Dec 23 2024 Remi Collet <remi@remirepo.net> - 2.2.5-1
+- update to 2.2.5 (no change)
+- re-license spec file to CECILL-2.1
+
* Mon Nov 25 2024 Remi Collet <remi@remirepo.net> - 2.2.4-1
- update to 2.2.4 (no change)