summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2025-04-28 08:18:38 +0200
committerRemi Collet <remi@php.net>2025-04-28 08:18:38 +0200
commitf99ddf8531f826dc7ac56759c20dfa274e25fd45 (patch)
tree5d6655b26ff11a4ae1233fb81aafa17b9ea17a1c
parent6296f99b3b6b4e986783ae5dc853be58447f8074 (diff)
update to 2.6.7HEADmaster
raise dependency on tecnickcom/tc-lib-file 2.1.4 see https://github.com/tecnickcom/tc-lib-pdf-font/pull/10
-rw-r--r--composer.json4
-rw-r--r--php-tecnickcom-tc-lib-pdf-font.spec13
2 files changed, 11 insertions, 6 deletions
diff --git a/composer.json b/composer.json
index 1f04da1..78b8a77 100644
--- a/composer.json
+++ b/composer.json
@@ -32,8 +32,8 @@
"require-dev": {
"pdepend/pdepend": "2.16.2",
"phpmd/phpmd": "2.15.0",
- "phpunit/phpunit": "12.0.1 || 11.5.7 || 10.5.40",
- "squizlabs/php_codesniffer": "3.11.3"
+ "phpunit/phpunit": "12.1.3 || 11.5.7 || 10.5.40",
+ "squizlabs/php_codesniffer": "3.12.2"
},
"autoload": {
"psr-4": {
diff --git a/php-tecnickcom-tc-lib-pdf-font.spec b/php-tecnickcom-tc-lib-pdf-font.spec
index 55fb90f..3e0a761 100644
--- a/php-tecnickcom-tc-lib-pdf-font.spec
+++ b/php-tecnickcom-tc-lib-pdf-font.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 316bdc5bdf820a564be05d7efcb194254f8982c3
+%global gh_commit 55e56421150d15930f81c6469d08819a53ef96c1
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -16,7 +16,7 @@
%global font_version 2.1.0
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.6.6
+Version: 2.6.7
Release: 1%{?dist}
Summary: PHP library containing PDF page formats and definitions
@@ -38,7 +38,7 @@ BuildRequires: php-json
BuildRequires: php-pcre
BuildRequires: php-spl
BuildRequires: php-zlib
-BuildRequires: (php-composer(%{c_vendor}/tc-lib-file) >= 2.1 with php-composer(%{c_vendor}/tc-lib-file) < 3)
+BuildRequires: (php-composer(%{c_vendor}/tc-lib-file) >= 2.1.4 with php-composer(%{c_vendor}/tc-lib-file) < 3)
BuildRequires: (php-composer(%{c_vendor}/tc-lib-unicode-data) >= 2.0 with php-composer(%{c_vendor}/tc-lib-unicode-data) < 3)
BuildRequires: (php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 2.1 with php-composer(%{c_vendor}/tc-lib-pdf-encrypt) < 3)
%endif
@@ -57,7 +57,7 @@ Requires: php-json
Requires: php-pcre
Requires: php-spl
Requires: php-zlib
-Requires: (php-composer(%{c_vendor}/tc-lib-file) >= 2.1 with php-composer(%{c_vendor}/tc-lib-file) < 3)
+Requires: (php-composer(%{c_vendor}/tc-lib-file) >= 2.1.4 with php-composer(%{c_vendor}/tc-lib-file) < 3)
Requires: (php-composer(%{c_vendor}/tc-lib-unicode-data) >= 2.0 with php-composer(%{c_vendor}/tc-lib-unicode-data) < 3)
Requires: (php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 2.1 with php-composer(%{c_vendor}/tc-lib-pdf-encrypt) < 3)
# From phpcompatinfo report for version 2.0.8
@@ -143,6 +143,11 @@ exit $ret
%changelog
+* Mon Apr 28 2025 Remi Collet <remi@remirepo.net> - 2.6.7-1
+- update to 2.6.7
+- raise dependency on tecnickcom/tc-lib-file 2.1.4
+ see https://github.com/tecnickcom/tc-lib-pdf-font/pull/10
+
* Fri Feb 7 2025 Remi Collet <remi@remirepo.net> - 2.6.6-1
- update to 2.6.6