summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-12-26 08:15:27 +0100
committerRemi Collet <remi@php.net>2024-12-26 08:15:27 +0100
commit085bfb01cb86b110d55aab7336b8a824fd3a2ca3 (patch)
tree0a79ee3a21a57ac87e8a819d5cfb9d07c1ae3ffc
parentc3de88ad4895ff358466d8c05fd1160c6c6fb746 (diff)
update to 2.1.10HEADmaster
raise dependency on PHP 8.1
-rw-r--r--composer.json10
-rw-r--r--php-tecnickcom-tc-lib-pdf-encrypt.spec16
2 files changed, 15 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index 7f5952f..b46247c 100644
--- a/composer.json
+++ b/composer.json
@@ -20,7 +20,7 @@
}
],
"require": {
- "php": ">=8.0",
+ "php": ">=8.1",
"ext-date": "*",
"ext-hash": "*",
"ext-openssl": "*",
@@ -30,10 +30,10 @@
"ext-posix": "*"
},
"require-dev": {
- "pdepend/pdepend": "2.13.0",
- "phpmd/phpmd": "2.13.0",
- "phpunit/phpunit": "10.1.2 || 9.6.13",
- "squizlabs/php_codesniffer": "3.7.2"
+ "pdepend/pdepend": "2.16.2",
+ "phpmd/phpmd": "2.15.0",
+ "phpunit/phpunit": "11.5.2 || 10.5.40",
+ "squizlabs/php_codesniffer": "3.11.2"
},
"autoload": {
"psr-4": {
diff --git a/php-tecnickcom-tc-lib-pdf-encrypt.spec b/php-tecnickcom-tc-lib-pdf-encrypt.spec
index cf82ae3..dbb85df 100644
--- a/php-tecnickcom-tc-lib-pdf-encrypt.spec
+++ b/php-tecnickcom-tc-lib-pdf-encrypt.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit a328be875038c7d5c8f82bc037bd3acd5841adef
+%global gh_commit eaf0b9ebd96322e56e66a48a3077a20ad75f4862
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.1.9
+Version: 2.1.10
Release: 1%{?dist}
Summary: PHP library to encrypt data for PDF
@@ -26,24 +26,24 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
BuildArch: noarch
%if %{with_tests}
# For tests
-BuildRequires: php(language) >= 8.0
+BuildRequires: php(language) >= 8.1
BuildRequires: php-date
BuildRequires: php-hash
BuildRequires: php-openssl
BuildRequires: php-pcre
BuildRequires: php-posix
%global phpunit %{_bindir}/phpunit10
-BuildRequires: phpunit10 >= 10.1.2
+BuildRequires: phpunit10 >= 10.5.40
%endif
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
-# "php": ">=8.0",
+# "php": ">=8.1",
# "ext-date": "*",
# "ext-hash": "*",
# "ext-openssl": "*",
# "ext-pcre": "*",
-Requires: php(language) >= 8.0
+Requires: php(language) >= 8.1
Requires: php-date
Requires: php-hash
Requires: php-openssl
@@ -119,6 +119,10 @@ exit $ret
%changelog
+* Thu Dec 26 2024 Remi Collet <remi@remirepo.net> - 2.1.10-1
+- update to 2.1.10
+- raise dependency on PHP 8.1
+
* Mon Dec 23 2024 Remi Collet <remi@remirepo.net> - 2.1.9-1
- update to 2.1.9 (no change)
- re-license spec file to CECILL-2.1