summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json10
-rw-r--r--php-tecnickcom-tc-lib-file.spec16
2 files changed, 15 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index cc1a135..59b1154 100644
--- a/composer.json
+++ b/composer.json
@@ -22,15 +22,15 @@
}
],
"require": {
- "php": ">=8.0",
+ "php": ">=8.1",
"ext-curl": "*",
"ext-pcre": "*"
},
"require-dev": {
- "pdepend/pdepend": "2.13.0",
- "phpmd/phpmd": "2.13.0",
- "phpunit/phpunit": "10.1.2 || 9.6.13",
- "squizlabs/php_codesniffer": "3.7.2"
+ "pdepend/pdepend": "2.16.2",
+ "phpmd/phpmd": "2.15.0",
+ "phpunit/phpunit": "11.5.2 || 10.5.40",
+ "squizlabs/php_codesniffer": "3.11.2"
},
"autoload": {
"psr-4": {
diff --git a/php-tecnickcom-tc-lib-file.spec b/php-tecnickcom-tc-lib-file.spec
index 1bee265..a5d625b 100644
--- a/php-tecnickcom-tc-lib-file.spec
+++ b/php-tecnickcom-tc-lib-file.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 35e6c9cfae8c785d84657c355c273a116b9db3f7
+%global gh_commit f550489aaa828f4275d047f9787b19dddef1f206
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.1.1
+Version: 2.1.2
Release: 1%{?dist}
Summary: PHP library to read byte-level data from files
@@ -27,18 +27,18 @@ BuildArch: noarch
%if %{with_tests}
# For tests
%global phpunit %{_bindir}/phpunit10
-BuildRequires: phpunit10 >= 10.1.2
-BuildRequires: php(language) >= 8.0
+BuildRequires: phpunit10 >= 10.5.40
+BuildRequires: php(language) >= 8.1
BuildRequires: php-curl
BuildRequires: php-pcre
%endif
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
-# "php": ">=8.0",
+# "php": ">=8.1",
# "ext-curl": "*",
# "ext-pcre": "*"
-Requires: php(language) >= 8.0
+Requires: php(language) >= 8.1
Requires: php-curl
Requires: php-pcre
# From phpcompatinfo report for version 1.6.4
@@ -109,6 +109,10 @@ exit $ret
%changelog
+* Thu Dec 26 2024 Remi Collet <remi@remirepo.net> - 2.1.2-1
+- update to 2.1.2
+- raise dependency on PHP 8.1
+
* Mon Dec 23 2024 Remi Collet <remi@remirepo.net> - 2.1.1-1
- update to 2.1.1
- re-license spec file to CECILL-2.1