summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json10
-rw-r--r--php-tecnickcom-tc-lib-color.spec27
2 files changed, 22 insertions, 15 deletions
diff --git a/composer.json b/composer.json
index a6b2567..1c27a5a 100644
--- a/composer.json
+++ b/composer.json
@@ -26,14 +26,14 @@
}
],
"require": {
- "php": ">=8.0",
+ "php": ">=8.1",
"ext-pcre": "*"
},
"require-dev": {
- "pdepend/pdepend": "2.13.0",
- "phpmd/phpmd": "2.13.0",
- "phpunit/phpunit": "10.1.2 || 9.6.13",
- "squizlabs/php_codesniffer": "3.7.2"
+ "pdepend/pdepend": "2.16.2",
+ "phpmd/phpmd": "2.15.0",
+ "phpunit/phpunit": "11.5.2 || 10.5.40",
+ "squizlabs/php_codesniffer": "3.11.2"
},
"autoload": {
"psr-4": {
diff --git a/php-tecnickcom-tc-lib-color.spec b/php-tecnickcom-tc-lib-color.spec
index 69679a3..6637914 100644
--- a/php-tecnickcom-tc-lib-color.spec
+++ b/php-tecnickcom-tc-lib-color.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-tecnickcom-tc-lib-color
#
-# Copyright (c) 2015-2024 Remi Collet
-# License: CC-BY-SA-4.0
-# http://creativecommons.org/licenses/by-sa/4.0/
+# SPDX-FileCopyrightText: Copyright 2015-2024 Remi Collet
+# SPDX-License-Identifier: CECILL-2.1
+# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
#
# Please, preserve the changelog entries
#
-%global gh_commit bddf746992e46026ac7387d56042ba6d9d14573d
+%global gh_commit 5fe3c1771ab577572b3304d11496745aff45db8e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.2.5
+Version: 2.2.7
Release: 1%{?dist}
Summary: PHP library to manipulate various color representations
@@ -27,16 +27,16 @@ BuildArch: noarch
%if %{with_tests}
# For tests
%global phpunit %{_bindir}/phpunit10
-BuildRequires: phpunit10 >= 10.1.2
-BuildRequires: php(language) >= 8.0
+BuildRequires: phpunit10 >= 10.5.40
+BuildRequires: php(language) >= 8.1
BuildRequires: php-pcre
%endif
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
-# "php": ">=8.0",
+# "php": ">=8.1",
# "ext-pcre": "*"
-Requires: php(language) >= 8.0
+Requires: php(language) >= 8.1
Requires: php-pcre
# From phpcompatinfo report for version 1.12.4
# none
@@ -93,7 +93,6 @@ for cmdarg in php php81 php82 php83 php84; do
cp phpunit.xml.dist phpunit.xml
$1 ${2:-%{phpunit}} --migrate-configuration || :
$1 ${2:-%{phpunit}} --no-coverage \
- --filter '^((?!(testGetColorObject|testGetColorObj)).)*$' \
|| ret=1
fi
done
@@ -113,6 +112,14 @@ exit $ret
%changelog
+* Thu Dec 26 2024 Remi Collet <remi@remirepo.net> - 2.2.7-1
+- update to 2.2.7
+- raise dependency on PHP 8.1
+
+* Mon Dec 23 2024 Remi Collet <remi@remirepo.net> - 2.2.6-1
+- update to 2.2.6 (no change)
+- re-license spec file to CECILL-2.1
+
* Mon Nov 25 2024 Remi Collet <remi@remirepo.net> - 2.2.5-1
- update to 2.2.5 (no change)