summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-12-26 08:13:13 +0100
committerRemi Collet <remi@php.net>2024-12-26 08:13:13 +0100
commita5a9d3c8e49687e0985a601713c7786604597aba (patch)
tree3c89c9fdb4668f9d922f650985023630b11844dd
parent79d17634f9c5e8f9b00187a81305b1f672f3c00c (diff)
update to 2.2.7HEADmaster
raise dependency on PHP 8.1
-rw-r--r--composer.json10
-rw-r--r--php-tecnickcom-tc-lib-color.spec17
2 files changed, 15 insertions, 12 deletions
diff --git a/composer.json b/composer.json
index a6b2567..1c27a5a 100644
--- a/composer.json
+++ b/composer.json
@@ -26,14 +26,14 @@
}
],
"require": {
- "php": ">=8.0",
+ "php": ">=8.1",
"ext-pcre": "*"
},
"require-dev": {
- "pdepend/pdepend": "2.13.0",
- "phpmd/phpmd": "2.13.0",
- "phpunit/phpunit": "10.1.2 || 9.6.13",
- "squizlabs/php_codesniffer": "3.7.2"
+ "pdepend/pdepend": "2.16.2",
+ "phpmd/phpmd": "2.15.0",
+ "phpunit/phpunit": "11.5.2 || 10.5.40",
+ "squizlabs/php_codesniffer": "3.11.2"
},
"autoload": {
"psr-4": {
diff --git a/php-tecnickcom-tc-lib-color.spec b/php-tecnickcom-tc-lib-color.spec
index 479319a..6637914 100644
--- a/php-tecnickcom-tc-lib-color.spec
+++ b/php-tecnickcom-tc-lib-color.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit f0f38cfd50bbeb3d40b4320bc1038e3e777e7b68
+%global gh_commit 5fe3c1771ab577572b3304d11496745aff45db8e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.2.6
+Version: 2.2.7
Release: 1%{?dist}
Summary: PHP library to manipulate various color representations
@@ -27,16 +27,16 @@ BuildArch: noarch
%if %{with_tests}
# For tests
%global phpunit %{_bindir}/phpunit10
-BuildRequires: phpunit10 >= 10.1.2
-BuildRequires: php(language) >= 8.0
+BuildRequires: phpunit10 >= 10.5.40
+BuildRequires: php(language) >= 8.1
BuildRequires: php-pcre
%endif
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
-# "php": ">=8.0",
+# "php": ">=8.1",
# "ext-pcre": "*"
-Requires: php(language) >= 8.0
+Requires: php(language) >= 8.1
Requires: php-pcre
# From phpcompatinfo report for version 1.12.4
# none
@@ -93,7 +93,6 @@ for cmdarg in php php81 php82 php83 php84; do
cp phpunit.xml.dist phpunit.xml
$1 ${2:-%{phpunit}} --migrate-configuration || :
$1 ${2:-%{phpunit}} --no-coverage \
- --filter '^((?!(testGetColorObject|testGetColorObj)).)*$' \
|| ret=1
fi
done
@@ -113,6 +112,10 @@ exit $ret
%changelog
+* Thu Dec 26 2024 Remi Collet <remi@remirepo.net> - 2.2.7-1
+- update to 2.2.7
+- raise dependency on PHP 8.1
+
* Mon Dec 23 2024 Remi Collet <remi@remirepo.net> - 2.2.6-1
- update to 2.2.6 (no change)
- re-license spec file to CECILL-2.1