summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--php-tecnickcom-tc-lib-barcode.spec34
2 files changed, 12 insertions, 24 deletions
diff --git a/composer.json b/composer.json
index 49f123a..8cda6d6 100644
--- a/composer.json
+++ b/composer.json
@@ -58,7 +58,7 @@
"ext-date": "*",
"ext-gd": "*",
"ext-pcre": "*",
- "tecnickcom/tc-lib-color": "^2.0"
+ "tecnickcom/tc-lib-color": "^2.2"
},
"require-dev": {
"pdepend/pdepend": "2.13.0",
diff --git a/php-tecnickcom-tc-lib-barcode.spec b/php-tecnickcom-tc-lib-barcode.spec
index 634ed99..a1a1f60 100644
--- a/php-tecnickcom-tc-lib-barcode.spec
+++ b/php-tecnickcom-tc-lib-barcode.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-tecnickcom-tc-lib-barcode
#
-# Copyright (c) 2015-2023 Remi Collet
+# Copyright (c) 2015-2024 Remi Collet
# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit 6877202fe7b3f746f22032e22d454c60c3db20fc
+%global gh_commit 1ec056eb68daf8aab072d9d7908712d7144814fa
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%bcond_without tests
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.2.1
+Version: 2.2.3
Release: 1%{?dist}
Summary: PHP library to generate linear and bidimensional barcodes
@@ -29,14 +29,7 @@ BuildArch: noarch
%global phpunit %{_bindir}/phpunit10
BuildRequires: phpunit10 >= 10.1.2
BuildRequires: php(language) >= 8.0
-# remirepo:1
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(%{c_vendor}/tc-lib-color) >= 2.0 with php-composer(%{c_vendor}/tc-lib-color) < 3)
-# remirepo:4
-%else
-BuildRequires: php-%{c_vendor}-tc-lib-color < 3
-BuildRequires: php-%{c_vendor}-tc-lib-color >= 2.0
-%endif
+BuildRequires: (php-composer(%{c_vendor}/tc-lib-color) >= 2.2 with php-composer(%{c_vendor}/tc-lib-color) < 3)
BuildRequires: php-bcmath
BuildRequires: php-ctype
BuildRequires: php-date
@@ -53,21 +46,14 @@ BuildRequires: php-fedora-autoloader-devel
# "ext-date": "*",
# "ext-gd": "*",
# "ext-pcre": "*",
-# "tecnickcom/tc-lib-color": "^2.0"
+# "tecnickcom/tc-lib-color": "^2.2"
Requires: php(language) >= 8.0
Requires: php-bcmath
Requires: php-ctype
Requires: php-date
Requires: php-gd
Requires: php-pcre
-# remirepo:1
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(%{c_vendor}/tc-lib-color) >= 2.0 with php-composer(%{c_vendor}/tc-lib-color) < 3)
-# remirepo:4
-%else
-Requires: php-%{c_vendor}-tc-lib-color < 3
-Requires: php-%{c_vendor}-tc-lib-color >= 2.0
-%endif
+Requires: (php-composer(%{c_vendor}/tc-lib-color) >= 2.2 with php-composer(%{c_vendor}/tc-lib-color) < 3)
# From phpcompatinfo report for version 1.15.5
# none
Requires: php-composer(fedora/autoloader)
@@ -127,7 +113,7 @@ require '%{buildroot}%{php_project}/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" php81 php82 php83; do
+for cmdarg in "php %{phpunit}" php81 php82 php83 php84; do
if which $cmdarg; then
set $cmdarg
cp phpunit.xml.dist phpunit.xml
@@ -144,8 +130,6 @@ exit $ret
%files
-# remirepo:1
-%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc composer.json
%doc *.md example
@@ -153,6 +137,10 @@ exit $ret
%changelog
+* Mon Aug 19 2024 Remi Collet <remi@remirepo.net> - 2.2.3-1
+- update to 2.2.3 (no change)
+- raise dependency on tc-lib-color 2.2
+
* Fri Apr 12 2024 Remi Collet <remi@remirepo.net> - 2.2.1-1
- update to 2.2.1