summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-symfony-pr19255.patch36
-rw-r--r--php-symfony.spec12
2 files changed, 5 insertions, 43 deletions
diff --git a/php-symfony-pr19255.patch b/php-symfony-pr19255.patch
deleted file mode 100644
index afecb37..0000000
--- a/php-symfony-pr19255.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 7696c95b17a7391fc6a1d48ff9d46512dd5e9d46 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Fri, 1 Jul 2016 08:55:04 +0200
-Subject: [PATCH] skip test with current phpunit bridge
-
----
- .../Component/DependencyInjection/Tests/ContainerBuilderTest.php | 3 +++
- src/Symfony/Component/Yaml/Tests/ParserTest.php | 1 +
- 2 files changed, 4 insertions(+)
-
-diff --git a/src/Symfony/Component/DependencyInjection/Tests/ContainerBuilderTest.php b/src/Symfony/Component/DependencyInjection/Tests/ContainerBuilderTest.php
-index f9f6aab..ac66d48 100644
---- a/src/Symfony/Component/DependencyInjection/Tests/ContainerBuilderTest.php
-+++ b/src/Symfony/Component/DependencyInjection/Tests/ContainerBuilderTest.php
-@@ -60,6 +60,9 @@ public function testDefinitions()
- }
- }
-
-+ /**
-+ * @requires function Symfony\Bridge\PhpUnit\ErrorAssert::assertDeprecationsAreTriggered
-+ */
- public function testCreateDeprecatedService()
- {
- ErrorAssert::assertDeprecationsAreTriggered('The "deprecated_foo" service is deprecated. You should stop using it, as it will soon be removed.', function () {
-diff --git a/src/Symfony/Component/Yaml/Tests/ParserTest.php b/src/Symfony/Component/Yaml/Tests/ParserTest.php
-index 7b36819..9e9a715 100644
---- a/src/Symfony/Component/Yaml/Tests/ParserTest.php
-+++ b/src/Symfony/Component/Yaml/Tests/ParserTest.php
-@@ -928,6 +928,7 @@ public function testFloatKeys()
- /**
- * @group legacy
- * throw ParseException in Symfony 3.0
-+ * @requires function Symfony\Bridge\PhpUnit\ErrorAssert::assertDeprecationsAreTriggered
- */
- public function testColonInMappingValueException()
- {
diff --git a/php-symfony.spec b/php-symfony.spec
index 1450cc5..da5a8ec 100644
--- a/php-symfony.spec
+++ b/php-symfony.spec
@@ -13,8 +13,8 @@
%global github_owner symfony
%global github_name symfony
-%global github_version 2.8.8
-%global github_commit 038d13264f732f9bba850c423e374dc72874d1a6
+%global github_version 2.8.9
+%global github_commit df02dd5d3f7decb3a05c6d0f31054b4263625dcb
%global github_short %(c=%{github_commit}; echo ${c:0:7})
%global composer_vendor symfony
@@ -114,9 +114,6 @@ License: MIT
URL: http://symfony.com
Source0: https://github.com/%{github_owner}/%{github_name}/archive/%{github_commit}/%{name}-%{github_version}-%{github_short}.tar.gz
-# https://github.com/symfony/symfony/pull/19255
-Patch0: %{name}-pr19255.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
# Tests
@@ -1756,8 +1753,6 @@ The YAML Component loads and dumps YAML files.
%prep
%setup -qn %{github_name}-%{github_commit}
-%patch0 -p1
-
: Remove unnecessary files
find src -name '.git*' -delete
@@ -2683,6 +2678,9 @@ exit $RET
# ##############################################################################
%changelog
+* Sat Jul 30 2016 Remi Collet <remi@fedoraproject.org> - 2.8.9-1
+- Update to 2.8.9
+
* Fri Jul 1 2016 Remi Collet <remi@fedoraproject.org> - 2.8.8-1
- Update to 2.8.8
- add patch for test suite with phpunit-bridge 2.8