summaryrefslogtreecommitdiffstats
path: root/php-solidworx-aspect.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-solidworx-aspect.spec')
-rw-r--r--php-solidworx-aspect.spec15
1 files changed, 9 insertions, 6 deletions
diff --git a/php-solidworx-aspect.spec b/php-solidworx-aspect.spec
index 9738ebc..9db7f97 100644
--- a/php-solidworx-aspect.spec
+++ b/php-solidworx-aspect.spec
@@ -14,7 +14,7 @@
# Extension
%global ext_name aspect
%global ini_name 40-%{ext_name}.ini
-%global upstream_version 0.1.0
+%global upstream_version 0.1.1
#global upstream_prever RC1
# PIE / packagist
%global pie_vend solidworx
@@ -23,20 +23,18 @@
%global gh_vend SolidWorx
%global gh_proj aspect
%global forgeurl https://github.com/%{gh_vend}/%{gh_proj}
-#global commit f199ab98496db0d040545ca10d1b7fdc166186e3
+#global commit b3ae87353da524f33374ee0418ad48f704bb6af1
%global tag %{upstream_version}%{?upstream_prever}
%forgemeta
Summary: PHP Aspect Extension
Name: %{?scl_prefix}php-%{pie_vend}-%{pie_proj}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: MIT
URL: %{forgeurl}
Source0: %{forgesource}
-Patch0: https://patch-diff.githubusercontent.com/raw/SolidWorx/aspect/pull/2.patch
-
BuildRequires: make
BuildRequires: gcc
BuildRequires: %{?scl_prefix}php-devel >= 8.0
@@ -61,7 +59,8 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%forgesetup
-%patch -P0 -p1
+
+sed -e '/PHP_ASPECT_VERSION/s/0.1.0/%{upstream_version}%{?upstream_prever}/' -i php_aspect.h
: Sanity check, really often broken
extver=$(sed -n '/# define PHP_ASPECT_VERSION/{s/.* "//;s/".*$//;p}' php_aspect.h)
@@ -118,6 +117,10 @@ TEST_PHP_ARGS="-n -d extension=%{buildroot}/%{php_extdir}/%{ext_name}.so" \
%changelog
+* Tue Jan 14 2025 Remi Collet <remi@remirepo.net> - 0.1.1-1
+- update to 0.1.1
+- drop patch merged upstream
+
* Tue Jan 14 2025 Remi Collet <remi@remirepo.net> - 0.1.0-2
- fix build with PHP 8.0 using patch from
https://github.com/SolidWorx/aspect/pull/2