summaryrefslogtreecommitdiffstats
path: root/php-solidworx-aspect.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-solidworx-aspect.spec')
-rw-r--r--php-solidworx-aspect.spec117
1 files changed, 117 insertions, 0 deletions
diff --git a/php-solidworx-aspect.spec b/php-solidworx-aspect.spec
new file mode 100644
index 0000000..9193837
--- /dev/null
+++ b/php-solidworx-aspect.spec
@@ -0,0 +1,117 @@
+# remirepo spec file for php-solidworx-aspect
+#
+# SPDX-FileCopyrightText: Copyright 2025 Remi Collet
+# SPDX-License-Identifier: CECILL-2.1
+# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
+#
+# Please, preserve the changelog entries
+#
+
+%{?scl:%scl_package php-solidworx-aspect}
+
+%bcond_without tests
+
+# PIE / packagist
+%global pie_vend solidworx
+%global pie_proj aspect
+# Github
+%global gh_vend SolidWorx
+%global gh_proj aspect
+%global gh_commit f199ab98496db0d040545ca10d1b7fdc166186e3
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+# Extension
+%global ext_name aspect
+%global ini_name 40-%{ext_name}.ini
+%global upstream_version 0.1.0
+#global upstream_prever RC1
+
+Summary: PHP Aspect Extension
+Name: %{?scl_prefix}php-%{pie_vend}-%{pie_proj}
+Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+License: MIT
+URL: https://github.com/%{gh_vend}/%{gh_proj}
+Source0: %{URL}/archive/%{gh_commit}/%{gh_proj}-%{upstream_version}%{?upstream_prever}-%{gh_short}.tar.gz
+
+BuildRequires: make
+BuildRequires: gcc
+BuildRequires: %{?scl_prefix}php-devel >= 8.0
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+
+Provides: %{?scl_prefix}php-%{ext_name} = %{version}
+Provides: %{?scl_prefix}php-%{ext_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pie(%{pie_vend}/%{pie_proj}) = %{version}
+
+
+%description
+Aspect is a PHP extension that provides a collection of utilities designed
+to enhance your development workflow. By introducing advanced features like
+attribute-based memoization, Aspect allows developers to write more efficient,
+clean, and maintainable code without the overhead of implementing complex
+patterns manually.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%prep
+%setup -q -n %{gh_proj}-%{gh_commit}
+
+: Sanity check, really often broken
+extver=$(sed -n '/# define PHP_ASPECT_VERSION/{s/.* "//;s/".*$//;p}' php_aspect.h)
+if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}.
+ exit 1
+fi
+
+: Create configuration file
+cat << 'EOF' | tee %{ini_name}
+; Enable the %{summary}
+extension=%{ext_name}.so
+EOF
+
+
+%build
+%{__phpize}
+sed -e 's/INSTALL_ROOT/DESTDIR/' -i build/Makefile.global
+
+%configure \
+ --enable-aspect \
+ --with-libdir=%{_lib} \
+ --with-php-config=%{__phpconfig}
+
+%make_build
+
+
+%install
+%make_install
+
+# install config file
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+
+%check
+: Minimal load test for the extension
+%{__php} --no-php-ini \
+ --define extension=%{buildroot}/%{php_extdir}/%{ext_name}.so \
+ --modules | grep '^%{ext_name}$'
+
+%if %{with tests}
+: Upstream test suite for the extension
+TEST_PHP_ARGS="-n -d extension=%{buildroot}/%{php_extdir}/%{ext_name}.so" \
+%{__php} -n run-tests.php -q --show-diff %{?_smp_mflags}
+%endif
+
+
+%files
+%license LICENSE
+%doc composer.json
+%doc *.md
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{ext_name}.so
+
+
+%changelog
+* Fri Jan 10 2025 Remi Collet <remi@remirepo.net> - 0.1.0-1
+- initial package