summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-09-06 11:24:17 +0200
committerRemi Collet <remi@php.net>2024-09-06 11:24:17 +0200
commitab059ed839c39a0a3c96a0d9227184eff1048151 (patch)
tree7b3c9a22e7738d2403b4a75b45c5fbd101ee503e
parent11e5a042b8ca2999dae0ec1ad724d274fd042701 (diff)
update to 4.0.6HEADmaster
-rw-r--r--composer.json6
-rw-r--r--php-sabre-xml4.spec27
2 files changed, 11 insertions, 22 deletions
diff --git a/composer.json b/composer.json
index be2caeb..faf06b3 100644
--- a/composer.json
+++ b/composer.json
@@ -44,8 +44,8 @@
}
},
"require-dev": {
- "friendsofphp/php-cs-fixer": "^3.51",
- "phpstan/phpstan": "^1.10",
+ "friendsofphp/php-cs-fixer": "^3.64",
+ "phpstan/phpstan": "^1.12",
"phpunit/phpunit" : "^9.6"
},
"scripts": {
@@ -56,7 +56,7 @@
"phpstan analyse --generate-baseline phpstan-baseline.neon"
],
"cs-fixer": [
- "php-cs-fixer fix"
+ "PHP_CS_FIXER_IGNORE_ENV=true php-cs-fixer fix"
],
"phpunit": [
"phpunit --configuration tests/phpunit.xml"
diff --git a/php-sabre-xml4.spec b/php-sabre-xml4.spec
index a3e9d5a..9616a3d 100644
--- a/php-sabre-xml4.spec
+++ b/php-sabre-xml4.spec
@@ -10,7 +10,7 @@
%bcond_without tests
# Github
-%global gh_commit c29e49fcf9ca8ca058b1e350ee9abe4205c0de89
+%global gh_commit a89257fd188ce30e456b841b6915f27905dfdbe3
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sabre-io
%global gh_project xml
@@ -24,7 +24,7 @@
Name: php-%{pk_vendor}-%{pk_project}%{major}
Summary: XML library that you may not hate
-Version: 4.0.5
+Version: 4.0.6
Release: 1%{?dist}
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -39,19 +39,13 @@ BuildRequires: php(language) >= 7.4
BuildRequires: php-xmlwriter
BuildRequires: php-xmlreader
BuildRequires: php-dom
-# remirepo:1
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(sabre/uri) >= 2.0 with php-composer(sabre/uri) < 4)
-# remirepo:3
-%else
-BuildRequires: php-sabre-uri2
-%endif
BuildRequires: php-libxml
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer.json, "require-dev": {
-# "friendsofphp/php-cs-fixer": "^3.51",
-# "phpstan/phpstan": "^1.10",
+# "friendsofphp/php-cs-fixer": "^3.64",
+# "phpstan/phpstan": "^1.12",
# "phpunit/phpunit" : "^9.6"
BuildRequires: phpunit9 >= 9.6
%global phpunit %{_bindir}/phpunit9
@@ -70,13 +64,7 @@ Requires: php(language) >= 7.4
Requires: php-xmlwriter
Requires: php-xmlreader
Requires: php-dom
-# remirepo:1
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(sabre/uri) >= 2.0 with php-composer(sabre/uri) < 4)
-# remirepo:3
-%else
-Requires: php-sabre-uri2
-%endif
# From phpcompatinfo report for version 2.1.2
Requires: php-libxml
Requires: php-pcre
@@ -145,7 +133,7 @@ cd tests
: Run upstream test suite against installed library
ret=0
-for cmdarg in "php %{phpunit}" php81 php82 php83; do
+for cmdarg in "php %{phpunit}" php81 php82 php83 php84; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} || ret=1
@@ -158,8 +146,6 @@ exit $ret
%files
-# remirepo:1
-%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *md
%doc composer.json
@@ -167,6 +153,9 @@ exit $ret
%changelog
+* Fri Sep 6 2024 Remi Collet <remi@remirepo.net> - 4.0.6-1
+- update to 4.0.6
+
* Thu Apr 18 2024 Remi Collet <remi@remirepo.net> - 4.0.5-1
- update to 4.0.5