summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json4
-rw-r--r--php-sabre-xml2.spec9
2 files changed, 8 insertions, 5 deletions
diff --git a/composer.json b/composer.json
index b96587b..72cffb5 100644
--- a/composer.json
+++ b/composer.json
@@ -44,7 +44,7 @@
}
},
"require-dev": {
- "friendsofphp/php-cs-fixer": "~2.17.1",
+ "friendsofphp/php-cs-fixer": "~2.17.1||^3.63",
"phpstan/phpstan": "^0.12",
"phpunit/phpunit" : "^7.5 || ^8.5 || ^9.6"
},
@@ -53,7 +53,7 @@
"phpstan analyse lib tests"
],
"cs-fixer": [
- "php-cs-fixer fix"
+ "PHP_CS_FIXER_IGNORE_ENV=true php-cs-fixer fix"
],
"phpunit": [
"phpunit --configuration tests/phpunit.xml"
diff --git a/php-sabre-xml2.spec b/php-sabre-xml2.spec
index 000a531..0edcf55 100644
--- a/php-sabre-xml2.spec
+++ b/php-sabre-xml2.spec
@@ -10,7 +10,7 @@
%bcond_without tests
# Github
-%global gh_commit 88288712d45f694be3679a0db7dfb3770f08d4f0
+%global gh_commit 0734b7af7f045d9ffb0018929750c492698a1536
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sabre-io
%global gh_project xml
@@ -24,7 +24,7 @@
Name: php-%{pk_vendor}-%{pk_project}%{major}
Summary: XML library that you may not hate
-Version: 2.2.9
+Version: 2.2.10
Release: 1%{?dist}
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -44,7 +44,7 @@ BuildRequires: php-libxml
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer.json, "require-dev": {
-# "friendsofphp/php-cs-fixer": "~2.17.1",
+# "friendsofphp/php-cs-fixer": "~2.17.1||^3.63",
# "phpstan/phpstan": "^0.12",
# "phpunit/phpunit" : "^7.5 || ^8.5 || ^9.6"
BuildRequires: phpunit9 >= 9.6
@@ -153,6 +153,9 @@ exit $ret
%changelog
+* Wed Aug 28 2024 Remi Collet <remi@remirepo.net> - 2.2.10-1
+- update to 2.2.10 (no change, CS only)
+
* Fri Jul 26 2024 Remi Collet <remi@remirepo.net> - 2.2.9-1
- update to 2.2.9