summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--php-sabre-xml2.spec26
2 files changed, 9 insertions, 19 deletions
diff --git a/composer.json b/composer.json
index 4524cf5..b96587b 100644
--- a/composer.json
+++ b/composer.json
@@ -46,7 +46,7 @@
"require-dev": {
"friendsofphp/php-cs-fixer": "~2.17.1",
"phpstan/phpstan": "^0.12",
- "phpunit/phpunit" : "^7.5 || ^8.5 || ^9.0"
+ "phpunit/phpunit" : "^7.5 || ^8.5 || ^9.6"
},
"scripts": {
"phpstan": [
diff --git a/php-sabre-xml2.spec b/php-sabre-xml2.spec
index ee37672..15af2f2 100644
--- a/php-sabre-xml2.spec
+++ b/php-sabre-xml2.spec
@@ -10,7 +10,7 @@
%bcond_without tests
# Github
-%global gh_commit f1d53d55976bbd4cf3e640dda6ebc31120c71a4e
+%global gh_commit 1f89d65f366a8a79630c1f5717c823dc5f5fd673
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sabre-io
%global gh_project xml
@@ -24,7 +24,7 @@
Name: php-%{pk_vendor}-%{pk_project}%{major}
Summary: XML library that you may not hate
-Version: 2.2.7
+Version: 2.2.8
Release: 1%{?dist}
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -39,21 +39,15 @@ BuildRequires: php(language) >= 7.1
BuildRequires: php-xmlwriter
BuildRequires: php-xmlreader
BuildRequires: php-dom
-# remirepo:1
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(sabre/uri) >= 1.0 with php-composer(sabre/uri) < 3)
-# remirepo:3
-%else
-BuildRequires: php-sabre-uri2
-%endif
BuildRequires: php-libxml
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer.json, "require-dev": {
# "friendsofphp/php-cs-fixer": "~2.17.1",
# "phpstan/phpstan": "^0.12",
-# "phpunit/phpunit" : "^7.5 || ^8.5 || ^9.0"
-BuildRequires: phpunit9
+# "phpunit/phpunit" : "^7.5 || ^8.5 || ^9.6"
+BuildRequires: phpunit9 >= 9.6
%global phpunit %{_bindir}/phpunit9
%endif
# Autoloader
@@ -70,13 +64,7 @@ Requires: php(language) >= 7.1
Requires: php-xmlwriter
Requires: php-xmlreader
Requires: php-dom
-# remirepo:1
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(sabre/uri) >= 1.0 with php-composer(sabre/uri) < 3)
-# remirepo:3
-%else
-Requires: php-sabre-uri2
-%endif
# From phpcompatinfo report for version 2.1.2
Requires: php-libxml
Requires: php-pcre
@@ -145,7 +133,7 @@ cd tests
: Run upstream test suite against installed library
ret=0
-for cmdarg in "php %{phpunit}" php81 php82 php83; do
+for cmdarg in "php %{phpunit}" php81 php82 php83 php84; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} || ret=1
@@ -159,7 +147,6 @@ exit $ret
%files
# remirepo:1
-%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *md
%doc composer.json
@@ -167,6 +154,9 @@ exit $ret
%changelog
+* Thu Jul 25 2024 Remi Collet <remi@remirepo.net> - 2.2.8-1
+- update to 2.2.8
+
* Thu Apr 18 2024 Remi Collet <remi@remirepo.net> - 2.2.7-1
- update to 2.2.7