summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json10
-rw-r--r--php-sabre-uri2.spec23
2 files changed, 17 insertions, 16 deletions
diff --git a/composer.json b/composer.json
index 03c3387..ba4a8e0 100644
--- a/composer.json
+++ b/composer.json
@@ -37,11 +37,11 @@
}
},
"require-dev": {
- "friendsofphp/php-cs-fixer": "^3.17",
- "phpstan/phpstan": "^1.10",
- "phpstan/phpstan-phpunit": "^1.3",
- "phpstan/phpstan-strict-rules": "^1.5",
- "phpstan/extension-installer": "^1.3",
+ "friendsofphp/php-cs-fixer": "^3.63",
+ "phpstan/phpstan": "^1.12",
+ "phpstan/phpstan-phpunit": "^1.4",
+ "phpstan/phpstan-strict-rules": "^1.6",
+ "phpstan/extension-installer": "^1.4",
"phpunit/phpunit" : "^9.6"
},
"scripts": {
diff --git a/php-sabre-uri2.spec b/php-sabre-uri2.spec
index 6a3c086..477cca7 100644
--- a/php-sabre-uri2.spec
+++ b/php-sabre-uri2.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-sabre-uri2
#
-# Copyright (c) 2016-2022 Remi Collet
+# Copyright (c) 2016-2024 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -10,7 +10,7 @@
%bcond_without tests
# Github
-%global gh_commit 7e0e7dfd0b7e14346a27eabd66e843a6e7f1812b
+%global gh_commit b76524c22de90d80ca73143680a8e77b1266c291
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sabre-io
%global gh_project uri
@@ -24,7 +24,7 @@
Name: php-%{pk_vendor}-%{pk_project}%{major}
Summary: Functions for making sense out of URIs
-Version: 2.3.3
+Version: 2.3.4
Release: 1%{?dist}
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -37,11 +37,11 @@ BuildArch: noarch
%if %{with tests}
BuildRequires: php(language) >= 7.4
# From composer.json, "require-dev": {
-# "friendsofphp/php-cs-fixer": "^3.17",
-# "phpstan/phpstan": "^1.10",
-# "phpstan/phpstan-phpunit": "^1.3",
-# "phpstan/phpstan-strict-rules": "^1.5",
-# "phpstan/extension-installer": "^1.3",
+# "friendsofphp/php-cs-fixer": "^3.63",
+# "phpstan/phpstan": "^1.12",
+# "phpstan/phpstan-phpunit": "^1.4",
+# "phpstan/phpstan-strict-rules": "^1.6",
+# "phpstan/extension-installer": "^1.4",
# "phpunit/phpunit" : "^9.6"
BuildRequires: php-pcre
BuildRequires: phpunit9 >= 9.6
@@ -116,7 +116,7 @@ mkdir vendor
ln -s %{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}%{major}/autoload.php vendor/autoload.php
cd tests
-for cmdarg in "php %{phpunit}" php80 php81 php82 php83; do
+for cmdarg in "php %{phpunit}" php81 php82 php83 php84; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -129,8 +129,6 @@ exit $ret
%files
-# remirepo:1
-%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *md
%doc composer.json
@@ -139,6 +137,9 @@ exit $ret
%changelog
+* Wed Aug 28 2024 Remi Collet <remi@remirepo.net> - 2.3.4-1
+- update to 2.3.4 (no change, CS only)
+
* Mon Jun 12 2023 Remi Collet <remi@remirepo.net> - 2.3.3-1
- update to 2.3.3