summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-07-26 11:06:57 +0200
committerRemi Collet <remi@php.net>2024-07-26 11:06:57 +0200
commit494778cf0574ac386cea431626c430223622cbbf (patch)
treebe0b08ea9a19a6663af7e11dda79e2f206ec80ea
parent99d08049b306a4ee6ed397d625f1b4159222f82a (diff)
update to 5.1.11
-rw-r--r--composer.json2
-rw-r--r--php-sabre-http5.spec31
2 files changed, 10 insertions, 23 deletions
diff --git a/composer.json b/composer.json
index 353646a..0412b4d 100644
--- a/composer.json
+++ b/composer.json
@@ -15,7 +15,7 @@
"require-dev" : {
"friendsofphp/php-cs-fixer": "~2.17.1",
"phpstan/phpstan": "^0.12",
- "phpunit/phpunit" : "^7.5 || ^8.5 || ^9.0"
+ "phpunit/phpunit" : "^7.5 || ^8.5 || ^9.6"
},
"suggest" : {
"ext-curl" : " to make http requests with the Client class"
diff --git a/php-sabre-http5.spec b/php-sabre-http5.spec
index 7d7361e..47c55f2 100644
--- a/php-sabre-http5.spec
+++ b/php-sabre-http5.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-sabre-http5
#
-# Copyright (c) 2013-2023 Remi Collet
+# Copyright (c) 2013-2024 Remi Collet
# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -10,7 +10,7 @@
%bcond_without tests
# Github
-%global gh_commit f9f3d1fba8916fa2f4ec25636c4fedc26cb94e02
+%global gh_commit abb019d9415d8c6c39c377e212ef34ad727b711f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sabre-io
%global gh_project http
@@ -24,7 +24,7 @@
Name: php-%{pk_vendor}-%{pk_project}%{major}
Summary: Library for dealing with http requests and responses
-Version: 5.1.10
+Version: 5.1.11
Release: 1%{?dist}
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -36,20 +36,13 @@ BuildArch: noarch
BuildRequires: php(language) >= 7.1
BuildRequires: php-mbstring
BuildRequires: php-ctype
-# remirepo:1
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(sabre/event) >= 4.0 with php-composer(sabre/event) < 6)
BuildRequires: (php-composer(sabre/uri) >= 2.0 with php-composer(sabre/uri) < 3)
# From composer.json, "require-dev" : {
# "friendsofphp/php-cs-fixer": "~2.17.1",
# "phpstan/phpstan": "^0.12",
-# "phpunit/phpunit" : "^7.5 || ^8.5 || ^9.0"
-# remirepo:4
-%else
-BuildRequires: php-sabre-event5
-BuildRequires: php-sabre-uri2
-%endif
-BuildRequires: phpunit9
+# "phpunit/phpunit" : "^7.5 || ^8.5 || ^9.6"
+BuildRequires: phpunit9 >= 9.6
%global phpunit %{_bindir}/phpunit9
BuildRequires: php-curl
BuildRequires: php-date
@@ -72,15 +65,8 @@ Requires: php(language) >= 7.1
Requires: php-mbstring
Requires: php-ctype
Requires: php-curl
-# remirepo:1
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(sabre/event) >= 4.0 with php-composer(sabre/event) < 6)
Requires: (php-composer(sabre/uri) >= 2.0 with php-composer(sabre/uri) < 3)
-# remirepo:4
-%else
-Requires: php-sabre-event5
-Requires: php-sabre-uri2
-%endif
# From phpcompatinfo report for version 5.0.0
Requires: php-date
Requires: php-hash
@@ -172,7 +158,7 @@ PHPPID=$!
: Run upstream test suite against installed library
ret=0
-for cmdarg in "php %{phpunit}" php80 php81 php82 php83; do
+for cmdarg in "php %{phpunit}" php81 php82 php83 php84; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -188,8 +174,6 @@ exit $ret
%files
-# remirepo:1
-%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *md
%doc composer.json
@@ -197,6 +181,9 @@ exit $ret
%changelog
+* Fri Jul 26 2024 Remi Collet <remi@remirepo.net> - 5.1.11-1
+- update to 5.1.11
+
* Thu Aug 24 2023 Remi Collet <remi@remirepo.net> - 5.1.10-1
- update to 5.1.10