diff options
author | Remi Collet <remi@remirepo.net> | 2021-03-17 10:18:21 +0100 |
---|---|---|
committer | Remi Collet <remi@remirepo.net> | 2021-03-17 10:18:21 +0100 |
commit | 6b00c2b3db43d8bd4d2436a36a19a9f88ccaa859 (patch) | |
tree | 4571dbb7a0f0102317f8fc9028f7ac5a80e8813c /makesrc.sh | |
parent | 5002a1eb299dfc8c09577aaca0efeb248c5e0021 (diff) |
update to 9.5.3
Diffstat (limited to 'makesrc.sh')
-rwxr-xr-x | makesrc.sh | 36 |
1 files changed, 20 insertions, 16 deletions
@@ -1,28 +1,32 @@ #!/bin/bash NAME=$(basename $PWD) -OWNER=$(sed -n '/^%global gh_vendor/{s/.* //;p}' $NAME.spec) +OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec) PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec) -VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec) +VERSION=$(sed -n '/^%global upstream_version/{s/.* //;p}' $NAME.spec) COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec) SHORT=${COMMIT:0:7} -echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n" +if [ -f $NAME-$VERSION-$SHORT.tgz ]; then + echo "$NAME-$VERSION-$SHORT.tgz already there" +else + echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n" -echo "Cloning..." -rm -rf $PROJECT-$COMMIT -git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT + echo "Cloning..." + rm -rf $PROJECT-$COMMIT + git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT -echo "Getting commit..." -pushd $PROJECT-$COMMIT -git checkout $COMMIT -cp composer.json ../composer.json -popd + echo "Getting commit..." + pushd $PROJECT-$COMMIT + git checkout $COMMIT || exit1 + cp composer.json ../composer.json + popd -echo "Archiving..." -tar czf $NAME-$VERSION-$SHORT.tgz --exclude-vcs --exclude tools $PROJECT-$COMMIT + echo "Archiving..." + tar czf $NAME-$VERSION-$SHORT.tgz --exclude-vcs --exclude tools $PROJECT-$COMMIT -echo "Cleaning..." -rm -rf $PROJECT-$COMMIT + echo "Cleaning..." + rm -rf $PROJECT-$COMMIT -echo "Done." + echo "Done." +fi |