summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json4
-rw-r--r--phpunit11-rpm.patch30
-rw-r--r--phpunit11.spec25
3 files changed, 32 insertions, 27 deletions
diff --git a/composer.json b/composer.json
index 636f51f..4658623 100644
--- a/composer.json
+++ b/composer.json
@@ -29,7 +29,7 @@
"ext-mbstring": "*",
"ext-xml": "*",
"ext-xmlwriter": "*",
- "myclabs/deep-copy": "^1.12.0",
+ "myclabs/deep-copy": "^1.12.1",
"phar-io/manifest": "^2.0.4",
"phar-io/version": "^3.2.1",
"phpunit/php-code-coverage": "^11.0.7",
@@ -39,7 +39,7 @@
"phpunit/php-timer": "^7.0.1",
"sebastian/cli-parser": "^3.0.2",
"sebastian/code-unit": "^3.0.1",
- "sebastian/comparator": "^6.1.1",
+ "sebastian/comparator": "^6.2.1",
"sebastian/diff": "^6.0.2",
"sebastian/environment": "^7.2.0",
"sebastian/exporter": "^6.1.3",
diff --git a/phpunit11-rpm.patch b/phpunit11-rpm.patch
index bcc35c6..22b991f 100644
--- a/phpunit11-rpm.patch
+++ b/phpunit11-rpm.patch
@@ -1,6 +1,6 @@
diff -up ./phpunit.rpm ./phpunit
---- ./phpunit.rpm 2024-10-28 16:32:22.000000000 +0100
-+++ ./phpunit 2024-10-28 16:32:27.795731213 +0100
+--- ./phpunit.rpm 2024-11-28 07:29:40.000000000 +0100
++++ ./phpunit 2024-11-28 07:31:32.759973771 +0100
@@ -46,27 +46,13 @@ if (isset($GLOBALS['_composer_autoload_p
define('PHPUNIT_COMPOSER_INSTALL', $GLOBALS['_composer_autoload_path']);
@@ -50,8 +50,8 @@ diff -up ./phpunit.rpm ./phpunit
+ PHPUnit\TextUI\Command::main();
+}
diff -up ./src/TextUI/Command/Commands/VersionCheckCommand.php.rpm ./src/TextUI/Command/Commands/VersionCheckCommand.php
---- ./src/TextUI/Command/Commands/VersionCheckCommand.php.rpm 2024-10-28 16:32:22.000000000 +0100
-+++ ./src/TextUI/Command/Commands/VersionCheckCommand.php 2024-10-28 17:11:42.258839065 +0100
+--- ./src/TextUI/Command/Commands/VersionCheckCommand.php.rpm 2024-11-28 07:29:40.000000000 +0100
++++ ./src/TextUI/Command/Commands/VersionCheckCommand.php 2024-11-28 07:32:43.493663870 +0100
@@ -39,7 +39,7 @@ final readonly class VersionCheckCommand
assert($latestVersion !== false);
@@ -59,9 +59,9 @@ diff -up ./src/TextUI/Command/Commands/VersionCheckCommand.php.rpm ./src/TextUI/
- $latestCompatibleVersion = $this->downloader->download('https://phar.phpunit.de/latest-version-of/phpunit-' . $this->majorVersionNumber);
+ $latestCompatibleVersion = $this->downloader->download('https://phar.phpunit.de/latest-version-of/phpunit-' . $major=$this->majorVersionNumber);
- assert($latestCompatibleVersion !== false);
-
-@@ -52,11 +52,11 @@ final readonly class VersionCheckCommand
+ $notLatest = version_compare($latestVersion, $this->versionId, '>');
+ $notLatestCompatible = false;
+@@ -50,11 +50,11 @@ final readonly class VersionCheckCommand
if (!$notLatest && !$notLatestCompatible) {
return Result::from(
@@ -75,7 +75,7 @@ diff -up ./src/TextUI/Command/Commands/VersionCheckCommand.php.rpm ./src/TextUI/
if ($notLatestCompatible) {
$buffer .= sprintf(
-@@ -64,6 +64,7 @@ final readonly class VersionCheckCommand
+@@ -62,6 +62,7 @@ final readonly class VersionCheckCommand
$this->versionId,
$latestCompatibleVersion,
);
@@ -83,7 +83,7 @@ diff -up ./src/TextUI/Command/Commands/VersionCheckCommand.php.rpm ./src/TextUI/
}
if ($notLatest) {
-@@ -71,6 +72,9 @@ final readonly class VersionCheckCommand
+@@ -69,6 +70,9 @@ final readonly class VersionCheckCommand
'The latest version is PHPUnit %s.' . PHP_EOL,
$latestVersion,
);
@@ -94,8 +94,8 @@ diff -up ./src/TextUI/Command/Commands/VersionCheckCommand.php.rpm ./src/TextUI/
return Result::from($buffer, Result::FAILURE);
diff -up ./src/TextUI/Configuration/Xml/SchemaFinder.php.rpm ./src/TextUI/Configuration/Xml/SchemaFinder.php
---- ./src/TextUI/Configuration/Xml/SchemaFinder.php.rpm 2024-10-28 16:32:22.000000000 +0100
-+++ ./src/TextUI/Configuration/Xml/SchemaFinder.php 2024-10-28 16:32:27.795731213 +0100
+--- ./src/TextUI/Configuration/Xml/SchemaFinder.php.rpm 2024-11-28 07:29:40.000000000 +0100
++++ ./src/TextUI/Configuration/Xml/SchemaFinder.php 2024-11-28 07:31:32.759973771 +0100
@@ -77,6 +77,6 @@ final readonly class SchemaFinder
return __PHPUNIT_PHAR_ROOT__ . '/';
}
@@ -105,8 +105,8 @@ diff -up ./src/TextUI/Configuration/Xml/SchemaFinder.php.rpm ./src/TextUI/Config
}
}
diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
---- ./tests/bootstrap.php.rpm 2024-10-28 16:32:22.000000000 +0100
-+++ ./tests/bootstrap.php 2024-10-28 16:32:27.796731252 +0100
+--- ./tests/bootstrap.php.rpm 2024-11-28 07:29:40.000000000 +0100
++++ ./tests/bootstrap.php 2024-11-28 07:31:32.759973771 +0100
@@ -11,8 +11,8 @@ if (!defined('TEST_FILES_PATH')) {
define('TEST_FILES_PATH', __DIR__ . DIRECTORY_SEPARATOR . '_files' . DIRECTORY_SEPARATOR);
}
@@ -137,8 +137,8 @@ diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
if ($phar) {
diff -up ./tests/unit/TextUI/Command/Commands/VersionCheckCommandTest.php.rpm ./tests/unit/TextUI/Command/Commands/VersionCheckCommandTest.php
---- ./tests/unit/TextUI/Command/Commands/VersionCheckCommandTest.php.rpm 2024-10-28 16:32:22.000000000 +0100
-+++ ./tests/unit/TextUI/Command/Commands/VersionCheckCommandTest.php 2024-10-28 17:11:47.725052771 +0100
+--- ./tests/unit/TextUI/Command/Commands/VersionCheckCommandTest.php.rpm 2024-11-28 07:29:40.000000000 +0100
++++ ./tests/unit/TextUI/Command/Commands/VersionCheckCommandTest.php 2024-11-28 07:31:32.759973771 +0100
@@ -28,7 +28,7 @@ final class VersionCheckCommandTest exte
{
return [
diff --git a/phpunit11.spec b/phpunit11.spec
index 398ec97..7297f2c 100644
--- a/phpunit11.spec
+++ b/phpunit11.spec
@@ -20,8 +20,8 @@
%bcond_with defcmd
%endif
-%global gh_commit e8e8ed1854de5d36c088ec1833beae40d2dedd76
-%global gh_date 2024-10-28
+%global gh_commit f9ba7bd3c9f3ff54ec379d7a1c2e3f13fe0bbde4
+%global gh_date 2024-11-27
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project phpunit
@@ -34,12 +34,12 @@
%global ver_major 11
%global ver_minor 4
-%global upstream_version 11.4.3
+%global upstream_version 11.4.4
#global upstream_prever dev
Name: %{pk_project}%{ver_major}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}
+Release: 1%{?dist}
Summary: The PHP Unit Testing framework version %{ver_major}
License: BSD-3-Clause
@@ -53,7 +53,7 @@ Patch0: %{name}-rpm.patch
BuildArch: noarch
BuildRequires: php(language) >= 8.2
-BuildRequires: (php-composer(myclabs/deep-copy) >= 1.12.0 with php-composer(myclabs/deep-copy) < 2)
+BuildRequires: (php-composer(myclabs/deep-copy) >= 1.12.1 with php-composer(myclabs/deep-copy) < 2)
BuildRequires: (php-composer(phar-io/manifest) >= 2.0.4 with php-composer(phar-io/manifest) < 3)
BuildRequires: (php-composer(phar-io/version) >= 3.2.1 with php-composer(phar-io/version) < 4)
BuildRequires: (php-composer(phpunit/php-code-coverage) >= 11.0.7 with php-composer(phpunit/php-code-coverage) < 12)
@@ -63,7 +63,7 @@ BuildRequires: (php-composer(phpunit/php-text-template) >= 4.0.1 with php-c
BuildRequires: (php-composer(phpunit/php-timer) >= 7.0.1 with php-composer(phpunit/php-timer) < 8)
BuildRequires: (php-composer(sebastian/cli-parser) >= 3.0.2 with php-composer(sebastian/cli-parser) < 4)
BuildRequires: (php-composer(sebastian/code-unit) >= 3.0.1 with php-composer(sebastian/code-unit) < 4)
-BuildRequires: (php-composer(sebastian/comparator) >= 6.1.1 with php-composer(sebastian/comparator) < 7)
+BuildRequires: (php-composer(sebastian/comparator) >= 6.2.1 with php-composer(sebastian/comparator) < 7)
BuildRequires: (php-composer(sebastian/diff) >= 6.0.2 with php-composer(sebastian/diff) < 7)
BuildRequires: (php-composer(sebastian/environment) >= 7.2.0 with php-composer(sebastian/environment) < 8)
BuildRequires: (php-composer(sebastian/exporter) >= 6.1.3 with php-composer(sebastian/exporter) < 7)
@@ -88,7 +88,7 @@ BuildRequires: php-fedora-autoloader-devel >= 1.0.0
# "ext-mbstring": "*",
# "ext-xml": "*",
# "ext-xmlwriter": "*",
-# "myclabs/deep-copy": "^1.12.0",
+# "myclabs/deep-copy": "^1.12.1",
# "phar-io/manifest": "^2.0.4",
# "phar-io/version": "^3.2.1",
# "phpunit/php-code-coverage": "^11.0.7",
@@ -98,7 +98,7 @@ BuildRequires: php-fedora-autoloader-devel >= 1.0.0
# "phpunit/php-timer": "^7.0.1",
# "sebastian/cli-parser": "^3.0.2",
# "sebastian/code-unit": "^3.0.1",
-# "sebastian/comparator": "^6.1.1",
+# "sebastian/comparator": "^6.2.1",
# "sebastian/diff": "^6.0.2",
# "sebastian/environment": "^7.2.0",
# "sebastian/exporter": "^6.1.3",
@@ -114,7 +114,7 @@ Requires: php-libxml
Requires: php-mbstring
Requires: php-xml
Requires: php-xmlwriter
-Requires: (php-composer(myclabs/deep-copy) >= 1.12.0 with php-composer(myclabs/deep-copy) < 2)
+Requires: (php-composer(myclabs/deep-copy) >= 1.12.1 with php-composer(myclabs/deep-copy) < 2)
Requires: (php-composer(phar-io/manifest) >= 2.0.4 with php-composer(phar-io/manifest) < 3)
Requires: (php-composer(phar-io/version) >= 3.2.1 with php-composer(phar-io/version) < 4)
Requires: (php-composer(phpunit/php-code-coverage) >= 11.0.7 with php-composer(phpunit/php-code-coverage) < 12)
@@ -124,7 +124,7 @@ Requires: (php-composer(phpunit/php-text-template) >= 4.0.1 with php-c
Requires: (php-composer(phpunit/php-timer) >= 7.0.1 with php-composer(phpunit/php-timer) < 8)
Requires: (php-composer(sebastian/cli-parser) >= 3.0.2 with php-composer(sebastian/cli-parser) < 4)
Requires: (php-composer(sebastian/code-unit) >= 3.0.1 with php-composer(sebastian/code-unit) < 4)
-Requires: (php-composer(sebastian/comparator) >= 6.1.1 with php-composer(sebastian/comparator) < 7)
+Requires: (php-composer(sebastian/comparator) >= 6.2.1 with php-composer(sebastian/comparator) < 7)
Requires: (php-composer(sebastian/diff) >= 6.0.2 with php-composer(sebastian/diff) < 7)
Requires: (php-composer(sebastian/environment) >= 7.2.0 with php-composer(sebastian/environment) < 8)
Requires: (php-composer(sebastian/exporter) >= 6.1.3 with php-composer(sebastian/exporter) < 7)
@@ -280,6 +280,11 @@ exit $ret
%changelog
+* Thu Nov 28 2024 Remi Collet <remi@remirepo.net> - 11.4.4-1
+- update to 11.4.4
+- raise dependency on myclabs/deep-copy 1.12.1
+- raise dependency on sebastian/comparator 6.2.1
+
* Mon Oct 28 2024 Remi Collet <remi@remirepo.net> - 11.4.3-2
- update to 11.4.3