summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-10-09 09:13:48 +0200
committerRemi Collet <remi@php.net>2024-10-09 09:13:48 +0200
commit4489c68d27bd4b15a0b6085260fd8c704a56feb0 (patch)
tree2563128593fb9b419eed5f30edc1c6941ba58a92
parent676cdbc265fbb038b3b98a6d0ce339e4fff1780c (diff)
update to 11.4.1
-rw-r--r--composer.json21
-rw-r--r--phpunit11.spec38
2 files changed, 48 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index 027988b..0483ee8 100644
--- a/composer.json
+++ b/composer.json
@@ -71,10 +71,27 @@
},
"autoload-dev": {
"classmap": [
- "tests/"
+ "tests/_files"
],
"files": [
"tests/_files/deprecation-trigger/trigger_deprecation.php",
+ "tests/unit/Event/AbstractEventTestCase.php",
+ "tests/unit/Framework/MockObject/TestDoubleTestCase.php",
+ "tests/unit/Metadata/Parser/AnnotationParserTestCase.php",
+ "tests/unit/Metadata/Parser/AttributeParserTestCase.php",
+ "tests/unit/Framework/Assert/assertDirectoryExistsTest.php",
+ "tests/unit/Framework/Assert/assertFileExistsTest.php",
+ "tests/unit/Framework/Assert/assertIsNumericTest.php",
+ "tests/unit/Framework/Assert/assertIsObjectTest.php",
+ "tests/unit/Framework/Assert/assertIsReadableTest.php",
+ "tests/unit/Framework/Assert/assertIsResourceTest.php",
+ "tests/unit/Framework/Assert/assertIsScalarTest.php",
+ "tests/unit/Framework/Assert/assertIsStringTest.php",
+ "tests/unit/Framework/Assert/assertIsWritableTest.php",
+ "tests/unit/Framework/Assert/assertMatchesRegularExpressionTest.php",
+ "tests/unit/Framework/Assert/assertNullTest.php",
+ "tests/unit/Framework/Assert/assertSameSizeTest.php",
+ "tests/unit/Framework/Assert/assertSameTest.php",
"tests/_files/CoverageNamespacedFunctionTest.php",
"tests/_files/CoveredFunction.php",
"tests/_files/Generator.php",
@@ -83,7 +100,7 @@
},
"extra": {
"branch-alias": {
- "dev-main": "11.3-dev"
+ "dev-main": "11.4-dev"
}
}
}
diff --git a/phpunit11.spec b/phpunit11.spec
index c3f3c96..f26fcca 100644
--- a/phpunit11.spec
+++ b/phpunit11.spec
@@ -20,8 +20,8 @@
%bcond_with defcmd
%endif
-%global gh_commit d62c45a19c665bb872c2a47023a0baf41a98bb2b
-%global gh_date 2024-09-19
+%global gh_commit 7875627f15f4da7e7f0823d1f323f7295a77334e
+%global gh_date 2024-10-08
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project phpunit
@@ -32,9 +32,9 @@
%global ns_vendor PHPUnit11
%global php_home %{_datadir}/php
%global ver_major 11
-%global ver_minor 3
+%global ver_minor 4
-%global upstream_version 11.3.6
+%global upstream_version 11.4.1
#global upstream_prever dev
Name: %{pk_project}%{ver_major}
@@ -208,18 +208,32 @@ cat src/autoload.php
%{_bindir}/phpab \
--output tests/autoload.php \
- --exclude 'tests/end-to-end/regression/4376/tests/Test.php' \
- --exclude 'tests/end-to-end/regression/2448/Test.php' \
- --exclude 'tests/*/_files/*.php' \
- tests
+ tests/_files
cat << 'EOF' | tee -a tests/autoload.php
// Dependencies
\Fedora\Autoloader\Dependencies::required([
__DIR__ . '/_files/deprecation-trigger/trigger_deprecation.php',
+ __DIR__ . '/unit/Event/AbstractEventTestCase.php',
+ __DIR__ . '/unit/Framework/MockObject/TestDoubleTestCase.php',
+ __DIR__ . '/unit/Metadata/Parser/AnnotationParserTestCase.php',
+ __DIR__ . '/unit/Metadata/Parser/AttributeParserTestCase.php',
+ __DIR__ . '/unit/Framework/Assert/assertDirectoryExistsTest.php',
+ __DIR__ . '/unit/Framework/Assert/assertFileExistsTest.php',
+ __DIR__ . '/unit/Framework/Assert/assertIsNumericTest.php',
+ __DIR__ . '/unit/Framework/Assert/assertIsObjectTest.php',
+ __DIR__ . '/unit/Framework/Assert/assertIsReadableTest.php',
+ __DIR__ . '/unit/Framework/Assert/assertIsResourceTest.php',
+ __DIR__ . '/unit/Framework/Assert/assertIsScalarTest.php',
+ __DIR__ . '/unit/Framework/Assert/assertIsStringTest.php',
+ __DIR__ . '/unit/Framework/Assert/assertIsWritableTest.php',
+ __DIR__ . '/unit/Framework/Assert/assertMatchesRegularExpressionTest.php',
+ __DIR__ . '/unit/Framework/Assert/assertNullTest.php',
+ __DIR__ . '/unit/Framework/Assert/assertSameSizeTest.php',
+ __DIR__ . '/unit/Framework/Assert/assertSameTest.php',
__DIR__ . '/_files/CoverageNamespacedFunctionTest.php',
__DIR__ . '/_files/CoveredFunction.php',
+ __DIR__ . '/_files/Generator.php',
__DIR__ . '/_files/NamespaceCoveredFunction.php',
- __DIR__ . '/end-to-end/execution-order/_files/MultiDependencyTest.php',
]);
EOF
@@ -266,6 +280,12 @@ exit $ret
%changelog
+* Wed Oct 9 2024 Remi Collet <remi@remirepo.net> - 11.4.1-1
+- update to 11.4.1
+
+* Sun Oct 6 2024 Remi Collet <remi@remirepo.net> - 11.4.0-1
+- update to 11.4.0
+
* Thu Sep 19 2024 Remi Collet <remi@remirepo.net> - 11.3.6-1
- update to 11.3.6
- raise dependency on sebastian/type 5.1.0