diff options
author | Remi Collet <remi@remirepo.net> | 2024-01-14 08:41:37 +0100 |
---|---|---|
committer | Remi Collet <remi@php.net> | 2024-01-14 08:41:37 +0100 |
commit | 43a77b8c4c93d4eb5f6c524837d58cea3a97f0f8 (patch) | |
tree | 4b6fb1902e234c0141414dd60ba4699f75b6a7a4 | |
parent | ac4112aaa8434c373ad7f250aa0dc0bf50eb95d4 (diff) |
update to 10.5.6
-rwxr-xr-x | makesrc.sh | 5 | ||||
-rw-r--r-- | phpunit10.spec | 9 |
2 files changed, 9 insertions, 5 deletions
@@ -1,6 +1,7 @@ #!/bin/bash NAME=$(basename $PWD) +DATE=$(sed -n '/^%global gh_date/{s/.* //;p}' $NAME.spec) OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec) PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec) VERSION=$(sed -n '/^%global upstream_version/{s/.* //;p}' $NAME.spec) @@ -10,11 +11,11 @@ SHORT=${COMMIT:0:7} if [ -f $NAME-$VERSION-$SHORT.tgz ]; then echo "$NAME-$VERSION-$SHORT.tgz already there" else - echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n" + echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION, Date=$DATE\n" echo "Cloning..." rm -rf $PROJECT-$COMMIT - git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT + git clone --shallow-since=$DATE https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT || exit 1 echo "Getting commit..." pushd $PROJECT-$COMMIT diff --git a/phpunit10.spec b/phpunit10.spec index ce5ffdc..f257d53 100644 --- a/phpunit10.spec +++ b/phpunit10.spec @@ -20,8 +20,8 @@ %bcond_with defcmd %endif -%global gh_commit ed21115d505b4b4f7dc7b5651464e19a2c7f7856 -#global gh_date 20150927 +%global gh_commit ab9a20b623b235165d24faa9d1da925cb54939c0 +%global gh_date 2024-01-13 %global gh_short %(c=%{gh_commit}; echo ${c:0:7}) %global gh_owner sebastianbergmann %global gh_project phpunit @@ -34,7 +34,7 @@ %global ver_major 10 %global ver_minor 5 -%global upstream_version 10.5.5 +%global upstream_version 10.5.6 #global upstream_prever dev Name: %{pk_project}%{ver_major} @@ -319,6 +319,9 @@ exit $ret %changelog +* Sun Jan 14 2024 Remi Collet <remi@remirepo.net> - 10.5.6-1 +- update to 10.5.6 + * Thu Dec 28 2023 Remi Collet <remi@remirepo.net> - 10.5.5-1 - update to 10.5.5 |