summaryrefslogtreecommitdiffstats
path: root/php-sebastian-type5.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-sebastian-type5.spec')
-rw-r--r--php-sebastian-type5.spec15
1 files changed, 9 insertions, 6 deletions
diff --git a/php-sebastian-type5.spec b/php-sebastian-type5.spec
index 0ef19fb..60f2b59 100644
--- a/php-sebastian-type5.spec
+++ b/php-sebastian-type5.spec
@@ -11,11 +11,11 @@
%bcond_with tests
# github
-%global gh_commit fb6a6566f9589e86661291d13eba708cce5eb4aa
+%global gh_commit 461b9c5da241511a2a0e8f240814fb23ce5c0aac
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project type
-%global gh_date 2024-07-03
+%global gh_date 2024-09-17
# packagist
%global pk_vendor sebastian
%global pk_project %{gh_project}
@@ -26,7 +26,7 @@
%global ns_project Type
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 5.0.1
+Version: 5.1.0
Release: 1%{?dist}
Summary: Collection of value objects that represent the types of the PHP type system, v%{major}
@@ -43,8 +43,8 @@ BuildRequires: php-reflection
BuildRequires: php-fedora-autoloader-devel >= 1.0.0
%if %{with tests}
# from composer.json, "require-dev": {
-# "phpunit/phpunit": "^11.0"
-BuildRequires: phpunit11
+# "phpunit/phpunit": "^11.3"
+BuildRequires: phpunit11 >= 11.3
%endif
# from composer.json, "require": {
@@ -98,7 +98,7 @@ ret=0
for cmd in php php82 php83 php84; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
- %{_bindir}/phpunit11 || ret=1
+ %{_bindir}/phpunit11 --bootstrap vendor/autoload.php --no-coverage || ret=1
fi
done
exit $ret
@@ -116,6 +116,9 @@ exit $ret
%changelog
+* Wed Sep 18 2024 Remi Collet <remi@remirepo.net> - 5.1.0-1
+- update to 5.1.0
+
* Wed Jul 3 2024 Remi Collet <remi@remirepo.net> - 5.0.1-1
- update to 5.0.1