summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-sebastian-lines-of-code3.spec25
1 files changed, 7 insertions, 18 deletions
diff --git a/php-sebastian-lines-of-code3.spec b/php-sebastian-lines-of-code3.spec
index a2cf4b2..e0c5750 100644
--- a/php-sebastian-lines-of-code3.spec
+++ b/php-sebastian-lines-of-code3.spec
@@ -11,11 +11,11 @@
%bcond_with tests
# github
-%global gh_commit 376c5b3f6b43c78fdc049740bca76a7c846706c0
+%global gh_commit d36ad0d782e5756913e42ad87cb2890f4ffe467a
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project lines-of-code
-%global gh_date 2024-02-02
+%global gh_date 2024-07-03
# packagist
%global pk_vendor sebastian
%global pk_project %{gh_project}
@@ -26,25 +26,19 @@
%global ns_project LinesOfCode
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 3.0.0
+Version: 3.0.1
Release: 1%{?dist}
Summary: Counting the lines of code in PHP source code, version %{major}
License: BSD-3-Clause
URL: https://github.com/%{gh_owner}/%{gh_project}
-# git snapshot to retrieve test suite
+# run makesrc.sh to create a git snapshot with test suite
Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
BuildArch: noarch
BuildRequires: php(language) >= 8.2
-# remirepo:1
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(nikic/php-parser) >= 5.0 with php-composer(nikic/php-parser) < 6)
-# remirepo:3
-%else
-BuildRequires: php-nikic-php-parser5
-%endif
BuildRequires: php-spl
# Autoloader
BuildRequires: php-fedora-autoloader-devel >= 1.0.0
@@ -58,13 +52,7 @@ BuildRequires: phpunit11
# "php": ">=8.1",
# "nikic/php-parser": "^5.0"
Requires: php(language) >= 8.2
-# remirepo:1
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(nikic/php-parser) >= 5.0 with php-composer(nikic/php-parser) < 6)
-# remirepo:3
-%else
-Requires: php-nikic-php-parser5
-%endif
# from phpcompatinfo report for version 2.0.0
Requires: php-spl
# Autoloader
@@ -121,8 +109,6 @@ exit $ret
%files
-# remirepo:1
-%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
%doc composer.json
@@ -131,6 +117,9 @@ exit $ret
%changelog
+* Wed Jul 3 2024 Remi Collet <remi@remirepo.net> - 3.0.1-1
+- update to 3.0.1
+
* Mon Feb 5 2024 Remi Collet <remi@remirepo.net> - 3.0.0-1
- update to 3.0.0
- raise dependency on PHP 8.2