summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json4
-rw-r--r--php-sebastian-exporter6.spec14
2 files changed, 11 insertions, 7 deletions
diff --git a/composer.json b/composer.json
index fcb0726..78c8b0b 100644
--- a/composer.json
+++ b/composer.json
@@ -44,7 +44,7 @@
"sebastian/recursion-context": "^6.0"
},
"require-dev": {
- "phpunit/phpunit": "^11.0"
+ "phpunit/phpunit": "^11.2"
},
"autoload": {
"classmap": [
@@ -58,7 +58,7 @@
},
"extra": {
"branch-alias": {
- "dev-main": "6.0-dev"
+ "dev-main": "6.1-dev"
}
}
}
diff --git a/php-sebastian-exporter6.spec b/php-sebastian-exporter6.spec
index 938e8e8..f7e0d80 100644
--- a/php-sebastian-exporter6.spec
+++ b/php-sebastian-exporter6.spec
@@ -10,11 +10,11 @@
# disabled until phpunit11 available
%bcond_with tests
-%global gh_commit f291e5a317c321c0381fa9ecc796fa2d21b186da
+%global gh_commit 507d2333cbc4e6ea248fbda2d45ee1511e03da13
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project exporter
-%global gh_date 2024-03-02
+%global gh_date 2024-06-18
# Packagist
%global pk_vendor sebastian
%global pk_project %{gh_project}
@@ -27,12 +27,13 @@
%global pear_channel pear.phpunit.de
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 6.0.1
+Version: 6.1.2
Release: 1%{?dist}
Summary: Export PHP variables for visualization, version %{major}
License: BSD-3-Clause
URL: https://github.com/%{gh_owner}/%{gh_project}
+# run makesrc.sh to create a git snapshot with test suite
Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
@@ -44,8 +45,8 @@ BuildRequires: php-spl
BuildRequires: php-fedora-autoloader-devel
%if %{with tests}
# from composer.json, "require-dev": {
-# "phpunit/phpunit": "^11.0",
-BuildRequires: phpunit11
+# "phpunit/phpunit": "^11.2",
+BuildRequires: phpunit11 >= 11.2
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(%{pk_vendor}/recursion-context) >= 6.0 with php-composer(%{pk_vendor}/recursion-context) < 7)
@@ -131,6 +132,9 @@ exit $ret
%changelog
+* Tue Jul 2 2024 Remi Collet <remi@remirepo.net> - 6.1.2-1
+- update to 6.1.2
+
* Tue Mar 5 2024 Remi Collet <remi@remirepo.net> - 6.0.1-1
- update to 6.0.1