summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-07-03 07:36:55 +0200
committerRemi Collet <remi@php.net>2024-07-03 07:36:55 +0200
commit829fa80e4c8b889d84e1aa288875161e158dc9d6 (patch)
tree20734041c8e4976b5def8a6dd4eb07560c93b766
parent56042c65caf707f447e8af0bdf1ee005fc64f46b (diff)
update to 4.0.1HEADmaster
-rw-r--r--php-sebastian-complexity4.spec27
1 files changed, 8 insertions, 19 deletions
diff --git a/php-sebastian-complexity4.spec b/php-sebastian-complexity4.spec
index 585496d..3c7519b 100644
--- a/php-sebastian-complexity4.spec
+++ b/php-sebastian-complexity4.spec
@@ -11,11 +11,11 @@
%bcond_with tests
# github
-%global gh_commit 88a434ad86150e11a606ac4866b09130712671f0
+%global gh_commit ee41d384ab1906c68852636b6de493846e13e5a0
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project complexity
-%global gh_date 2024-02-02
+%global gh_date 2024-07-03
# packagist
%global pk_vendor sebastian
%global pk_project %{gh_project}
@@ -26,25 +26,19 @@
%global ns_project Complexity
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 4.0.0
+Version: 4.0.1
Release: 1%{?dist}
Summary: Calculating the complexity of PHP code units, version %{major}
License: BSD-3-Clause
URL: https://github.com/%{gh_owner}/%{gh_project}
-# git snapshot to retrieve test suite
+# run makesrc.sh to create a git snapshot with test suite
Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
BuildArch: noarch
BuildRequires: php(language) >= 8.2
-# remirepo:1
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(nikic/php-parser) >= 5.0 with php-composer(nikic/php-parser) < 6)
-# remirepo:3
-%else
-BuildRequires: php-nikic-php-parser5
-%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel >= 1.0.0
%if %{with tests}
@@ -57,13 +51,7 @@ BuildRequires: phpunit11
# "php": ">=8.2",
# "nikic/php-parser": "^4.18 || ^5.0"
Requires: php(language) >= 8.2
-# remirepo:1
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(nikic/php-parser) >= 5.0 with php-composer(nikic/php-parser) < 6)
-# remirepo:3
-%else
-Requires: php-nikic-php-parser5
-%endif
# from phpcompatinfo report for version 3.0.0
# none
# Autoloader
@@ -107,7 +95,7 @@ touch vendor/autoload.php
: Run upstream test suite
ret=0
-for cmd in php php82 php83; do
+for cmd in php php82 php83 php84; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
%{_bindir}/phpunit11 || ret=1
@@ -120,8 +108,6 @@ exit $ret
%files
-# remirepo:1
-%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
%doc composer.json
@@ -130,6 +116,9 @@ exit $ret
%changelog
+* Wed Jul 3 2024 Remi Collet <remi@remirepo.net> - 4.0.1-1
+- update to 4.0.1
+
* Mon Feb 5 2024 Remi Collet <remi@remirepo.net> - 4.0.0-1
- update to 4.0.0
- raise dependency on PHP 8.2