summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--php-sebastian-code-unit3.spec20
2 files changed, 13 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index e942b66..d97cfee 100644
--- a/composer.json
+++ b/composer.json
@@ -20,7 +20,7 @@
"php": ">=8.2"
},
"require-dev": {
- "phpunit/phpunit": "^11.0"
+ "phpunit/phpunit": "^11.5"
},
"config": {
"platform": {
diff --git a/php-sebastian-code-unit3.spec b/php-sebastian-code-unit3.spec
index 368af69..4807002 100644
--- a/php-sebastian-code-unit3.spec
+++ b/php-sebastian-code-unit3.spec
@@ -1,8 +1,8 @@
# remirepo/fedora spec file for php-sebastian-code-unit3
#
-# Copyright (c) 2020-2024 Remi Collet
-# License: CC-BY-SA-4.0
-# http://creativecommons.org/licenses/by-sa/4.0/
+# SPDX-FileCopyrightText: Copyright 2024 Remi Collet
+# SPDX-License-Identifier: CECILL-2.1
+# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
#
# Please, preserve the changelog entries
#
@@ -11,11 +11,11 @@
%bcond_with tests
# Sources
-%global gh_commit 6bb7d09d6623567178cf54126afa9c2310114268
+%global gh_commit ee88b0cdbe74cf8dd3b54940ff17643c0d6543ca
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project code-unit
-%global gh_date 2024-07-03
+%global gh_date 2024-12-12
# Packagist
%global pk_vendor sebastian
%global pk_project %{gh_project}
@@ -26,7 +26,7 @@
%global ns_project CodeUnit
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 3.0.1
+Version: 3.0.2
Release: 1%{?dist}
Summary: Collection of value objects that represent the PHP code units, version %{major}
@@ -44,8 +44,8 @@ BuildRequires: php-spl
BuildRequires: php-fedora-autoloader-devel
%if %{with tests}
# from composer.json, "require-dev": {
-# "phpunit/phpunit": "^11.0"
-BuildRequires: phpunit11
+# "phpunit/phpunit": "^11.5"
+BuildRequires: phpunit11 >= 11.5
%endif
# from composer.json, "require": {
@@ -122,6 +122,10 @@ exit $ret
%changelog
+* Thu Dec 12 2024 Remi Collet <remi@remirepo.net> - 3.0.2-1
+- update to 3.0.2
+- re-license spec file to CECILL-2.1
+
* Wed Jul 3 2024 Remi Collet <remi@remirepo.net> - 3.0.1-1
- update to 3.0.1