summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-phpunit-php-invoker5.spec20
1 files changed, 11 insertions, 9 deletions
diff --git a/php-phpunit-php-invoker5.spec b/php-phpunit-php-invoker5.spec
index 4236516..83dea25 100644
--- a/php-phpunit-php-invoker5.spec
+++ b/php-phpunit-php-invoker5.spec
@@ -10,11 +10,11 @@
# disabled until phpunit11 available
%bcond_with tests
-%global gh_commit 5d8d9355a16d8cc5a1305b0a85342cfa420612be
+%global gh_commit c1ca3814734c07492b3d4c5f794f4b0995333da2
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project php-invoker
-%global gh_date 2024-02-02
+%global gh_date 2024-07-03
%global php_home %{_datadir}/php
# Packagist
%global pk_vendor phpunit
@@ -25,17 +25,18 @@
%global ns_project Invoker
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 5.0.0
+Version: 5.0.1
Release: 1%{?dist}
Summary: Invoke callables with a timeout, version %{major}
License: BSD-3-Clause
URL: https://github.com/%{gh_owner}/%{gh_project}
+# run makesrc.sh to create a git snapshot with test suite
Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
BuildArch: noarch
-BuildRequires: php(language) >= 8.1
+BuildRequires: php(language) >= 8.2
BuildRequires: php-spl
BuildRequires: php-fedora-autoloader-devel
%if %{with tests}
@@ -47,8 +48,8 @@ BuildRequires: phpunit11
%endif
# From composer.json, require
-# "php": ">=8.1",
-Requires: php(language) >= 8.1
+# "php": ">=8.2",
+Requires: php(language) >= 8.2
# From phpcompatinfo report for version 4.0.0
Requires: php-pcntl
Requires: php-spl
@@ -90,7 +91,7 @@ mkdir vendor
: Run upstream test suite
ret=0
-for cmd in php php82 php83; do
+for cmd in php php82 php83 php84; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
%{_bindir}/phpunit11 || ret=1
@@ -101,8 +102,6 @@ exit $ret
%files
-# remirepo:1
-%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc README.md
%doc composer.json
@@ -111,6 +110,9 @@ exit $ret
%changelog
+* Wed Jul 3 2024 Remi Collet <remi@remirepo.net> - 5.0.1-1
+- update to 5.0.1
+
* Mon Feb 5 2024 Remi Collet <remi@remirepo.net> - 5.0.0-1
- update to 5.0.0
- raise dependency on PHP 8.2