summaryrefslogtreecommitdiffstats
path: root/php-phpunit-php-code-coverage11.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-phpunit-php-code-coverage11.spec')
-rw-r--r--php-phpunit-php-code-coverage11.spec20
1 files changed, 13 insertions, 7 deletions
diff --git a/php-phpunit-php-code-coverage11.spec b/php-phpunit-php-code-coverage11.spec
index b4e0d7b..ac53658 100644
--- a/php-phpunit-php-code-coverage11.spec
+++ b/php-phpunit-php-code-coverage11.spec
@@ -11,11 +11,11 @@
%bcond_with tests
# Github
-%global gh_commit 7e35a2cbcabac0e6865fd373742ea432a3c34f92
+%global gh_commit 4dc2b7a606073f0fb80da09842ffb068b627c38f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project php-code-coverage
-%global gh_date 2024-03-12
+%global gh_date 2024-06-29
# Packagist
%global pk_vendor phpunit
%global pk_project php-code-coverage
@@ -26,7 +26,7 @@
%global ver_major 11
Name: php-%{pk_vendor}-%{pk_project}%{ver_major}
-Version: 11.0.3
+Version: 11.0.4
Release: 1%{?dist}
Summary: PHP code coverage information, version %{ver_major}
@@ -195,10 +195,13 @@ then EXT="-d zend_extension=xdebug.so -d xdebug.mode=coverage"
fi
export XDEBUG_MODE=coverage
-cat << 'EOF' | tee tests/bootstrap.php
-<?php
-require __DIR__ . '/TestCase.php';
-require __DIR__ . '/_files/BankAccountTest.php';
+%{_bindir}/phpab \
+ --template fedora \
+ --output tests/bootstrap.php \
+ --exclude 'tests/_files/*.php' \
+ tests
+
+cat << 'EOF' | tee -a tests/bootstrap.php
define('TEST_FILES_PATH', __DIR__ . '/_files/');
EOF
@@ -229,6 +232,9 @@ exit $ret
%changelog
+* Tue Jul 2 2024 Remi Collet <remi@remirepo.net> - 11.0.4-1
+- update to 11.0.4
+
* Wed Mar 13 2024 Remi Collet <remi@remirepo.net> - 11.0.3-1
- update to 11.0.3