summaryrefslogtreecommitdiffstats
path: root/php-phpspec-prophecy-phpunit.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-11-21 07:53:05 +0100
committerRemi Collet <remi@php.net>2024-11-21 07:53:05 +0100
commitaa2cc7d343fd7362e38927f2f55f34c792b0818d (patch)
tree2be59374935614386251c2214907f259ccc74f24 /php-phpspec-prophecy-phpunit.spec
parentc41f21ed54f658390ccfe5ec0389a7d8acc9aca7 (diff)
update to 2.3.0HEADmaster
Diffstat (limited to 'php-phpspec-prophecy-phpunit.spec')
-rw-r--r--php-phpspec-prophecy-phpunit.spec26
1 files changed, 7 insertions, 19 deletions
diff --git a/php-phpspec-prophecy-phpunit.spec b/php-phpspec-prophecy-phpunit.spec
index 835cc56..f0c5f72 100644
--- a/php-phpspec-prophecy-phpunit.spec
+++ b/php-phpspec-prophecy-phpunit.spec
@@ -9,13 +9,13 @@
%bcond_without tests
-%global gh_commit 16e1247e139434bce0bac09848bc5c8d882940fc
+%global gh_commit 8819516c1b489ecee4c60db5f5432fac1ea8ac6f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpspec
%global gh_project prophecy-phpunit
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.2.0
+Version: 2.3.0
Release: 1%{?dist}
Summary: Integrating the Prophecy mocking library in PHPUnit test cases
@@ -27,14 +27,8 @@ Source2: makesrc.sh
BuildArch: noarch
BuildRequires: php(language) >= 7.3
%if %{with tests}
-# remirepo:1
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(phpspec/prophecy) >= 1.18 with php-composer(phpspec/prophecy) < 2)
# remirepo:3
-%else
-BuildRequires: php-phpspec-prophecy >= 1.18
-%endif
-# remirepo:3
%if 0%{?fedora} >= 38 || 0%{?rhel} >= 10
BuildRequires: phpunit11 >= 11.0
%endif
@@ -49,15 +43,8 @@ BuildRequires: php-fedora-autoloader-devel
# "phpspec/prophecy": "^1.18",
# "phpunit/phpunit":"^9.1 || ^10.1 || ^11.0"
Requires: php(language) >= 7.3
-# remirepo:1
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(phpspec/prophecy) >= 1.18 with php-composer(phpspec/prophecy) < 2)
Requires: (phpunit9 >= 9.1 or phpunit10 >= 10.1 or phpunit11 >= 11.0)
-# remirepo:4
-%else
-Requires: php-phpspec-prophecy >= 1.18
-Requires: phpunit9 >= 9.1
-%endif
# From phpcompatinfo report for version 2.0.1
#none
# Autoloader
@@ -111,7 +98,7 @@ sed -e 's:src/::' -i tests/MockFailure.phpt
: upstream test suite
ret=0
-for cmd in php php81 php82 php83; do
+for cmd in php php81 php82 php83 php84; do
if which $cmd; then
sed -e 's/@PHPUNIT@/PHPUnit9/' vendor/autoload.php.in > vendor/autoload.php
$cmd -d auto_prepend_file=vendor/autoload.php \
@@ -122,7 +109,7 @@ for cmd in php php81 php82 php83; do
%{_bindir}/phpunit10 --no-coverage|| ret=1
fi
done
-for cmd in php php82 php83; do
+for cmd in php php82 php83 php84; do
if which %{_bindir}/phpunit11 && which $cmd; then
sed -e 's/@PHPUNIT@/PHPUnit11/' vendor/autoload.php.in > vendor/autoload.php
$cmd -d auto_prepend_file=vendor/autoload.php \
@@ -136,8 +123,6 @@ exit $ret
%files
-# remirepo:1
-%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
%doc composer.json
@@ -145,6 +130,9 @@ exit $ret
%changelog
+* Thu Nov 21 2024 Remi Collet <remi@remirepo.net> - 2.3.0-1
+- update to 2.3.0
+
* Fri Mar 1 2024 Remi Collet <remi@remirepo.net> - 2.2.0-1
- update to 2.2.0
- allow phpunit11