summaryrefslogtreecommitdiffstats
path: root/php-phplang-scope-exit.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-phplang-scope-exit.spec')
-rw-r--r--php-phplang-scope-exit.spec29
1 files changed, 20 insertions, 9 deletions
diff --git a/php-phplang-scope-exit.spec b/php-phplang-scope-exit.spec
index 5c0973c..754ee45 100644
--- a/php-phplang-scope-exit.spec
+++ b/php-phplang-scope-exit.spec
@@ -1,8 +1,8 @@
# remirepo/fedora spec file for php-phplang-scope-exit
#
-# Copyright (c) 2019 Remi Collet
-# License: CC-BY-SA
-# http://creativecommons.org/licenses/by-sa/4.0/
+# SPDX-FileCopyrightText: Copyright 2019-2024 Remi Collet
+# SPDX-License-Identifier: CECILL-2.1
+# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
#
# Please, preserve the changelog entries
#
@@ -23,10 +23,10 @@
Name: php-%{pk_vendor}-%{pk_project}%{major}
Version: 1.0.0
-Release: 2%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
+Release: 13%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: Emulation of SCOPE_EXIT construct from C++
-License: BSD
+License: BSD-3-Clause
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{?gh_short}.tar.gz
@@ -35,8 +35,8 @@ BuildArch: noarch
BuildRequires: php(language)
# For tests, from composer.json "require-dev": {
# "phpunit/phpunit": "*",
-BuildRequires: php-composer(phpunit/phpunit)
-%global phpunit %{_bindir}/phpunit
+BuildRequires: phpunit10
+%global phpunit %{_bindir}/phpunit10
# For autoloader
BuildRequires: php-fedora-autoloader-devel
%endif
@@ -83,12 +83,17 @@ mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
require '%{buildroot}%{_datadir}/php/%{ns_vendor}/%{pk_project}-autoload.php';
+class_alias('PHPUnit\\Framework\\TestCase', 'PHPUnit_Framework_TestCase');
EOF
ret=0
-for cmd in php php56 php70 php71 php72 php73 php74; do
+for cmd in php php81 php82 php83 php84; do
if which $cmd; then
- $cmd %{phpunit} --no-coverage --verbose . || ret=1
+ $cmd %{phpunit} \
+ --do-not-cache-result \
+ --no-coverage \
+ --no-configuration \
+ . || ret=1
fi
done
exit $ret
@@ -107,6 +112,12 @@ exit $ret
%changelog
+* Mon Dec 23 2024 Remi Collet <remi@remirepo.net> - 1.0.0-13
+- re-license spec file to CECILL-2.1
+
+* Wed Jan 31 2024 Remi Collet <remi@remirepo.net> - 1.0.0-12
+- switch to phpunit10, fix FTBFS #2261502
+
* Thu Sep 19 2019 Remi Collet <remi@remirepo.net> - 1.0.0-2
- add commit to include LICENSE file (no change)