summaryrefslogtreecommitdiffstats
path: root/php-phpdocumentor-reflection-docblock-get-source.sh
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-01-22 11:56:36 +0100
committerRemi Collet <remi@remirepo.net>2018-01-22 11:56:36 +0100
commit0513bb9698d88018ddae7b87870085890dcc4b1f (patch)
tree57285e0ec542c640ff47ddeebba9e042f981175d /php-phpdocumentor-reflection-docblock-get-source.sh
parent8343b8414527cb53386b0e4225c51b968508f7fd (diff)
Update to 4.2.0
rename to php-phpdocumentor-reflection-docblock4 move to /usr/share/php/phpDocumentor/Reflection/DocBlock4 raise dependency on PHP 7.0 raise dependency on phpdocumentor/type-resolver 0.4.0 use phpunit6 and php-mockery for test suite
Diffstat (limited to 'php-phpdocumentor-reflection-docblock-get-source.sh')
-rwxr-xr-xphp-phpdocumentor-reflection-docblock-get-source.sh71
1 files changed, 0 insertions, 71 deletions
diff --git a/php-phpdocumentor-reflection-docblock-get-source.sh b/php-phpdocumentor-reflection-docblock-get-source.sh
deleted file mode 100755
index 8cf51f1..0000000
--- a/php-phpdocumentor-reflection-docblock-get-source.sh
+++ /dev/null
@@ -1,71 +0,0 @@
-#/bin/sh
-
-GIT=`which git`
-RPM=`which rpm`
-
-if [ -z "$GIT" ]
-then
- echo "ERROR: 'git' command not found" 1>&2
- exit 1
-elif [ -z "$RPM" ]
-then
- echo "ERROR: 'rpm' command not found" 1>&2
- exit 1
-fi
-
-function print {
- echo -e "\e[0;33m>>>>> ${1}\e[0m"
-}
-
-if [ -x "$1" ]
-then
- SPEC=$1
-else
- SPEC=`ls *.spec | head -1`
-fi
-
-NAME=`echo $SPEC | sed 's#\.spec##'`
-VERSION=`egrep '^Version:' $SPEC | awk '{print $2}'`
-
-print "SPEC = $SPEC"
-print "NAME = $NAME"
-
-GIT_OWNER=`egrep '%global\s*gh_owner' $SPEC | awk '{print $3}'`
-GIT_NAME=`egrep '%global\s*gh_project' $SPEC | awk '{print $3}'`
-GIT_COMMIT=`egrep '%global\s*gh_commit' $SPEC | awk '{print $3}'`
-GIT_REPO=https://github.com/${GIT_OWNER}/${GIT_NAME}
-GIT_DIR=`echo $GIT_REPO | sed 's#.*/##'`
-
-print "GIT_OWNER = $GIT_OWNER"
-print "GIT_NAME = $GIT_NAME"
-print "GIT_COMMIT = $GIT_COMMIT"
-print "GIT_REPO = $GIT_REPO"
-print "GIT_DIR = $GIT_DIR"
-
-TEMP_DIR=$(mktemp --dir)
-TAR_FILE=$PWD/${NAME}-${VERSION}-${GIT_COMMIT}.tar.gz
-CMP_FILE=$PWD/composer.json
-
-pushd $TEMP_DIR
- print "Cloning git repo..."
- $GIT clone $GIT_REPO
-
- pushd $GIT_DIR
- print "Checking out commit..."
- $GIT checkout $GIT_COMMIT
- cp composer.json $CMP_FILE
- popd
-
- TAR_DIR=${GIT_NAME}-${GIT_COMMIT}
- print "TAR_DIR = $TAR_DIR"
-
- mv $GIT_DIR $TAR_DIR
-
- print "TAR_FILE = $TAR_FILE"
-
- [ -e $TAR_FILE ] && rm -f $TAR_FILE
- tar --exclude-vcs -czf $TAR_FILE $TAR_DIR
- chmod 0644 $TAR_FILE
-popd
-
-rm -rf $TEMP_DIR