summaryrefslogtreecommitdiffstats
path: root/php84.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php84.spec')
-rw-r--r--php84.spec20
1 files changed, 17 insertions, 3 deletions
diff --git a/php84.spec b/php84.spec
index 731bf3c..79cdbf6 100644
--- a/php84.spec
+++ b/php84.spec
@@ -58,6 +58,13 @@
# /usr/sbin/a# build with libiodbc instead of unixODBC
%bcond_with iodbc
+# OpenSSL2 with argon2
+%if 0%{?fedora} >= 40 || 0%{?rhel} >= 9
+%bcond_without openssl32
+%else
+%bcond_with openssl32
+%endif
+
# /usr/sbin/apsx with httpd < 2.4 and defined as /usr/bin/apxs with httpd >= 2.4
%{!?_httpd_apxs: %{expand: %%global _httpd_apxs %%{_sbindir}/apxs}}
%{!?_httpd_mmn: %{expand: %%global _httpd_mmn %%(cat %{_includedir}/httpd/.mmn 2>/dev/null || echo 0-0)}}
@@ -80,7 +87,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 1%{?dist}
+Release: 2%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -158,8 +165,12 @@ BuildRequires: httpd-filesystem
# to ensure we are using nginx with filesystem feature (see #1142298)
BuildRequires: nginx-filesystem
BuildRequires: %{?dtsprefix}libstdc++-devel
-# no pkgconfig to avoid compat-openssl10
+%if %{with openssl32}
+BuildRequires: pkgconfig(openssl) >= 3.2
+%else
+# no pkgconfig to avoid compat-openssl10/compat-openssl11
BuildRequires: openssl-devel >= 1.0.2
+%endif
BuildRequires: pkgconfig(sqlite3) >= 3.7.4
BuildRequires: pkgconfig(zlib) >= 1.2.0.4
BuildRequires: smtpdaemon
@@ -1026,7 +1037,7 @@ ln -sf ../configure
--with-exec-dir=%{_bindir} \
--without-gdbm \
--with-openssl \
-%if 0%{?fedora} >= 40 || 0%{?rhel} >= 10
+%if %{with openssl32}
--with-openssl-argon2 \
%endif
--with-system-ciphers \
@@ -1693,6 +1704,9 @@ systemctl try-restart php-fpm.service >/dev/null 2>&1 || :
%changelog
+* Mon Dec 2 2024 Remi Collet <remi@remirepo.net> - 8.4.1-2
+- EL-9.5: enable argon2 password hash, using OpenSSL 3.2
+
* Wed Nov 20 2024 Remi Collet <remi@remirepo.net> - 8.4.1-1
- Update to 8.4.1 - http://www.php.net/releases/8_4_1.php