summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2025-03-12 10:36:37 +0100
committerRemi Collet <remi@php.net>2025-03-12 10:36:37 +0100
commit70699ea0148cf1bb5e2df171e946fbb17274f91d (patch)
treecb29ff16b07b1710c95f91ad0ebf43e6c92ad57b
parent3d403ebd998488d19ef530e56df561dad58d31c5 (diff)
Update to 8.2.28 - http://www.php.net/releases/8_2_28.phpHEADmaster
use oracle client library version 23.7 on x86_64 and arm64
-rw-r--r--failed.txt6
-rw-r--r--php-8.2.28-pcretests.patch43
-rw-r--r--php-8.2.28-zlibtests.patch20
-rw-r--r--php82.spec28
4 files changed, 78 insertions, 19 deletions
diff --git a/failed.txt b/failed.txt
index 87ab6e2..082f989 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,4 +1,4 @@
-===== 8.2.27 (2024-12-19)
+===== 8.2.28 (2025-03-13)
$ grep -ar 'Tests failed' /var/lib/mock/*/build.log
@@ -8,12 +8,12 @@ $ grep -ar 'Tests failed' /var/lib/mock/*/build.log
/var/lib/mock/el9x82/build.log:Tests failed : 0
/var/lib/mock/el10a82/build.log:Tests failed : 0
/var/lib/mock/el10x82/build.log:Tests failed : 0
-/var/lib/mock/fc39a82/build.log:Tests failed : 0
-/var/lib/mock/fc39x82/build.log:Tests failed : 0
/var/lib/mock/fc40a82/build.log:Tests failed : 0
/var/lib/mock/fc40x82/build.log:Tests failed : 0
/var/lib/mock/fc41a82/build.log:Tests failed : 0
/var/lib/mock/fc41x82/build.log:Tests failed : 0
+/var/lib/mock/fc42a82/build.log:Tests failed : 0
+/var/lib/mock/fc42x82/build.log:Tests failed : 0
1 proc_open give erratic test results :(
diff --git a/php-8.2.28-pcretests.patch b/php-8.2.28-pcretests.patch
new file mode 100644
index 0000000..c226661
--- /dev/null
+++ b/php-8.2.28-pcretests.patch
@@ -0,0 +1,43 @@
+From c3150fcc89825f50d476b1b1971870aeb71f167d Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Wed, 12 Mar 2025 07:48:05 +0100
+Subject: [PATCH 1/2] Relax test expectation for pcre2lib 10.45 Using
+ e92848789acd8aa5cf32fedb519ba9378ac64e02
+
+---
+ ext/pcre/tests/bug75457.phpt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ext/pcre/tests/bug75457.phpt b/ext/pcre/tests/bug75457.phpt
+index ee5ab162f8a6c..87dc12a1ad056 100644
+--- a/ext/pcre/tests/bug75457.phpt
++++ b/ext/pcre/tests/bug75457.phpt
+@@ -6,5 +6,5 @@ $pattern = "/(((?(?C)0?=))(?!()0|.(?0)0)())/";
+ var_dump(preg_match($pattern, "hello"));
+ ?>
+ --EXPECTF--
+-Warning: preg_match(): Compilation failed: assertion expected after (?( or (?(?C) at offset 8 in %sbug75457.php on line %d
++Warning: preg_match(): Compilation failed: %r(atomic|)%r assertion expected after (?( or (?(?C) at offset 8 in %sbug75457.php on line %d
+ bool(false)
+
+From 126095700a02b9aa1f33764a63c93a70e8373ad8 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@famillecollet.com>
+Date: Wed, 12 Mar 2025 09:36:33 +0100
+Subject: [PATCH 2/2] Update ext/pcre/tests/bug75457.phpt
+
+Co-authored-by: Niels Dossche <7771979+nielsdos@users.noreply.github.com>
+---
+ ext/pcre/tests/bug75457.phpt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ext/pcre/tests/bug75457.phpt b/ext/pcre/tests/bug75457.phpt
+index 87dc12a1ad056..1401b25ff6fb7 100644
+--- a/ext/pcre/tests/bug75457.phpt
++++ b/ext/pcre/tests/bug75457.phpt
+@@ -6,5 +6,5 @@ $pattern = "/(((?(?C)0?=))(?!()0|.(?0)0)())/";
+ var_dump(preg_match($pattern, "hello"));
+ ?>
+ --EXPECTF--
+-Warning: preg_match(): Compilation failed: %r(atomic|)%r assertion expected after (?( or (?(?C) at offset 8 in %sbug75457.php on line %d
++Warning: preg_match(): Compilation failed:%r( atomic|)%r assertion expected after (?( or (?(?C) at offset 8 in %sbug75457.php on line %d
+ bool(false)
diff --git a/php-8.2.28-zlibtests.patch b/php-8.2.28-zlibtests.patch
new file mode 100644
index 0000000..4c1692d
--- /dev/null
+++ b/php-8.2.28-zlibtests.patch
@@ -0,0 +1,20 @@
+From ed1d51fa4fda4572982e390e7b0c8c9dc8d9f622 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Wed, 29 Jan 2025 09:46:15 +0100
+Subject: [PATCH] relax test for zlib-ng
+
+---
+ ext/standard/tests/filters/gh13264.phpt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ext/standard/tests/filters/gh13264.phpt b/ext/standard/tests/filters/gh13264.phpt
+index 6456a082a1e40..e992d0868898d 100644
+--- a/ext/standard/tests/filters/gh13264.phpt
++++ b/ext/standard/tests/filters/gh13264.phpt
+@@ -45,5 +45,5 @@ array(4) {
+ ["line"]=>
+ int(%d)
+ }
+-string(7) "Hello 6"
++string(%d) "Hello%s"
+
diff --git a/php82.spec b/php82.spec
index 3d846d8..9bd67d8 100644
--- a/php82.spec
+++ b/php82.spec
@@ -24,17 +24,10 @@
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
-%ifarch aarch64
-%global oraclever 19.25
-%global oraclemax 20
-%global oraclelib 19.1
-%global oracledir 19.25
-%else
-%global oraclever 23.6
+%global oraclever 23.7
%global oraclemax 24
%global oraclelib 23.1
%global oracledir 23
-%endif
# Build for LiteSpeed Web Server (LSAPI), you can disable using --without tests
%bcond_without lsws
@@ -126,7 +119,7 @@
%bcond_without libgd
%bcond_with zip
-%global upver 8.2.27
+%global upver 8.2.28
#global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
@@ -199,6 +192,10 @@ Patch91: php-7.2.0-oci8conf.patch
# Fixes for tests (300+)
# Factory is droped from system tzdata
Patch300: php-7.4.0-datetests.patch
+# for pcre2 10.45 (F42)
+Patch301: php-8.2.28-pcretests.patch
+# for zlib-ng
+Patch302: php-8.2.28-zlibtests.patch
# WIP
@@ -764,14 +761,7 @@ Interbase/Firebird databases.
Summary: A module for PHP applications that use OCI8 databases
# All files licensed under PHP version 3.01
License: PHP-3.01
-%ifarch aarch64
-BuildRequires: oracle-instantclient%{oraclever}-devel
-# Should requires libclntsh.so.19.1()(aarch-64), but it's not provided by Oracle RPM.
-Requires: libclntsh.so.%{oraclelib}
-AutoReq: 0
-%else
BuildRequires: (oracle-instantclient-devel >= %{oraclever} with oracle-instantclient-devel < %{oraclemax})
-%endif
Requires: php-pdo%{?_isa} = %{version}-%{release}
Provides: php_database
Provides: php-pdo_oci
@@ -1221,6 +1211,8 @@ in pure PHP.
%if %{with tzdata}
%patch -P300 -p1 -b .datetests
%endif
+%patch -P301 -p1 -b .pcretests
+%patch -P302 -p1 -b .zlibtests
# WIP patch
@@ -2209,6 +2201,10 @@ fi
%changelog
+* Wed Mar 12 2025 Remi Collet <remi@remirepo.net> - 8.2.28-1
+- Update to 8.2.28 - http://www.php.net/releases/8_2_28.php
+- use oracle client library version 23.7 on x86_64 and arm64
+
* Tue Dec 17 2024 Remi Collet <remi@remirepo.net> - 8.2.27-1
- Update to 8.2.27 - http://www.php.net/releases/8_2_27.php