summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-06-16 06:59:14 +0200
committerRemi Collet <remi@remirepo.net>2021-06-16 06:59:14 +0200
commit278c8a3a2c0e77dad4463e08ea0d773087c3543c (patch)
tree4cba5cb2545a67a45e281e81fd30cc875fa73097
parentbe8a124151211e6716302c53957d1a55b6dd5cc9 (diff)
update to 7.4.21RC1
ignore unsupported "threads" option on password_hash
-rw-r--r--failed.txt2
-rw-r--r--php-7.4.20-argon2.patch15
-rw-r--r--php74.spec11
3 files changed, 25 insertions, 3 deletions
diff --git a/failed.txt b/failed.txt
index 56fed50..ea48c77 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,4 +1,4 @@
-===== 7.4.20 (2021-06-03)
+===== 7.4.21RC1 (2021-06-17)
$ grep -ar 'Tests failed' /var/lib/mock/{fc,el}*/build.log
diff --git a/php-7.4.20-argon2.patch b/php-7.4.20-argon2.patch
new file mode 100644
index 0000000..73a1452
--- /dev/null
+++ b/php-7.4.20-argon2.patch
@@ -0,0 +1,15 @@
+diff --git a/ext/sodium/sodium_pwhash.c b/ext/sodium/sodium_pwhash.c
+index 2b284c7116..4a453255e2 100644
+--- a/ext/sodium/sodium_pwhash.c
++++ b/ext/sodium/sodium_pwhash.c
+@@ -64,10 +64,6 @@ static inline int get_options(zend_array *options, size_t *memlimit, size_t *ops
+ return FAILURE;
+ }
+ }
+- if ((opt = zend_hash_str_find(options, "threads", strlen("threads"))) && (zval_get_long(opt) != 1)) {
+- php_error_docref(NULL, E_WARNING, "A thread value other than 1 is not supported by this implementation");
+- return FAILURE;
+- }
+ return SUCCESS;
+ }
+
diff --git a/php74.spec b/php74.spec
index 4a01f41..0f65d8b 100644
--- a/php74.spec
+++ b/php74.spec
@@ -90,8 +90,8 @@
%global with_libzip 1
%global with_zip 0
-%global upver 7.4.20
-#global rcver RC1
+%global upver 7.4.21
+%global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: php
@@ -144,6 +144,8 @@ Patch42: php-7.3.3-systzdata-v18.patch
Patch43: php-7.4.0-phpize.patch
# Use -lldap_r for OpenLDAP
Patch45: php-7.4.0-ldap_r.patch
+# Ignore unsupported "threads" option on password_hash
+Patch46: php-7.4.20-argon2.patch
# drop "Configure command" from phpinfo output
# and add build system and provider (from 8.0)
Patch47: php-7.4.8-phpinfo.patch
@@ -1143,6 +1145,7 @@ in pure PHP.
%endif
%patch43 -p1 -b .headers
%patch45 -p1 -b .ldap_r
+%patch46 -p1 -b .argon2
%patch47 -p1 -b .phpinfo
%patch91 -p1 -b .remi-oci8
@@ -2159,6 +2162,10 @@ fi
%changelog
+* Wed Jun 16 2021 Remi Collet <remi@remirepo.net> - 7.4.21~RC1-1
+- update to 7.4.21RC1
+- ignore unsupported "threads" option on password_hash
+
* Wed Jun 2 2021 Remi Collet <remi@remirepo.net> - 7.4.20-1
- Update to 7.4.20 - http://www.php.net/releases/7_4_20.php